Announcement

Collapse
No announcement yet.

Can't run phoronix on fedora VM

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    type:

    which php5

    to see if you have php5 available
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #12
      Originally posted by learn View Post
      problem is I don't think Php-cli is installed yet just as php5-qtk.

      This is what I can't get around.

      Please how will this work in fedora I believe it uses yum instead of cvs.

      $cvs -d pserver:cvsread@cvs.php.net:/repository login
      $ cvs -d pserver:cvsread@cvs.php.net:/repository co -r PHP_5_2 php-src
      When I use Which Php
      I get /usr/bin/php

      can I conclude that php cli is install?

      Comment


      • #13
        Yep, just run an aforementioned command to run PTS from the CLI or run phoronix-test-suite system-info or something similar.
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #14
          Originally posted by Michael View Post
          Yep, just run an aforementioned command to run PTS from the CLI or run phoronix-test-suite system-info or something similar.
          I run phoronix-test-suite benchmark encode-ogg and got this


          libtool: install: warning: relinking `libvorbisfile.la'
          libtool: install: warning: relinking `libvorbisenc.la'
          configure: WARNING: libcurl missing
          configure: WARNING: libao missing
          configure: WARNING: libFLAC missing
          configure: WARNING: libOggFLAC missing
          configure: WARNING: libFLAC headers missing
          configure: WARNING: libspeex missing
          configure: WARNING: libspeex headers missing
          configure: WARNING: FLAC and/or OggFLAC libraries or headers missing, oggenc
          will NOT be built with FLAC read support.
          configure: WARNING: Prerequisites for ogg123 not met, ogg123 will be skipped.
          Please ensure that you have POSIX threads, libao, and (optionally) libcurl
          libraries and headers present if you would like to build ogg123.
          oggenc.c: In function ‘parse_options’:
          oggenc.c:775: warning: comparison with string literal results in unspecified behavior
          resample.c: In function ‘res_init’:
          resample.c:177: warning: comparison with string literal results in unspecified behavior
          /root/.phoronix-test-suite/installed-tests/encode-ogg/vorbis/include/vorbis/vorbisfile.h:56: warning: ‘OV_CALLBACKS_DEFAULT’ defined but not used
          /root/.phoronix-test-suite/installed-tests/encode-ogg/vorbis/include/vorbis/vorbisfile.h:63: warning: ‘OV_CALLBACKS_NOCLOSE’ defined but not used
          /root/.phoronix-test-suite/installed-tests/encode-ogg/vorbis/include/vorbis/vorbisfile.h:70: warning: ‘OV_CALLBACKS_STREAMONLY’ defined but not used
          /root/.phoronix-test-suite/installed-tests/encode-ogg/vorbis/include/vorbis/vorbisfile.h:77: warning: ‘OV_CALLBACKS_STREAMONLY_NOCLOSE’ defined but not used

          what could have happen, I really was enjoying this

          At the end I uploaded the results and had a graph with 52.12

          http://global.phoronix-test-suite.co...046-9398-27526

          can tell me whats going on Please I desperately needed to understand this tool.
          thx

          Comment


          • #15
            Those are just code warnings produced when you compile something.... LAME has some warnings and what not, but as you can see, it built.

            So the Phoronix Test Suite is working.

            BTW, you probably should upgrade the Phoronix Test Suite, 1.8.1 is rather old.
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #16
              Originally posted by Michael View Post
              Those are just code warnings produced when you compile something.... LAME has some warnings and what not, but as you can see, it built.

              So the Phoronix Test Suite is working.

              BTW, you probably should upgrade the Phoronix Test Suite, 1.8.1 is rather old.
              I got this version through the gnome package manager , whats the latest and how do I upgrade this.

              1. I was'nt able to install my php gtk for GUI, the instructions were of ubuntu rathar then fedora deos it make any diffirence.

              2. I also wish to test HDD, Cpu and other system parts individually can I do that

              Comment


              • #17
                Originally posted by learn View Post
                I got this version through the gnome package manager , whats the latest and how do I upgrade this.

                1. I was'nt able to install my php gtk for GUI, the instructions were of ubuntu rathar then fedora deos it make any diffirence.

                2. I also wish to test HDD, Cpu and other system parts individually can I do that
                All these questions are pretty self explanatory if you read the documentation that comes with the Phoronix Test Suite and/or some searching of these forums.
                Michael Larabel
                http://www.michaellarabel.com/

                Comment


                • #18
                  Originally posted by learn View Post
                  I got this version through the gnome package manager , whats the latest and how do I upgrade this.

                  1. I was'nt able to install my php gtk for GUI, the instructions were of ubuntu rathar then fedora deos it make any diffirence.

                  2. I also wish to test HDD, Cpu and other system parts individually can I do that
                  Oh did not spot the upgrade link thx. can you share some light on #2?

                  pls.

                  Comment


                  • #19
                    Originally posted by learn View Post
                    Oh did not spot the upgrade link thx. can you share some light on #2?

                    pls.
                    pls ignore the latter msg I still need help as said in the former.

                    thx

                    Comment


                    • #20
                      Originally posted by learn View Post
                      Oh did not spot the upgrade link thx. can you share some light on #2?

                      pls.
                      If you will just read the documentation and/or look around at all you will find that there are more than 120 test profiles for the Phoronix Test Suite that cover just about any subsystem or key area of interest.
                      Michael Larabel
                      http://www.michaellarabel.com/

                      Comment

                      Working...
                      X