Announcement

Collapse
No announcement yet.

PTS not working in Ubuntu 9.04

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PTS not working in Ubuntu 9.04

    Ok I installed PTS and Ubunty 9.04 just for some reviewing that you will know about later..

    I have tested PTS and still testing in Mandriva and its working like chram. However since 2.0 debuts with ubuntu notification support I thought of giving it a try..

    When I try to initiate PTS it didn't start and when I try to open GUI from CLI I get this error

    Code:
    shashwat@shashwat-desktop:~$ phoronix-test-suite gui
    
    Fatal error: Class 'GtkWindow' not found in /usr/share/phoronix-test-suite/pts-core/objects/gtk/pts_gtk_window.php on line 23
    shashwat@shashwat-desktop:~$
    How can I fix it / I installed it using the deb provide at PTS download section..

    Regards

  • #2
    Ubuntu doesn't have php5-gtk. If you're on x86_64 you can use: http://phoronix-test-suite.com/misc/....1-0_amd64.deb
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Sorry for the incomplete details. I am using 64bit Jaunty .

      I installed that deb but still its not loading

      Edit : Please help me . I really want to see that notification thng and cover it. Will get PTS Live in few days
      Last edited by Dark_Star; 09-27-2009, 01:14 PM.

      Comment


      • #4
        Oh yeah, add: extension=php_gtk.so I believe is the line to /etc/php5/php.ini... Just search the forums and you will find the instructions a few times.
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          Can't find it

          Comment


          • #6
            Bump.. Someone please help.

            Comment


            • #7
              . Someone please help.

              Comment


              • #8
                On debian it's here /etc/php5/cli/php.ini. If you can't find it post the output of

                find /etc -name php.ini

                here.

                Comment


                • #9
                  shashwat@shashwat-desktop:~$ /etc -name php.ini
                  bash: /etc: is a directory
                  I have the file in the first command ! Now how do I fix it ?

                  Comment


                  • #10
                    Originally posted by Dark_Star View Post
                    I have the file in the first command ! Now how do I fix it ?
                    He He the word "find" is part of the command!

                    >find /etc -name php.ini

                    But it seems the file is located at the same place as in debian here. Open the file with an editor and add the line michael mentioned. Or type
                    Code:
                    sudo echo -e "\nextension=php_gtk.so" >> /etc/php5/cli/php.ini

                    Comment


                    • #11
                      I still have the same problem after adding that line to php.ini and installing the .deb. Any other steps that I might be missing? Thanks!

                      Comment


                      • #12
                        I've fixed it by renaming (copying really) the library in /usr/lib/php5/20060613
                        from php_gtk2.so to php_gtk.so . Now it works. Thanks.

                        Comment


                        • #13
                          ^^Yes its working now Thanks a million guys

                          Ohh and is it only for Ubuntu 64bit ? or for mdv 64bit as well ?

                          Comment


                          • #14
                            Am I missing something or the PTS is not responding through Ubuntu notification ?

                            Is that aimed for 2.2 ?

                            Comment

                            Working...
                            X