Announcement

Collapse
No announcement yet.

Doesn't work in FreeBSD

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Doesn't work in FreeBSD

    I installed the test suite in FreeBSD 7.2 but can't get the executable to run (everything as root):

    Code:
    # ./install-sh
    Code:
    Phoronix Test Suite Installation Completed
    
    Executable File: /usr/bin/phoronix-test-suite
    Documentation: /usr/share/doc/phoronix-test-suite/
    Phoronix Test Suite Files: /usr/share/phoronix-test-suite/

    In /usr/bin:
    Code:
    ./phoronix-test-suite
    just returns:

    Code:
    To run the Phoronix Test Suite locally you must first change directories to phoronix-test-suite/                                                                                  
    or install the program using the install-sh script. For support visit: http://www.phoronix-test-suite.com/
    Tried rehash and then running: 'phoronix-test-suite' from the command line prompt but get the same message.

    The script is definitely here: /usr/bin/phoronix-test-suite but it won't run.

    Also, can't use the GUI because PHP-GTK is a broken port - not compatible with PHP5.

    Any idea what's wrong?

    ...Jeff

  • #2
    Can you post the contents of your /usr/bin/phoronix-test-suite script? It shouldn't be too long.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Here it is. Some commands don't look like FreeBSD to me. Maybe this is just for Linux?

      ...Jeff
      =============================


      #!/bin/sh

      #
      # Phoronix Test Suite
      # URLs: http://www.phoronix.com, http://www.phoronix-test-suite.com/
      # Copyright (C) 2008 - 2009, Phoronix Media
      # Copyright (C) 2008 - 2009, Michael Larabel
      # phoronix-test-suite: The Phoronix Test Suite is an extensible open-source testing / benchmarking platform
      #
      # This program is free software; you can redistribute it and/or modify
      # it under the terms of the GNU General Public License as published by
      # the Free Software Foundation; either version 3 of the License, or
      # (at your option) any later version.
      #
      # This program is distributed in the hope that it will be useful,
      # but WITHOUT ANY WARRANTY; without even the implied warranty of
      # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
      # GNU General Public License for more details.
      #
      # You should have received a copy of the GNU General Public License
      # along with this program. If not, see <http://www.gnu.org/licenses/>.
      #

      # Full path to root directory of the actual Phoronix Test Suite code
      export PTS_DIR=/usr/share/phoronix-test-suite
      export PTS_MODE="CLIENT"

      if [ $PTS_DIR != `pwd` ]
      then
      cd $PTS_DIR
      fi

      # Determine PHP binary location
      if [ -x /usr/bin/php5 ] || [ -x /usr/local/bin/php5 ] || [ -x /usr/pkg/bin/php5 ]
      then
      export PHP_BIN="php5"
      elif [ -x /usr/bin/php ] || [ -x /usr/local/bin/php ] || [ -x /usr/pkg/bin/php ]
      then
      export PHP_BIN="php"
      elif [ -x /usr/php5/bin/php ]
      then
      export PHP_BIN="/usr/php5/bin/php"
      elif [ -x /usr/php/bin/php ]
      then
      export PHP_BIN="/usr/php/bin/php"
      else
      export PHP_BIN=""
      fi

      # Make sure PHP is installed
      if [ "X$PHP_BIN" = "X" ]
      then
      cat <<'EOT'

      PHP 5.x CLI Must Be Installed To Run The Phoronix Test Suite.
      Only PHP For The Command Line Is Needed, Not A Complete PHP Web Server Installation.
      The PHP CLI package is generally called php-cli or php5-cli.
      For more information visit: http://www.phoronix-test-suite.com/

      EOT
      exit
      fi

      # Ensure the user is in the correct directory
      if [ ! -f pts-core/phoronix-test-suite.php ]
      then
      cat <<'EOT'

      To run the Phoronix Test Suite locally you must first change directories to phoronix-test-suite/
      or install the program using the install-sh script. For support visit: http://www.phoronix-test-suite.com/

      EOT
      exit
      fi

      # Command-specific conditions
      case "$1" in
      "test-module" | "debug-module")
      export PTS_IGNORE_MODULES=1
      ;;
      esac

      # Run The Phoronix Test Suite
      $PHP_BIN pts-core/phoronix-test-suite.php $@

      Comment


      • #4
        What happens if you:

        cd /usr/share/phoronix-test-suite/
        ./usr/bin/phoronix-test-suite system-info

        or something like that? Or when you download PTS and extract it and before running install-sh, but just run: ./phoronix-test-suite from within the directory?
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          Just says command not found.

          Nothing works. I think it's because it's designed for Linux.

          You should get someone to make a FreeBSD port of this so more people can use it. You're missing a large community by not supporting BSD directly.

          Sorry I just don't have the skills and time to get this working now.

          Tnx, Jeff

          Comment


          • #6
            What version are you using? I have ran the Phoronix Test Suite (1.6, 1.8, and early 2.0 snapshots) on FreeBSD, PC-BSD, NetBSD, etc... It runs on BSD. I wrote in the BSD support. Either you have hit some PTS bug or have some odd system configuration or something like that or there is a regression.
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              Using PCBSD 7.1 (FreeBSD 7.2)

              A port is the easiest way to get people to use an app on FreeBSD.

              Comment


              • #8
                Originally posted by dejamuse View Post
                Using PCBSD 7.1 (FreeBSD 7.2)

                A port is the easiest way to get people to use an app on FreeBSD.
                I can get the phoronix-test-suite to launch and right now I'm going through installing each test because of a lack of xdg-screensaver(?) won't let me install the entire thing at once.

                That said, /usr/share/phoroni... will not work and returns the message above about running locally and such. I should also mention that the mirrors for the necessary files have never worked for me, ever.

                Comment


                • #9
                  Originally posted by pcfxer View Post
                  I should also mention that the mirrors for the necessary files have never worked for me, ever.
                  Try using a different DNS server. I don't think you can blame PTS for not being able to reach mirrors that the rest of us can.

                  Comment


                  • #10
                    Originally posted by deanjo View Post
                    Try using a different DNS server. I don't think you can blame PTS for not being able to reach mirrors that the rest of us can.
                    Okay, I shall try it out. I use OpenDNS.org so I assumed that things would be fine.

                    Comment


                    • #11
                      Oddly enough, all I did when I got home was try ./PTS install bsd and the suite started downloading successfully without any DNS change or the other. Most of the bsd suite was installed, but I am having an issue with crafty (stemming from me not being able to find numa for FreeBSD).

                      Code:
                      Hmm...  Looks like a unified diff to me...
                      The text leading up to this was:          
                      --------------------------                
                      |diff -Naur crafty-23.0.orig/Makefile crafty-23.0/Makefile
                      |--- crafty-23.0.orig/Makefile  2009-03-24 14:52:20.000000000 -0400
                      |+++ crafty-23.0/Makefile       2009-05-04 21:56:50.000000000 -0400
                      --------------------------                                         
                      Patching file crafty-23.0/Makefile using Plan A...                 
                      Hunk #1 succeeded at 150.                                          
                      Hunk #2 succeeded at 160.                                          
                      done                                                               
                      "Makefile", line 386: Need an operator                             
                      make: fatal errors encountered -- cannot continue                  
                      Archive:  crafty-23.0.zip                                          
                        inflating: crafty-23.0/analyze.c                                 
                        inflating: crafty-23.0/annotate.c                                
                        inflating: crafty-23.0/attacks.c                                 
                        inflating: crafty-23.0/bench.c                                   
                        inflating: crafty-23.0/book.c                                    
                        inflating: crafty-23.0/boolean.c                                 
                        inflating: crafty-23.0/crafty.c                                  
                        inflating: crafty-23.0/data.c                                    
                        inflating: crafty-23.0/drawn.c                                   
                        inflating: crafty-23.0/edit.c                                    
                        inflating: crafty-23.0/epd.c                                     
                        inflating: crafty-23.0/epdglue.c                                 
                        inflating: crafty-23.0/evaluate.c                                
                        inflating: crafty-23.0/evtest.c                                  
                        inflating: crafty-23.0/hash.c                                    
                        inflating: crafty-23.0/init.c                                    
                        inflating: crafty-23.0/input.c                                   
                        inflating: crafty-23.0/interupt.c                                
                        inflating: crafty-23.0/iterate.c                                 
                        inflating: crafty-23.0/killer.c                                  
                        inflating: crafty-23.0/learn.c                                   
                        inflating: crafty-23.0/main.c                                    
                        inflating: crafty-23.0/make.c                                    
                        inflating: crafty-23.0/movgen.c                                  
                        inflating: crafty-23.0/next.c                                    
                        inflating: crafty-23.0/option.c                                  
                        inflating: crafty-23.0/output.c                                  
                        inflating: crafty-23.0/ponder.c                                  
                        inflating: crafty-23.0/preeval.c                                 
                        inflating: crafty-23.0/probe.c                                   
                        inflating: crafty-23.0/quiesce.c                                 
                        inflating: crafty-23.0/repeat.c                                  
                        inflating: crafty-23.0/resign.c
                        inflating: crafty-23.0/root.c
                        inflating: crafty-23.0/search.c
                        inflating: crafty-23.0/setboard.c
                        inflating: crafty-23.0/swap.c
                        inflating: crafty-23.0/test.c
                        inflating: crafty-23.0/thread.c
                        inflating: crafty-23.0/time.c
                        inflating: crafty-23.0/unmake.c
                        inflating: crafty-23.0/utility.c
                        inflating: crafty-23.0/validate.c
                        inflating: crafty-23.0/chess.h
                        inflating: crafty-23.0/data.h
                        inflating: crafty-23.0/epddefs.h
                        inflating: crafty-23.0/epdglue.h
                        inflating: crafty-23.0/epd.h
                        inflating: crafty-23.0/inline32.h
                        inflating: crafty-23.0/inline64.h
                        inflating: crafty-23.0/lock.h
                        inflating: crafty-23.0/tbdecode.h
                        inflating: crafty-23.0/vcinline.h
                        inflating: crafty-23.0/egtb.cpp
                        inflating: crafty-23.0/crafty.hlp
                        inflating: crafty-23.0/speak
                        inflating: crafty-23.0/Makefile
                        inflating: crafty-23.0/Makefile.xp
                      
                      The crafty installer exited with a non-zero exit status. Installation failed.
                      This is the closest that I've been to installing PTS on BSD so far .

                      Here is my pkg_info output:

                      Code:
                      # pkg_info
                      autoconf-2.62       Automatically configure source code on many Un*x platforms
                      autoconf-wrapper-20071109 Wrapper script for GNU autoconf
                      geekbench-2.0.15    Cross-platform benchmark suite
                      gettext-0.17_1      GNU gettext package
                      gmake-3.81_3        GNU version of 'make' utility
                      help2man-1.36.4_3   Automatically generating simple manual pages from program o
                      libiconv-1.13.1     A character set conversion library
                      libtool-2.2.6a      Generic shared library support script
                      libxml2-2.7.3       XML parser library for GNOME
                      m4-1.4.13,1         GNU m4
                      p5-gettext-1.05_2   Message handling functions
                      perl-5.8.9_3        Practical Extraction and Report Language
                      php5-5.2.10         PHP Scripting Language
                      pkg-config-0.23_1   A utility to retrieve information about installed libraries
                      tcl-8.6.b.1_4       Tool Command Language
                      tcl-modules-8.5.7   Tcl common modules
                      ubench-0.32         Unix Benchmark Utility for CPU(s) and memory
                      Help is appreciated!

                      Comment


                      • #12
                        Originally posted by pcfxer View Post
                        Oddly enough, all I did when I got home was try ./PTS install bsd and the suite started downloading successfully without any DNS change or the other. Most of the bsd suite was installed, but I am having an issue with crafty (stemming from me not being able to find numa for FreeBSD).

                        Code:
                        Hmm...  Looks like a unified diff to me...
                        The text leading up to this was:          
                        --------------------------                
                        |diff -Naur crafty-23.0.orig/Makefile crafty-23.0/Makefile
                        |--- crafty-23.0.orig/Makefile  2009-03-24 14:52:20.000000000 -0400
                        |+++ crafty-23.0/Makefile       2009-05-04 21:56:50.000000000 -0400
                        --------------------------                                         
                        Patching file crafty-23.0/Makefile using Plan A...                 
                        Hunk #1 succeeded at 150.                                          
                        Hunk #2 succeeded at 160.                                          
                        done                                                               
                        "Makefile", line 386: Need an operator                             
                        make: fatal errors encountered -- cannot continue                  
                        Archive:  crafty-23.0.zip                                          
                          inflating: crafty-23.0/analyze.c                                 
                          inflating: crafty-23.0/annotate.c                                
                          inflating: crafty-23.0/attacks.c                                 
                          inflating: crafty-23.0/bench.c                                   
                          inflating: crafty-23.0/book.c                                    
                          inflating: crafty-23.0/boolean.c                                 
                          inflating: crafty-23.0/crafty.c                                  
                          inflating: crafty-23.0/data.c                                    
                          inflating: crafty-23.0/drawn.c                                   
                          inflating: crafty-23.0/edit.c                                    
                          inflating: crafty-23.0/epd.c                                     
                          inflating: crafty-23.0/epdglue.c                                 
                          inflating: crafty-23.0/evaluate.c                                
                          inflating: crafty-23.0/evtest.c                                  
                          inflating: crafty-23.0/hash.c                                    
                          inflating: crafty-23.0/init.c                                    
                          inflating: crafty-23.0/input.c                                   
                          inflating: crafty-23.0/interupt.c                                
                          inflating: crafty-23.0/iterate.c                                 
                          inflating: crafty-23.0/killer.c                                  
                          inflating: crafty-23.0/learn.c                                   
                          inflating: crafty-23.0/main.c                                    
                          inflating: crafty-23.0/make.c                                    
                          inflating: crafty-23.0/movgen.c                                  
                          inflating: crafty-23.0/next.c                                    
                          inflating: crafty-23.0/option.c                                  
                          inflating: crafty-23.0/output.c                                  
                          inflating: crafty-23.0/ponder.c                                  
                          inflating: crafty-23.0/preeval.c                                 
                          inflating: crafty-23.0/probe.c                                   
                          inflating: crafty-23.0/quiesce.c                                 
                          inflating: crafty-23.0/repeat.c                                  
                          inflating: crafty-23.0/resign.c
                          inflating: crafty-23.0/root.c
                          inflating: crafty-23.0/search.c
                          inflating: crafty-23.0/setboard.c
                          inflating: crafty-23.0/swap.c
                          inflating: crafty-23.0/test.c
                          inflating: crafty-23.0/thread.c
                          inflating: crafty-23.0/time.c
                          inflating: crafty-23.0/unmake.c
                          inflating: crafty-23.0/utility.c
                          inflating: crafty-23.0/validate.c
                          inflating: crafty-23.0/chess.h
                          inflating: crafty-23.0/data.h
                          inflating: crafty-23.0/epddefs.h
                          inflating: crafty-23.0/epdglue.h
                          inflating: crafty-23.0/epd.h
                          inflating: crafty-23.0/inline32.h
                          inflating: crafty-23.0/inline64.h
                          inflating: crafty-23.0/lock.h
                          inflating: crafty-23.0/tbdecode.h
                          inflating: crafty-23.0/vcinline.h
                          inflating: crafty-23.0/egtb.cpp
                          inflating: crafty-23.0/crafty.hlp
                          inflating: crafty-23.0/speak
                          inflating: crafty-23.0/Makefile
                          inflating: crafty-23.0/Makefile.xp
                        
                        The crafty installer exited with a non-zero exit status. Installation failed.
                        This is the closest that I've been to installing PTS on BSD so far .

                        Here is my pkg_info output:

                        Code:
                        # pkg_info
                        autoconf-2.62       Automatically configure source code on many Un*x platforms
                        autoconf-wrapper-20071109 Wrapper script for GNU autoconf
                        geekbench-2.0.15    Cross-platform benchmark suite
                        gettext-0.17_1      GNU gettext package
                        gmake-3.81_3        GNU version of 'make' utility
                        help2man-1.36.4_3   Automatically generating simple manual pages from program o
                        libiconv-1.13.1     A character set conversion library
                        libtool-2.2.6a      Generic shared library support script
                        libxml2-2.7.3       XML parser library for GNOME
                        m4-1.4.13,1         GNU m4
                        p5-gettext-1.05_2   Message handling functions
                        perl-5.8.9_3        Practical Extraction and Report Language
                        php5-5.2.10         PHP Scripting Language
                        pkg-config-0.23_1   A utility to retrieve information about installed libraries
                        tcl-8.6.b.1_4       Tool Command Language
                        tcl-modules-8.5.7   Tcl common modules
                        ubench-0.32         Unix Benchmark Utility for CPU(s) and memory
                        Help is appreciated!
                        Anyone? I'd like to have a new OS installed and further testing completed by today but I've been waiting for PTS to get up and running.

                        Code:
                        The MD5 check-sum of the downloaded file is incorrect.
                        Failed URL: http://internode.dl.sourceforge.net/sourceforge/imagemagick/ImageMagick-6.5.0-6.tar.bz2
                        
                        Download of Needed Test Dependencies Failed! Exiting.
                        
                        
                        Installation of build-imagemagick test failed.
                        
                        /*** MD5s for ImagMagick don't match ***/
                        
                        /*** and as you can see when installing sqlite the script wants tcl directory to be specified, though, I do have tcl installed as per pkg_info. ***/
                        
                        x sqlite-3.6.13/publish.sh
                        tclsh: not found
                        tclsh: not found
                        configure: WARNING: Can't find Tcl configuration definitions
                        configure: WARNING: *** Without Tcl the regression tests cannot be executed ***
                        configure: WARNING: *** Consider using --with-tcl=... to define location of Tcl ***
                        TIA

                        Comment

                        Working...
                        X