Announcement

Collapse
No announcement yet.

Bug with Super-pi from Phoronix 1.8.1 64 bit version

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug with Super-pi from Phoronix 1.8.1 64 bit version

    Running F10 64 bit
    I get the following error when attempting the super-pi benchmark:

    ***
    ./super_pi: ./pi: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory
    ***



    phoronix-test-suite dignostics result:

    ====================================
    Phoronix Test Suite v1.8.1 (SELBU)
    Diagnostics Dump
    ====================================

    PTS_PATH = /usr/share/phoronix-test-suite/
    PTS_MODE = CLIENT
    PTS_LIBRARY_PATH = /usr/share/phoronix-test-suite/pts-core/library/
    PTS_VERSION = 1.8.1
    PTS_CODENAME = SELBU
    DEFAULT_VIDEO_RAM_CAPACITY = 128
    PTS_MODULE_UNLOAD = PTS_MODULE_UNLOAD
    PTS_QUIT = PTS_QUIT
    PTS_CORE_PATH = /usr/share/phoronix-test-suite/pts-core/
    PTS_USER_DIR = /root/.phoronix-test-suite/
    XML_DISTRO_DIR = /usr/share/phoronix-test-suite/pts/distro-xml/
    SCRIPT_DISTRO_DIR = /usr/share/phoronix-test-suite/pts/distro-scripts/
    ETC_DIR = /usr/share/phoronix-test-suite/pts/etc/
    MODULE_DIR = /usr/share/phoronix-test-suite/pts-core/modules/
    MODULE_LOCAL_DIR = /root/.phoronix-test-suite/modules/
    RESULTS_VIEWER_DIR = /usr/share/phoronix-test-suite/pts-core/results-viewer/
    TEST_LIBRARIES_DIR = /usr/share/phoronix-test-suite/pts-core/test-libraries/
    STATIC_DIR = /usr/share/phoronix-test-suite/pts-core/static/
    MEDIA_DIR = /usr/share/phoronix-test-suite/pts-core/media/
    FONT_DIR = /usr/share/phoronix-test-suite/pts-core/results-viewer/fonts/
    XML_PROFILE_DIR = /usr/share/phoronix-test-suite/pts/test-profiles/
    XML_PROFILE_CTP_BASE_DIR = /usr/share/phoronix-test-suite/pts/base-test-profiles/
    XML_SUITE_DIR = /usr/share/phoronix-test-suite/pts/test-suites/
    TEST_RESOURCE_DIR = /usr/share/phoronix-test-suite/pts/test-resources/
    TEST_RESOURCE_CTP_BASE_DIR = /usr/share/phoronix-test-suite/pts/base-test-resources/
    XML_PROFILE_LOCAL_DIR = /root/.phoronix-test-suite/test-profiles/
    XML_SUITE_LOCAL_DIR = /root/.phoronix-test-suite/test-suites/
    TEST_RESOURCE_LOCAL_DIR = /root/.phoronix-test-suite/test-resources/
    PTS_TEMP_DIR = /tmp/phoronix-test-suite/
    PHP_BIN = php
    PTS_INIT_TIME = 1241567746
    OPERATING_SYSTEM = Linux
    OS_PREFIX = linux_
    TEST_ENV_DIR = /root/.phoronix-test-suite/installed-tests/
    SAVE_RESULTS_DIR = /root/.phoronix-test-suite/test-results/
    PTS_DOWNLOAD_CACHE_DIR = /root/.phoronix-test-suite/download-cache/
    PTS_USER_LOCK = /root/.phoronix-test-suite/run_lock
    PTS_STARTUP_TASK_PERFORMED = 1
    PTS_USER_AGREEMENT_CHECK = b9292f976d899bfda7f6e9225f6b013a

    End-User Run-Time Variables:
    VIDEO_RESOLUTION = 1680x1050
    VIDEO_CARD = nVidia GeForce 8800 GT (rev a2)
    VIDEO_DRIVER = 2.1 Mesa 7.3-devel
    OPERATING_SYSTEM = Fedora release 10 (Cambridge)
    PROCESSOR = Intel Core 2 Duo CPU E8400 @ 3.00GHz
    MOTHERBOARD = ASUSTeK P5N-E SLI
    CHIPSET = nVidia C55
    KERNEL_VERSION = 2.6.27.21-170.2.56.fc10.x86_64
    COMPILER = GCC 4.3.2
    HOSTNAME = Thor

    Environmental Variables (accessible via test scripts):
    PTS_VERSION = 1.8.1
    PTS_CODENAME = SELBU
    PTS_DIR = /usr/share/phoronix-test-suite/
    PHP_BIN = php
    NUM_CPU_CORES = 2
    NUM_CPU_JOBS = 4
    SYS_MEMORY = 3964
    VIDEO_MEMORY = 128
    VIDEO_WIDTH = 1680
    VIDEO_HEIGHT = 1050
    VIDEO_MONITOR_COUNT = 1
    VIDEO_MONITOR_LAYOUT = CENTER
    VIDEO_MONITOR_SIZES = 1680x1050
    OPERATING_SYSTEM = fedora
    OS_VERSION = Unknown
    OS_ARCH = x86_64
    OS_TYPE = Linux
    THIS_RUN_TIME = 1241567746

  • #2
    It looks like a bug with super-pi itself. Sadly, super-pi is closed-source so not much can be done.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Re: Super-pi

      Originally posted by Michael View Post
      It looks like a bug with super-pi itself. Sadly, super-pi is closed-source so not much can be done.
      It worked just fine with 1.8.0 Michael. Same system, same hardware, same version and 64 bit OS.

      Comment


      • #4
        Originally posted by Jaguar07 View Post
        It worked just fine with 1.8.0 Michael. Same system, same hardware, same version and 64 bit OS.
        Are you sure? Nothing with that test profile had changed between those releases and nothing with pts-core would touch super-pi. The error (./super_pi: ./pi: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory) shows it originating with the test binary itself.
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          Sure, Absolutely certain

          Originally posted by Michael View Post
          Are you sure? Nothing with that test profile had changed between those releases and nothing with pts-core would touch super-pi. The error (./super_pi: ./pi: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory) shows it originating with the test binary itself.
          Yeah I'm sure. I tested this same system with F10 64 bit using PG 1.8.0, It's in the Database as ECC-Voyager-E8400 with my Username. I may have an Elf interpreter issue on this build of the OS though. I recently re-OSed this partition from the latest F10 updates. Then installed 1.8.1 clean. Here's the Link for the same system running the 1.8.0 version and the results.

          http://global.phoronix-test-suite.co...700-1285-25080
          Last edited by Jaguar07; 05-05-2009, 08:11 PM.

          Comment


          • #6
            Originally posted by Jaguar07 View Post
            Yeah I'm sure. I tested this same system with F10 64 bit using PG 1.8.0, It's in the Database as ECC-Voyager-E8400 with my Username. I may have an Elf interpreter issue on this build of the OS though. I recently re-OSed this partition from the latest F10 updates. Then installed 1.8.1 clean. Here's the Link for the same system running the 1.8.0 version and the results.

            http://global.phoronix-test-suite.co...700-1285-25080
            Do you have you 32-bit compatibility libraries installed as well?

            Comment


            • #7
              Originally posted by deanjo View Post
              Do you have you 32-bit compatibility libraries installed as well?
              No I do not have 32 bit Libraries installed at all. I am not certain I did or did not on the previous build of the system.

              Comment


              • #8
                Originally posted by Jaguar07 View Post
                No I do not have 32 bit Libraries installed at all. I am not certain I did or did not on the previous build of the system.
                Seeing that super-pi is a 32-bit app I would bet that is what it is. I often see those ELF interpreter errors when I forget to install them and try to run a 32-binary in openSUSE 64.

                Comment


                • #9
                  Unfortunately super-pi is sort of closed source, even license is somewhat mystery. Anyway should work on 64-bit environment if 32-bits compat libs are installed.

                  Itself its 32bit binary...

                  Comment


                  • #10
                    32 Bit Bits

                    Originally posted by ppanula View Post
                    Unfortunately super-pi is sort of closed source, even license is somewhat mystery. Anyway should work on 64-bit environment if 32-bits compat libs are installed.

                    Itself its 32bit binary...
                    Ok. I'll install the 32 bit bits and see if that will fix this issue. Thanks everyone!

                    Comment

                    Working...
                    X