Announcement

Collapse
No announcement yet.

Prey benchmark problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Prey benchmark problem

    Hello,

    I've tried the prey benchmark, installing game files and key like for doom3, but it wasn't ok. I had to copy the demo folder in my home .prey/base. Then, the demo starts and runs, but 0 fps for result.

    I think there's a path problem, but I didn't find how to fix it. I did manage to run timedemo in prey console, and fps result appears.

    Any idea to fix it please?

  • #2
    Hmm I've ran into a problem with the Prey key not working when it's been copied, but beyond that I haven't encountered your problem where when the test runs it shows zero FPS. Does it run three times and all? Can you paste what's printed to the standard output?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Yes, after I copied demos and key in my home folder, it runs normally. But pts gives zero:

      Code:
      ====================================
      Prey (Run 1 of 3)
      ====================================
      
      
      ====================================
      Prey (Run 2 of 3)
      ====================================
      
      
      ====================================
      Prey (Run 3 of 3)
      ====================================
      
      
      ####################################
      Prey:
      1024 x 768
      
      
      Average: 0.00 Frames Per Second
      ####################################

      Then, if I run the command with arguments in a terminal, a line display:
      2555 frames rendered in 26.7 seconds = 95.7 fps

      Tested on Ubuntu 8.04 and Debian Lenny, where all other tests are ok.

      Comment


      • #4
        Originally posted by RenZO View Post
        Yes, after I copied demos and key in my home folder, it runs normally. But pts gives zero:

        Code:
        ====================================
        Prey (Run 1 of 3)
        ====================================
        
        
        ====================================
        Prey (Run 2 of 3)
        ====================================
        
        
        ====================================
        Prey (Run 3 of 3)
        ====================================
        
        
        ####################################
        Prey:
        1024 x 768
        
        
        Average: 0.00 Frames Per Second
        ####################################
        Then, if I run the command with arguments in a terminal, a line display:
        2555 frames rendered in 26.7 seconds = 95.7 fps

        Tested on Ubuntu 8.04 and Debian Lenny, where all other tests are ok.

        Ya the same thing happens in other distro's as well.

        Comment


        • #5
          Any idea to solve this problem please?
          Which files could we edit? I wonder how to debug pts...

          Comment


          • #6
            Well, I have found a bug itself with Prey... It seems to not pay attention to the $HOME environmental variable. PTS overrides HOME to ~/.phoronix-test-suite/installed-tests/prey/ but Prey is still using ~/.prey/ which is causing problems with the Prey key and copying of the demo file. But once I copied the demo and key to that location, it worked and recorded the results.

            http://global.phoronix-test-suite.co...68-31031-11568
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              I confirm that I had to copy files in home location, but still have 0.00 result, even with pts 1.8.0a2, ubuntu hardy.

              Comment


              • #8
                Can you run a : phoronix-test-suite force-install prey

                and try again?
                Michael Larabel
                http://www.michaellarabel.com/

                Comment


                • #9
                  Done, always the same.
                  If I go in prey-linux-x86 folder, open a terminal, ./prey.x86 +timedemoquit pts, it runs (in the last resolution choosen with pts), fps is shown: 2555 frames in 55 sec = 46,4 fps.

                  Comment


                  • #10
                    Hmmm. Is English not your main locale on your system (I notice the comma in your FPS). It might be the locales that could be messing up PTS. Locale problems are partially addressed in the latest Git code (Selbu Alpha 2 is too old) @ .tar.gz http://phorogit.com/index.php?p=phor...e.git&dl=targz
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment


                    • #11
                      Sorry, it displays 46.4 with dot, not comma.
                      I've tried in english session anyway, same problem.

                      Comment


                      • #12
                        I installed Ubuntu Intrepid on another machine, in english with english keyboard layout.
                        Same problem. FPS result is parsed from a log file, isn't it?

                        Comment


                        • #13
                          Originally posted by RenZO View Post
                          I installed Ubuntu Intrepid on another machine, in english with english keyboard layout.
                          Same problem. FPS result is parsed from a log file, isn't it?
                          Yes. To see the log file, ensure ~/.phoronix-test-suite/user-config.xml has SaveBenchmarkLogs to TRUE. Then when running Prey, make sure you save your results and run Prey. Then look in ~/.phoronix-test-suite/test-results/<whatever you named it> and then in a sub directory of that should be the log files.
                          Michael Larabel
                          http://www.michaellarabel.com/

                          Comment


                          • #14
                            Ok, I have the log files, but what I would like to know is:
                            How does pts parse the fps result? If I have this result when I use the terminal myself, why does pts miss it?

                            Comment


                            • #15
                              Can you upload the file somewhere so I can take a look?

                              The prey results are parsed via:

                              Code:
                              <?php
                              $log_file = file_get_contents(getenv("LOG_FILE"));
                              $BENCHMARK_RESULTS = substr($log_file, strrpos($log_file, "seconds =") + 9);
                              echo trim(substr($BENCHMARK_RESULTS, 0, strpos($BENCHMARK_RESULTS, "fps")));
                              ?>
                              Michael Larabel
                              http://www.michaellarabel.com/

                              Comment

                              Working...
                              X