Announcement

Collapse
No announcement yet.

Realtek rtl8192 wifi adapter problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by deanjo View Post
    There are far better wifi adapters out there with better compatibility. Intel and ralink for example.
    Ralink has not released Linux drivers for the few 80211ac chipsets that are being used in a handful of Wifi cards and adapters.

    And Atheros has also dropped support for all the v1 versions of their 80211ac chipsets, with the code already purged from upstream: http://lists.infradead.org/pipermail...ly/000021.html http://www.spinics.net/lists/linux-w...msg110852.html

    Comment


    • #12
      Originally posted by Sonadow View Post
      Ralink has not released Linux drivers for the few 80211ac chipsets that are being used in a handful of Wifi cards and adapters.
      They merged with Mediatek and they do have 80211ac support in linux for the MT7601u

      http://www.mediatek.com/_en/07_downl...ows.php?sn=501 (don't let the "windows" word in the link fool you).

      Comment


      • #13
        OK, guys I got realteks official driver to work. It seems retarded but it worked. I had to enable at least one other wifi driver in kernel in order for the kernel to build the required interfaces that realteks driver needed. I just enabled ipw2200 in kernel and now realteks driver is working. The rtl8192cu driver that is included in the kernel is still completely broken. But the official driver seems to be working well now.

        Comment


        • #14
          listen up friend, cause I had your hardware. There are two options.
          1. you blacklist the rtl8192 , go to realtek website and get and install official driver. Why, because the standard driver is a free driver with buggy firmware.
          2. you buy an atheros based card like Tplink TL-WN821N, it will pop due to open firmware.

          Ralink is garbage, newer esp 802.11n versions are closed blobs.
          Overall the unhealthy tendency is to ship firmware rather than anything open. I guess it's because of two things:
          1. Adherence to govt frequency standards with increased network speed.
          2. Simplifications of hardware layout with firmware being exactly the logic of hardware, so they don't want to unveil how their hardware works.

          I had rtl8192u, Ralink and now atheros based card. Atheros is the only one completely trouble free, I would buy or recommend only them, they are really awesome.


          Originally posted by Sonadow View Post
          There's always the option of Windows.

          I have gotten Windows 8.1 to work with XP drivers for various hardware, well after the manufacturer decided to end all support for the device. That's more than 10 years of binary compatibility you're talking about.

          Similarly have coaxed Win98 drivers to run in Vista, that's close to another 10 years of binary compatibility, and for a completely different kernel architecture (DOS to NT) to boot.
          You are lucky baseball bat doesn't work over TCPIP, you stupid microsoft mole.

          Comment


          • #15
            Yeah, I did get realteks official driver to work. I got it from here https://github.com/dz0ny/rt8192cu instead of realteks website though. This git repo has been patched to work with the newest kernels and has some patches to fix problems with 64bit compiles. The only thing is that you have to enable a different wifi driver in the kernel in order for the kernel to build with all the interfaces this driver needs. Even though I don't need it, I had to build ipw2200 in order to resolve that no wireless extensions thing that iwconfig had.

            Comment


            • #16
              Well, it seems I spoke too soon....

              This driver doesnt seem to support changing the bitrate or it's that something is missing so it can't. It's stuck a 300Mb/s but it really can't handle that bitrate at this distance.....

              Comment


              • #17
                Originally posted by duby229 View Post
                Well, it seems I spoke too soon....

                This driver doesnt seem to support changing the bitrate or it's that something is missing so it can't. It's stuck a 300Mb/s but it really can't handle that bitrate at this distance.....
                let me guess, you have a nano reciever? just get an atheros-based dongle with seperate antennae. Mine was capable of reaching the router 2 stocks higher in appartment across (yes, legally, we set it up inbefore)

                Comment


                • #18
                  Well, I think I'm gonna try ndiswrapper and see if I can get the windows driver to work. If that doesnt work then I am just gonna have to get a different adapter.

                  Comment


                  • #19
                    No luck on getting ndiswrapper to work. It won't work with this drivers inf file. It just spits out a bunch of error messages about it missing sections.

                    Comment


                    • #20
                      I just rebooted into my gentoo install today, to get some files that I needed, and the manufacturer driver seems to be working flawlessly now. I have no idea what changed between now and the last time I booted into this operating system, but it is definitely working correctly now.

                      I'm stumped but I'm not complaining.

                      Comment

                      Working...
                      X