Announcement

Collapse
No announcement yet.

Fighting with the accursed NetworkManager

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fighting with the accursed NetworkManager

    Not content with rewriting my /etc/hosts file so that my PCs FQDN is set to 127.0.0.1, it is also now setting the hostname to "localhost.localdomain". (This is with a wired eth0 port, for a PC that belongs to a local network connected to the Internet via a router.)

    Does anyone know how to configure NetworkManager so that it stops messing around with settings that are none of its business, please? Short of uninstalling the **** thing, of course, although that is starting to sound like a very good idea.

    Thanks,
    Chris

  • #2
    Originally posted by chrisr View Post
    Not content with rewriting my /etc/hosts file so that my PCs FQDN is set to 127.0.0.1, it is also now setting the hostname to "localhost.localdomain". (This is with a wired eth0 port, for a PC that belongs to a local network connected to the Internet via a router.)

    Does anyone know how to configure NetworkManager so that it stops messing around with settings that are none of its business, please? Short of uninstalling the **** thing, of course, although that is starting to sound like a very good idea.

    Thanks,
    Chris
    Check out wicd, well worth it. I like it alot better than NetworkManager

    Comment


    • #3
      edit: Heres a link to the sourceforge page.
      http://wicd.sourceforge.net/

      Comment


      • #4
        Originally posted by duby229 View Post
        Check out wicd, well worth it. I like it alot better than NetworkManager
        Seconded. I keep hearing networkmanager has improved since the days it was just broken, but here it doesn't work as cleanly as wicd. Maybe it's the KDE version that sucks (I still don't get the difference between plasma-netkwork-manager and kde-network-manager). For what is worth, now there's also wicd-qt (or something) which supposedly integrates better into KDE, but alas it doesn't work : D The regular version works fine everywhere.

        Comment


        • #5
          I also agree with the posts above...

          Originally posted by chrisr View Post
          Not content with rewriting my /etc/hosts file so that my PCs FQDN is set to 127.0.0.1, it is also now setting the hostname to "localhost.localdomain". (This is with a wired eth0 port, for a PC that belongs to a local network connected to the Internet via a router.)

          Does anyone know how to configure NetworkManager so that it stops messing around with settings that are none of its business, please? Short of uninstalling the **** thing, of course, although that is starting to sound like a very good idea.

          Thanks,
          Chris
          I also agree with the posts above. Wicd is simpler, more lightweight, and has muss less Gnome-ish dependencies than Network*Ubuntu*Manager (you just need to have python 2 and GTK libs installed in your system)... Furthermore, it also supports better some network protection schemes, such as WPA-Enterprise networks (I use it for my "eduroam" network in the university) and is very easy to configure as a system daemon, (so you can also auto-associate to your favorite networks if you want to do so, OC...).

          Cheers

          Comment


          • #6
            Network Manager does not control your hostname, btw. Not by default anyways.

            What sort of horror of a operating system are you using that does not have it correctly setup for you to use right off the bat?

            Comment


            • #7
              Oh really?

              Originally posted by drag View Post
              Network Manager does not control your hostname, yada yada
              I'm not going to argue with you. Please just go read the entry in RedHat's bugzilla:
              https://bugzilla.redhat.com/show_bug.cgi?id=648725

              Comment


              • #8
                Originally posted by evolution View Post
                I also agree with the posts above. Wicd is simpler, more lightweight, and has muss less Gnome-ish dependencies than Network*Ubuntu*Manager (you just need to have python 2 and GTK libs installed in your system)... Furthermore, it also supports better some network protection schemes, such as WPA-Enterprise networks (I use it for my "eduroam" network in the university) and is very easy to configure as a system daemon, (so you can also auto-associate to your favorite networks if you want to do so, OC...).

                Cheers
                I have wicd installed on ArchBang and it works flawlessly. Yes NetworkManager sucks and I prefer wicd as it puts me in control of my network connections and gets out of the way.

                Comment


                • #9
                  Originally posted by chrisr View Post
                  I'm not going to argue with you. Please just go read the entry in RedHat's bugzilla:
                  https://bugzilla.redhat.com/show_bug.cgi?id=648725
                  *shrug*

                  Redhat has always been goofy as hell for hostname stuff.

                  I guess it's not the default for Ubuntu/Debian.

                  Comment


                  • #10
                    Originally posted by DeepDayze View Post
                    I have wicd installed on ArchBang and it works flawlessly. Yes NetworkManager sucks and I prefer wicd as it puts me in control of my network connections and gets out of the way.
                    Wake me up when wicd supports tethering, bluetooth, and other 3G networking support. As well as ad-hoc networking, temporary wireless access point, etc.

                    Network-manager-dispatcher FTW, btw, if your dealing with custom networking setups and VMs.

                    Comment

                    Working...
                    X