Announcement

Collapse
No announcement yet.

What is happening to the old ATI hardware support

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • What is happening to the old ATI hardware support

    Recently I'm only hearing about improvements on the newer ATI Radeon open source drivers.
    I think that this shouldn't be a priority because people already have access to a closed source driver for the newer hardware.
    However, older hardware from ATI lacks of support.
    I have an ATI Radeon X1650 with 512 MB that works fine on Windows, and is able to play almost all recent games.
    Although it is unable to render Compiz on Ubuntu 10.04.
    On an old notebook that I have with a Mobility Radeon X300 I'm unable to use Google Earth on Ubuntu 10.04.
    Is AMD going to abandon their old hardware costumers?

  • #2
    Drivers for R500 and below are much more complete than for new cards. All those bugs you mention aren't the driver's fault; Compiz works *PERFECTLY* with R500. If on Ubuntu it doesn't, report it to the Ubuntu devs.

    Comment


    • #3
      Yep, the open source stack for older chips has gone through an almost total rewrite in order to bring new features and better performance, but that work probably introduced problems for some systems. Problems that appear on systems the developers have access to have generally been fixed already, but there are probably some issues they aren't seeing. File good complete bug reports and I think you will see them get fixed.

      What specific problem are you having with Compiz ?

      Did/does the *same* version of Google Earth work with older versions of Ubuntu ? Remember that there have been a *lot* of changes in Google Earth as well and those changes are also causing new problems to appear.

      Comment


      • #4
        Originally posted by bridgman View Post
        Yep, the open source stack for older chips has gone through an almost total rewrite in order to bring new features and better performance, but that work probably introduced problems for some systems. Problems that appear on systems the developers have access to have generally been fixed already, but there are probably some issues they aren't seeing. File good complete bug reports and I think you will see them get fixed.

        What specific problem are you having with Compiz ?

        Did/does the *same* version of Google Earth work with older versions of Ubuntu ? Remember that there have been a *lot* of changes in Google Earth as well and those changes are also causing new problems to appear.
        I don't think that these problems that I'm facing on google earth are related to the application itself.
        On my desktop with an NVIDIA card, everything works perfectly.

        Are you all telling me that Ubuntu drivers are old and buggy?
        Which is the distribution that I can get the best performance with the open source drivers?
        Does Gentoo brings these drivers?

        Comment


        • #5
          OK, one more time, what specific problems are you having with Compiz ?

          I don't know what problem you are having with Google Earth so I can't really comment on what the cause might be. Ubuntu has quite new versions of the "released" drivers but for the last 6-9 months most of the open source driver work has been on the not-yet-released Gallium3D-based Mesa driver rather than the "classic" Mesa driver used by current releases of Ubuntu and (AFAIK) all other disstros.

          Read up on the "300g" driver and give that a try. You should find that it runs a number of additional apps well, although it may also bring a few problems that you don't see today. There's a good chance that "300g" will become the default in the next Mesa release, but you don't need to wait for that to try it yourself.

          Comment


          • #6
            Originally posted by fernandoc1 View Post
            Are you all telling me that Ubuntu drivers are old and buggy?
            Which is the distribution that I can get the best performance with the open source drivers?
            Does Gentoo brings these drivers?
            I think your best bet would be Fedora, as it's the distro most driver devs themselves are using.

            Gentoo does have the latest versions of the whole X.Org stack, including integration of Git into the package manager (imagine "aptitude install" would pull the latest Git master and install it, all with dependency tracking etc), but well, drivers are no reason to use Gentoo; you open that can of worms if you're really into source-based distros.

            Comment


            • #7
              -

              Originally posted by fernandoc1 View Post
              Recently I'm only hearing about improvements on the newer ATI Radeon open source drivers.
              I think that this shouldn't be a priority because people already have access to a closed source driver for the newer hardware.
              However, older hardware from ATI lacks of support.
              I have an ATI Radeon X1650 with 512 MB that works fine on Windows, and is able to play almost all recent games.
              Although it is unable to render Compiz on Ubuntu 10.04.
              On an old notebook that I have with a Mobility Radeon X300 I'm unable to use Google Earth on Ubuntu 10.04.
              Is AMD going to abandon their old hardware costumers?
              I'm in the same situation. I have a 2007 Acer desktop with ATI Radeon X200
              graphics. It worked fine with the open & closed source drivers on older versions of Ubuntu (8.04, 9.04). Then Ubuntu support started running out for those old ubuntu versions and I switched to the latest version Ubuntu 10.04. Now the default ATI driver no longer works smoothly with graphics intense programs like Google Earth & Secret Maryo Chronicles. And my graphics is now classified as Legacy by ATI, and the Legacy ATI will not work on the latest versions of Ubuntu. So now I'm stuck.

              Comment


              • #8
                after reading this post, I just had to run Google earth. With latest update from xedgers and running r300g. Not, GoogleEarth is working perfectly, no more break ups while redrawing!

                Comment


                • #9
                  Google Earth really should be working with the free driver, in fact, all of the apps mentioned should be working very well.

                  Try upgrading the whole driver stack (including the kernel!) from an experimental PPA. If things worked in Ubuntu 8.4, then you've probably run into problems with the migration to KMS. Running the most recent stack should help in that case.

                  Comment

                  Working...
                  X