Announcement

Collapse
No announcement yet.

A Closer Look At Red Hat's Plymouth

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    It doesn't require Kernel patches, and is more modular and newer(bootsplash is abandoned)

    IMO they should've fixed up splashy instead of many yet-another boot splash app.

    ----

    The reason it CAN'T be done with packages is it requires modifying initrd/initramfs, that is a crucial part of the system and it also requires(most likely) modifying /etc/init.d(or rc.d) scripts

    Comment


    • #32
      Originally posted by elanthis View Post
      </tangent>
      Alright, fair enough, that's too bad though is all that the framework isn't already in place for it but it's clearly a new framework so that's understandable. If they are helping with that standardization, with that framework/infrastructure for Linux, so that in the future developers can easily snap in their own software, then great and that's all I'm saying is important really. Obviously this software isn't ready for prime time until that infrastructure is in place and ready for it, and I hope that that framework is one that is a good standard so that major infrastructure changes won't be needed much in the future, cept when they upgrade from Plymouth Linux Infrastructure API 1.0 to 2.0. But even then, 1.0 apps should work with 2.0! hehe

      Comment


      • #33
        Originally posted by gQuigs View Post
        Was just wondering if anyone knew of any way to force modesetting on for r200 series cards, specifically RV250
        I believe they don't have it on because it breaks 3d; well the 3d isn't very good anyway...
        so I want to try KMS and Plymouth.
        radeon.modeset=1 on the kernel command line shuold enable it on r100/r200 at the expense of 3D.

        Comment


        • #34
          Originally posted by fat_chris View Post
          Question for Airlied:
          I have been try to get KMS working on another distro (gentoo) but have so far been unsuccessful.
          I've got the kernel from git://git.kernel.org/pub/scm/linux/kernel/git/airlied/drm-2.6.git (drm-rawhide branch) built it with modesetting on by default all built fine, libdrm from git://git.freedesktop.org/git/mesa/drm.git (modesetting-gem branch) and xf86-video-ati from git://people.freedesktop.org/~airlied/xf86-video-ati (branch radeon-gem-cs). When I boot without nomodeset it will get to openrc and then load the modules where I get a blank screen and a no signal message on the screen. In the logs it pretty much just says that it can't find anything connected to the graphics card (r580 x1900 xt) and it says the drivers loaded fine. I also tried building drm and radeon into the kernel but the same happens just much earlier in the boot process.
          Is there anything else I need to do/enable/install?
          Any help is appreciated
          its a bit messy, the libdrm has diverged a bit from the kernel, so using the patches from Fedora probably makes more sense until we line it all up again.

          http://cvs.fedora.redhat.com/viewvc/rpms/libdrm/F-10/

          the -ati and kernel bits should be fine, its just libdrm that got diverged.

          Comment

          Working...
          X