Announcement

Collapse
No announcement yet.

A Closer Look At Red Hat's Plymouth

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by puelocesar View Post
    Well, think in both things connected

    You press the power button and then it fades from black to your desktop or login screen in a smooth animation

    Instant boot + smooth graphics = Holy grail!
    Yeah, and don't forget to turn display ON, only when you feel (won't even guess by what receptor) that kernel is loaded ;-)

    Comment


    • #12
      Was just wondering if anyone knew of any way to force modesetting on for r200 series cards, specifically RV250
      I believe they don't have it on because it breaks 3d; well the 3d isn't very good anyway...
      so I want to try KMS and Plymouth.
      Last edited by gQuigs; 10-28-2008, 01:16 PM.

      Comment


      • #13
        The vga=0x318 is not necessary correct for vesafb. That one doesn't work on my system, for example. I can use 0x31A or any of a number of others.

        The article also says that R600 works with KMS, but that doesn't seem to be the case yet (for stock Fedora/Rawhide, anyways). As stated on the Open Source AMD/ATI boards, that still requires building your own DRM and releated bits from the modesetting-gem branch of mesa/drm.

        KMS in Rawhide definitely isn't working on R600 on my machine without using vesafb, anyways.

        Comment


        • #14
          Originally posted by gQuigs View Post
          Was just wondering if anyone knew of any way to force modesetting on for r200 series cards, specifically RV250
          I believe they don't have it on because it breaks 3d; well the 3d isn't very good anyway...
          so I want to try KMS and Plymouth.
          Add radeon.modeset=1 to the kernel command line for r100/r200s

          R600 the code is there, the PCI IDs are not, I'll probably enable them in rawhide post-F10, it was just a matter of bad timing.

          Comment


          • #15
            Originally posted by airlied View Post
            Add radeon.modeset=1 to the kernel command line for r100/r200s
            What about r300s/400s? If I understand phoronix's article correctly it's only enabled for 500+ series by default?

            Comment


            • #16
              airlied: thanks! X won't actually start when using KMS, so yea.. not ready for prime time. But it's still cool to watch the solar bootup :P

              zombiepig: AFAIK r300 - r500 should be supported

              Comment


              • #17
                Originally posted by gQuigs View Post
                airlied: thanks! X won't actually start when using KMS, so yea.. not ready for prime time. But it's still cool to watch the solar bootup :P
                Wierd X should start whats the card? AGP rv250?

                it works on my AGP rv280 here.

                You can also try adding radeon.agpmode=
                options
                with -1 == PCI mode, 1,2,4,8 for various agp modes.

                Comment


                • #18
                  01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] (rev 02)

                  It's in a laptop if that matters. Tried many of the combinations of radeon.agpmode=-1/1/2/4/8 with and without radeon.modeset=1.

                  Didn't matter what radeon.agpmode was set to.

                  I suppose since this is unsupported a bug report wouldn't be an option.
                  The Xorg.0.log looks really weird to me...why is vesa in there?(although I haven't ever seen an Xorg log from a KMS system before.)

                  It is available here (http://gquigs.googlepages.com/Xorg.0.log) if interested.

                  Do you have (good) 3d on your rv280?

                  Comment


                  • #19
                    It would also be nice to see Plymouth (or some adaptation of it) supported by other Linux distributions.

                    Supported? It's open source, just install it in Ubuntu if you want it in Ubuntu. So what if it doesn't come with it by default. I guess that's one reason for rolling your own distro, but yeah I hope most desktop Linuxes will come with this software in the future because most users will want it I reckon.

                    Linux needed a boot process sleek enough to match Mac's. I hope the next step will be to implement this in the Linux BIOS as well, so that it will be possible to go from power on all the way to your desktop with no flickering or changing of resolutions whatsoever.

                    Comment


                    • #20
                      Yfrwlf, I think you failed to read the whole article.

                      It's pretty clear that you can NOT just install Plymouth into a distro and actually have it work. It needs tight integration with the distro to actually work. It needs to properly inserted into the initrd (which will require an entirely different set of commands and scripts than Fedora uses) and the init system needs updates to communicate with Plymouth properly. Plus I'd imagine you'd need to change the GDM startup to use the new features to not reset the video mode and get smooth fade-in.

                      If Ubuntu/Debian/SUSE/etc. want Plymouth, the distro engineers are going to have to integrate it, which will take a fair amount of effort.

                      It is not at all something a regular user -- or even a moderately advanced user -- would be expected to know how to do properly.

                      Comment

                      Working...
                      X