Announcement

Collapse
No announcement yet.

Latest X11 DRM modules won't load with kernel 2.6.25

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Latest X11 DRM modules won't load with kernel 2.6.25

    The latest DRM kernel modules from git master build fine but won't load with kernel 2.6.25.11. A "modprobe drm" results in:

    drm: Unknown symbol shmem_file_setup

    Not sure how to resolve this.

  • #2
    You usually have parts of the drm modules already loaded, reboot and it should work.

    Comment


    • #3
      It looks like the shmem_file_setup reference was added during the GEM merge over the last couple of days. You might want to mention this on the #dri-devel IRC or mailing list. It may be as simple as needing another package to support shmfs but I'm guessing there.
      Last edited by bridgman; 08-09-2008, 07:54 PM.

      Comment


      • #4
        I'm not up on the details but it looks like some bits were added late in 2.6.26 to support GEM and this call was one of the ones mentioned.

        Comment


        • #5
          Originally posted by Kano View Post
          You usually have parts of the drm modules already loaded, reboot and it should work.
          Unfortunately, nope; this wasn't the problem.

          Originally posted by bridgman View Post
          Not 100% sure but it looks like the shmem_file_setup reference was added during the GEM merge over the last couple of days. You might want to mention this on the #dri-devel IRC or mailing list.
          I've emailed dri-users@lists.sourceforge.net.

          I've found this: http://www.opensubscriber.com/messag...t/9353749.html

          Not sure what's going on exactly. Does that mean an upstream patch to mm/shmem.c is required?

          Comment


          • #6
            It looks like that 2.6.26.3 could add that hotfix Well in that case you have to compile your kernel on your own with that added EXPORT_SYMBOL(shmem_file_setup).

            Comment


            • #7
              This looks innocent enough so I've added the export. The modules load fine now. I really hope this gets backported to 2.6.25 since 2.6.26 has IRQ problems with my graphics card :P

              Comment


              • #8
                my r500 gets blank screen with 2.6.26

                with 2.6.26, the screen goes blank when startx, and a reboot is required before I could see anything on screen

                now, drm module won't load with 2.6.25

                is the open source support being downgraded to fglrx level?

                Originally posted by RealNC View Post
                This looks innocent enough so I've added the export. The modules load fine now. I really hope this gets backported to 2.6.25 since 2.6.26 has IRQ problems with my graphics card :P

                Comment


                • #9
                  I had other problems with 2.6.26 but not the one you describe. In any event, this *is* supposed to work with 2.6.26.

                  It is natural for the module not to load with 2.6.25; you must compile it against the same kernel you're running. That is, when compiling the modules, make sure /usr/src/linux points to the correct kernel source version.

                  Comment


                  • #10
                    the 2.6.25 issue being fixed in mesa/drm -git

                    Originally posted by RealNC View Post
                    I had other problems with 2.6.26 but not the one you describe. In any event, this *is* supposed to work with 2.6.26.

                    It is natural for the module not to load with 2.6.25; you must compile it against the same kernel you're running. That is, when compiling the modules, make sure /usr/src/linux points to the correct kernel source version.

                    Comment

                    Working...
                    X