Announcement

Collapse
No announcement yet.

Last Minute GLX Extensions For X.Org Server 1.13

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Last Minute GLX Extensions For X.Org Server 1.13

    Phoronix: Last Minute GLX Extensions For X.Org Server 1.13

    While the GLX_ARB_create_context and GLX_ARB_create_context_profile extensions were already pulled into the GLX code for X.Org Server 1.13, with the merge window being extended to allow the landing of Airlie's RandR 1.5 work, a few more GLX extensions have now landed too...

    http://www.phoronix.com/vr.php?view=MTEzMzc

  • #2
    Another extension for X.org has just landed: GLX_ARB_replaceX11_with_wayland

    Comment


    • #3
      OpenGL support still sucks.

      Tbe best platform for open source graphics is Windows!
      Windows support the latest OpenGL 4 graphics!

      Linux still sucks for open source OpenGL graphics API.

      Comment


      • #4
        Originally posted by uid313 View Post
        OpenGL support still sucks.The best platform for open source graphics is Windows!
        Windows support the latest OpenGL 4 graphics! Linux still sucks for open source OpenGL graphics API.
        Go away, troll.

        Comment


        • #5
          Originally posted by DanL View Post
          Go away, troll.

          He has a point thought. Open drivers are not on par with the blobs feature wise.

          Comment


          • #6
            Stop fucking with the ABI at the last minute!

            http://www.youtube.com/watch?v=i4FGvMdhG80

            (NB: Fucking with the ABI earlier in the cycle is OK.)

            Comment


            • #7
              Originally posted by 89c51 View Post
              He has a point thought. Open drivers are not on par with the blobs feature wise.
              No he doesn't because the blobs are just as good on linux. He wasn't talking about the blobs, he was talking about the OS.

              Comment


              • #8
                Originally posted by allquixotic View Post
                Stop fucking with the ABI at the last minute!

                http://www.youtube.com/watch?v=i4FGvMdhG80

                (NB: Fucking with the ABI earlier in the cycle is OK.)
                it's not the last minute - the release isn't until september, which it even says in the article. this is feature freeze, not release.

                Comment


                • #9
                  I think it is a good thing these extensions are added sooner than later.
                  Being able to set up a context is one of the first and a very important part in a program that uses OpenGL.

                  Even if it means X.Org server gets released a bit later. It's better to have these last minute glx extensions.
                  It's very important to have context creation as early as possible in place.

                  A good job done!

                  Comment


                  • #10
                    Looking at the extensions.
                    Noticed a problem, the GLX_EXT_create_context_es2_profile needs to allow for version and not just es2.
                    Because they things need to be changed every time a new version comes out.
                    (Considering OpenGL ES 3 will come out this summer, I'd say it's best if this is done good from the start.)

                    Please add a way to specify a version and rename the extension to GLX_EXT_create_context_es_profile.

                    Comment

                    Working...
                    X