Announcement

Collapse
No announcement yet.

XAA In X.Org Has Finally Met Its Executioner

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • XAA In X.Org Has Finally Met Its Executioner

    Phoronix: XAA In X.Org Has Finally Met Its Executioner

    The XAA 2D acceleration architecture is finally set to be stripped out of X.Org Server 1.13 and upstream open-source X.Org drivers...

    http://www.phoronix.com/vr.php?view=MTA0NDg

  • #2
    i'm glad to see a lot of this old stuff taken out. i'm starting to feel like its time to move onto X12 though, now that X11 is gradually becoming incompatible with it's own drivers. X11 has been around for a really long time. if you have old devices that use these old, removed drivers then it is going to be difficult to find the last version that supports it. i'm not really sure why X11 has been around for as long as it has been. i'm sure the very first release of it has enough missing features that it'd be incompatible with modern desktop environments.

    Comment


    • #3
      In other words, any last shreds of acceleration are being removed for any cards in that list. Way to make even more hardware unusable.

      Comment


      • #4
        Originally posted by curaga View Post
        In other words, any last shreds of acceleration are being removed for any cards in that list. Way to make even more hardware unusable.
        Yeah, it's sad... I have an Alpha that I was going to set up with a 3DFX Voodoo3 in the near future. Looks like I'll have to restrict myself to older versions of X.org if I want a working non-VESA driver. That, or I finally have to learn X driver development and figure out how to port the voodoo driver to EXA, and possibly KMS/DRI2...

        Wasn't someone actually working on a KMS driver for 3dfx cards a few years back as part of a documentation GSoC project?

        Comment


        • #5
          Originally posted by schmidtbag View Post
          i'm starting to feel like its time to move onto X12 though, now that X11 is gradually becoming incompatible with it's own drivers
          Nonsense, because the X11 protocol has nothing to do with changes in the driver architecture. XAA, EXA, and friends are simply parts of the Xorg implementation of that protocol.

          Comment


          • #6
            It looks that some porting will be needed to bring back support for older devices with EXA. I have still machines using cirrus, s3, s3virage, neomagic and trident drivers. I understand XAA must be removed, and I fully support this move. But I was always so proud that Linux kernel and X.org server supports so much devices without installing any additional drivers or manual compilation. Now this advantages is going to die.

            Comment


            • #7
              The problem is most of these old cards don't have the necessary hardware bits to actually accelerate much that a modern desktop uses. Some of them are not even capable enough to support the bare minimum required for EXA. You'll get better performance using shadowfb (albeit with slightly higher CPU usage) than using the actual 2D hardware in most cases. We are talking about 10-15 year old cards here...

              Comment


              • #8
                Originally posted by curaga View Post
                In other words, any last shreds of acceleration are being removed for any cards in that list. Way to make even more hardware unusable.
                This is hyperbolic. the effected cards are absolutely ancient, and one cannot reasonably expect such old hardware to keep being supported with a modern OS.

                Comment


                • #9
                  Originally posted by curaga View Post
                  In other words, any last shreds of acceleration are being removed for any cards in that list. Way to make even more hardware unusable.
                  Agreed, there's perfectly good old laptops and desktops that still function...maybe there needs to be a xserver-legacy-1.11 branch with someone who could step forward to maintain the older X server along with the classic drivers. If enough people say something maybe the X developers can look into what's doable.

                  Also what about the Radeon 7500-9000 series that use the R100~R200 drivers? I have 2 thinkpads that use these graphics chips and I'd like to keep using them with Linux
                  Last edited by DeepDayze; 01-18-2012, 06:53 PM.

                  Comment


                  • #10
                    Originally posted by DeepDayze View Post
                    Agreed, there's perfectly good old laptops and desktops that still function...maybe there needs to be a xserver-legacy-1.11 branch with someone who could step forward to maintain the older X server along with the classic drivers. If enough people say something maybe the X developers can look into what's doable
                    Anyone that wants to can check out older xservers from git and use them. However, I suspect most people won't notice much of a difference since XAA really hasn't accelerated much for the last 4 years since XAA offscreen pixmap support has been broken and disabled. Note that this only removes XAA support, not the drivers themselves.


                    Originally posted by DeepDayze View Post
                    Also what about the Radeon 7500-9000 series that use the R100~R200 drivers? I have 2 thinkpads that use these graphics chips and I'd like to keep using them with Linux
                    All radeons are still fully supported (EXA, KMS, DRI2, etc.). This basically only affects hw that pre-dates the original radeon.

                    Comment

                    Working...
                    X