Announcement

Collapse
No announcement yet.

Wayland LiveCD Updated Against v1.5, Uses Systemd On Ubuntu

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by mark45 View Post
    Yeah, I'm not an expert so I might call "drivers" anything in the whole Linux graphics stack.


    Yes, there are 2 files, "card0" and "controlD64".



    I do "sudo modprobe nouveau", hit enter and I instantly get back to the command line, no message, apparently nothing happens.
    What's the root password, maybe I should do it as su rather than sudo?
    Hmm... That all seems good. Sudo is running modprobe as root, and modprobe did'nt throw an error, so su won't make a difference


    If you can't copy the log file to a flash drive with the tty, after starting with the standard boot option, can you try to get a picture of the screen showing the contents of the log file?



    also try
    ps -A grep weston

    beware that every 15 seconds the waylandloginmanager tries to restart the loginmanagerdisplay once its down, which causes the tty to change.
    I'll add a maximum attempt in the next iso for the waylandloginmanager, so it displays an error, instead of showing nothing

    Comment


    • #12
      Originally posted by nerdopolis View Post
      If you can't copy the log file to a flash drive with the tty, after starting with the standard boot option, can you try to get a picture of the screen showing the contents of the log file?
      I learned how to mount partitions from the command line, so here's the data from /var/log/loginmanagerdisplay.log:
      Code:
      Date: 2014-05-29 UTC
      [21:04:00.754] weston 1.5.90
                     http://wayland.freedesktop.org/
                     Bug reports to: https://bugs.freedesktop.org/enter_bug.cgi?product=Wayland&component=weston&version=1.5.90
                     Build: 1.4.93-20-g73dfbd5-dirty Add releasing.txt to describe the release steps and other bits of process (2014-05-23 10:13:59 -0700)
      [21:04:00.754] OS: Linux, 3.13.0-24-generic, #47-Ubuntu SMP Fri May 2 23:31:42 UTC 2014, i686
      [21:04:00.761] Using config file '/etc/loginmanagerdisplay//.config/weston.ini'
      [21:04:00.809] Loading module '/opt/lib/i386-linux-gnu/weston/drm-backend.so'
      [21:04:00.902] initializing drm backend
      [21:04:00.904] using /dev/dri/card0
      [21:04:00.907] launching '/opt/libexec/weston-keyboard'
      [21:04:01.030] Failed to initialize backlight
      [21:04:01.030] EDID data 'GSM', 'W2453', '413255'
      [21:04:01.030] Output DVI1, (connector 15, crtc 13)
                     mode 1920x1080@60.0, preferred, current
                     mode 1680x1050@60.0
                     mode 1280x1024@75.0
                     mode 1280x960@60.0
                     mode 1280x800@59.8
                     mode 1152x864@75.0
                     mode 1024x768@75.1
                     mode 1024x768@60.0
                     mode 832x624@74.6
                     mode 800x600@75.0
                     mode 800x600@60.3
                     mode 800x600@56.2
                     mode 640x480@75.0
                     mode 640x480@60.0
                     mode 720x400@70.1
      [21:04:01.062] Loading module '/opt/lib/i386-linux-gnu/weston/desktop-shell.so'
      [21:04:01.062] Module '/opt/lib/i386-linux-gnu/weston/desktop-shell.so' already loaded
      [21:04:01.062] Module '/opt/lib/i386-linux-gnu/weston/desktop-shell.so' already loaded
      [21:04:01.062] Compositor capabilities:
                     arbitrary surface rotation: yes
                     screen capture uses y-flip: yes
      [21:04:01.097] launching '/opt/libexec/weston-desktop-shell'
      [21:04:02.207] already in the native mode
      [21:04:05.740] already in the native mode
      [18:04:17.468] deactivating session

      Originally posted by nerdopolis View Post
      also try
      ps -A grep weston
      It yields:
      Code:
       1459 tty8     00:00:00 weston-launch
       1492 tty8     00:00:00 weston
       1611 tty8     00:00:07 weston-display-
       1613 tty8     00:00:00 weston-keyboard
       1614 tty8     00:00:00 weston-desktop-
      In case it matters here's my hw specs (sudo lshw >> file.txt).
      Didn't post here cause can't attach files and it's too large to be displayed.

      Comment


      • #13
        Thanks.


        That's a bit odd though. It seems Weston is actually running.

        What happens if you try to start it up with the standard boot option, switch to tty1, and then switch to tty8 ?

        Comment


        • #14
          What command do I have to run and when? (I'm not sure what you mean).

          Comment


          • #15
            Originally posted by mark45 View Post
            What command do I have to run and when? (I'm not sure what you mean).

            When you start up the live CD with the default boot opton, when it's done starting up
            Just press ctrl+alt+F1 wait 1 second, and then press ctrl+alt+F8

            Thanks

            Comment


            • #16
              After pressing ctrl+alt+F1 I get the usual login prompt for the tty (at F1), and then after ctrl+alt+F8 I get back to a completely black screen.
              Maybe you need some other .log files?

              Comment


              • #17
                Originally posted by mark45 View Post
                After pressing ctrl+alt+F1 I get the usual login prompt for the tty (at F1), and then after ctrl+alt+F8 I get back to a completely black screen.
                Maybe you need some other .log files?
                I can't think of any log files. Try pressing enter, (or maybe tab tab enter) to try to select the default session in the zenity dialog at that black screen. It could an issue with pixman that the loginmanagerdisplay uses

                Comment


                • #18
                  "enter" or "tab tab enter" didn't help.

                  Comment


                  • #19
                    Originally posted by mark45 View Post
                    "enter" or "tab tab enter" didn't help.
                    Hm... looks like you might be effected by
                    https://bugs.freedesktop.org/show_bug.cgi?id=75761

                    Try adding the kernel option nouveau.config=NvMSI=0 by pressing tab at the boot menu, appending that string and pressing enter please?

                    If not, it also says something about nouveau-firmware... the problem is I don't know if I can add that to the live CD, because it's in multiverse, and my SourceForge project is GPL v2...

                    Comment


                    • #20
                      nouveau.config=NvMSI=0 didn't help, btw I got asus, not msi.

                      Though, as I mentioned earlier if I pick an option below the default one in the grub menu it works, I wonder why. If you had a nouveau/pc you could workaround this issue, to me it's a matter of choosing an option below the default one and I end up with a 1920x1080 desktop resolution regardless of which resolution I choose at grub menu (I chose 2 options both worked, though the one with 1440xXXX gave a warning).

                      Comment

                      Working...
                      X