Announcement

Collapse
No announcement yet.

Ubuntu 13.04 Will Enable Wayland Support In GTK+

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ubuntu 13.04 Will Enable Wayland Support In GTK+

    Phoronix: Ubuntu 13.04 Will Enable Wayland Support In GTK+

    While Canonical developers previously said they "won't fix" GTK+ support for Wayland in Ubuntu, the matter has now changed. It looks like Ubuntu 13.04 will be able to handle GTK+ applications on Wayland...

    http://www.phoronix.com/vr.php?view=MTI3MDY

  • #2
    I believe that ideally, major changes on the stack, such as the move to wayland should come on LTS+1 releases, in order to have 3 whole releases to sort out the main bugs. I know this news does not mean ubuntu is moving to wayland on 13.04, and that is what I find puzzling.

    Either there will be wayland introduction on 13.10, or, since is is most probably not going to be introduced on the LTS itself, 14.04 will still be a Xorg release. However, 14.04 is touted as the phone/tablet/tv release, and to do that, specially the TV part (due to all the tearing) on top of Xorg seems like a lackluster.

    Comment


    • #3
      Update Wayland

      I hope they update the Wayland package in 13.04 raring, because it is still at old 0.95 in the repository.

      Comment


      • #4
        Originally posted by Figueiredo View Post
        Either there will be wayland introduction on 13.10, or, since is is most probably not going to be introduced on the LTS itself, 14.04 will still be a Xorg release.
        You're reading too much into this. We've been trying to get the wayland backend of the gtk package enabled for a while. It's just happening now because we finally figured out the way to make it happen.

        Originally posted by uid313 View Post
        I hope they update the Wayland package in 13.04 raring, because it is still at old 0.95 in the repository.
        Huh, that is odd. I saw libwayland0 was up to 1.0.2, and assumed that weston came along with it. But you're right, it's still 0.95.

        Comment


        • #5
          Originally posted by uid313 View Post
          I hope they update the Wayland package in 13.04 raring, because it is still at old 0.95 in the repository.
          Opened a bug: https://bugs.launchpad.net/ubuntu/+s...n/+bug/1097685
          Thanks for pointing that out. And in the future, I encourage you to open such bugs yourself.

          Comment


          • #6
            Redi

            Isn't the main problem that Wayland is now supported only by GTK+ and Intel drivers? And by informations from here there won't be any support in binary blobs any soon...

            Comment


            • #7
              Originally posted by Darxus View Post
              You're reading too much into this. We've been trying to get the wayland backend of the gtk package enabled for a while. It's just happening now because we finally figured out the way to make it happen.
              And what does it mean actually. Those who have compatiple drivers will be able to run GTK+ apps on wayland itself on 13.04, unity maybe?

              Comment


              • #8
                Originally posted by Redi44 View Post
                Isn't the main problem that Wayland is now supported only by GTK+ and Intel drivers? And by informations from here there won't be any support in binary blobs any soon...
                Main problem with what? It also works with the radeon and nvidia (nouveau) open source drivers. Wayland / weston also works with X clients, but that capability still isn't upstream, so doesn't look like it will be in ubuntu any time soon.

                Originally posted by Figueiredo View Post
                And what does it mean actually. Those who have compatiple drivers will be able to run GTK+ apps on wayland itself on 13.04, unity maybe?
                Could be. Depending on how they deal with the libxkbcommon dependency that was just brought up in the relevant bug, and the incompatible wayland and weston versions in raring which uid313 mentioned.

                Comment


                • #9
                  Isnít it possible for programs to have libwayland as an optional dependency? I mean surely when wayland is not in use then libwayland is uselessÖ

                  Comment


                  • #10
                    Originally posted by stqn View Post
                    Isnít it possible for programs to have libwayland as an optional dependency? I mean surely when wayland is not in use then libwayland is uselessÖ
                    Yes. In response to the bug I opened requesting that gtk do that, it has been said that that would be prohibitively hard, due to the way gtk is structured: https://bugzilla.gnome.org/show_bug.cgi?id=690381#c3

                    Comment

                    Working...
                    X