Announcement

Collapse
No announcement yet.

Westion Terminal not working (no fonts!!) on vmwgfx.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Westion Terminal not working (no fonts!!) on vmwgfx.

    Hello.

    I have successfully build weston/wayland on VMWare with vmwgfx (without X windows, so no X11 libs, no X server).
    I can run almost all clients. Flower, simple-egl, clickdot are working like a charm.

    But I have problem with weston-terminal. When I run it I got no screen. No title bar/no content.
    Then i played with terminal.c source code.
    When I comment this out:

    Code:
    cairo_push_group(cr);
    ...
    ...
    cairo_pop_group_to_source(cr);
    Then the window is displayed, but no text, no cursor etc.
    But on title bar, there is a text.

    I have compiled cairo without Fontconfig, so it is using only buildin fonts.
    I have debugged weston-terminal, but can't find the reason why it is not working.


    Any suggestions?

  • #2
    Hello again.

    I have tried also other clients and for example smoke is not working.
    The window is there but not visible. I see only hand cursor.

    And the funnies about it is, when I start simple-egl and then smoke I see the content of simgle-egl in the smoke window
    and no real smoke effects.

    I have tried to turn off SHM window type but It is not working.
    Still debugging to find a reason.

    One more comment. The Ubuntu Unity is not working correctly on my Intel GMA X3100, but Gnome shell works okay in VMWare with vmwgfx.

    Comment


    • #3
      Originally posted by hanzelpeter View Post
      Hello.

      I have successfully build weston/wayland on VMWare with vmwgfx (without X windows, so no X11 libs, no X server).
      I can run almost all clients. Flower, simple-egl, clickdot are working like a charm.
      Whoa. How did you do that. I've been trying and haven't got anything to really work. What options did you feed the various configure scripts?

      Comment


      • #4
        configure options

        Mostly I haved used --enable-glesv2 instead of --enable-opengl.
        But in next couple of days i will fetch all from git a build it again from scratch so I will note all commands and changes to source (As I remeber some Mesa sources needed to ne modified)

        Comment


        • #5
          The build instructions.

          Here is what I did:

          1. Start with clean system. I use LFS (Linux from scratch where no X is installed, no png, jpeg libs etc..)
          2. Complile and install newest kernel with vmwgfx enabled (DRM driver for VMware Virtual GPU)
          I used linux-3.4.7
          3. Open http://wayland.freedesktop.org/building.html and next we will follow it
          4. Install pkg-config if not installed.
          I will install all in /usr/local

          5. Setting up the environment
          I only setup this:
          ACLOCAL="aclocal -I usr/local/share/aclocal"
          export ACLOCAL

          6. Compile wayland

          (needed dependecies:
          libffi
          expat
          ) - install first

          ./autogen.sh --prefix=/usr/local
          make
          make install

          7. Compile mesa
          Compile drm

          (needed dependecies:
          pthread-stubs
          xorg-macros (util-macros)
          pciaccess
          )

          ./autogen.sh --prefix=/usr/local --enable-vmwgfx-experimental-api
          make
          make install

          Compile mesa

          (needed depeendecies:
          xproto
          makedepend
          Python
          libxml2
          )

          ./autogen.sh --prefix=/usr/local --enable-gles2 --disable-gallium-egl --with-egl-platforms=wayland,drm --enable-gbm --enable-shared-glapi --with-gallium-drivers=swrast,svga --disable-glx --enable-gallium-gbm


          Compiling will fail on include/EGL/eglplatform.h - X11/Xlib.h no such file
          This is definition of EGLNativeDisplayType, EGLNativePixmapType, EGLNativeWindowType
          I resolved this by add #define __GBM__ on begin of header eglplatform.h

          Also in src/gallium/auxiliary/pipe-loader/pipe_loader.h
          we must add #define HAVE_PIPE_LOADER_DRM
          and modify Makefile to compile pipe_loader_drm.c


          After compile verify
          cd /sources/mesa/lib/gbm
          nm gbm_gallium_drm.so | grep probe_fd

          and it must be T symbol

          8. Compile libxkbcommon
          (needed depeendecies:
          kbproto
          )

          ./autogen.sh --prefix=/usr/local --with-xkb-config-root=/usr/local/share/X11/xkb


          9. Compile pixman

          ./autogen.sh --prefix=/usr/local

          10. Compile cairo
          (needed dependecie
          libpng
          jpeg
          freetype
          fontconfig
          )

          ./autogen.sh --prefix=/usr/local --enable-glesv2

          Compiling will fail:
          fix src/cairo-gl-device.c = definition of GL_DEPTH24_STENCIL8 =


          11. Compile weston
          (needed dependecies
          mtdev
          linux-pam
          )

          ./autogen --prefix=/usr/local --disable-xwayland --disable-x11-compositor
          make
          make install

          mkdir ~/.config
          cp weston.ini ~/.config/


          12. Copy cusor icons /usr/share/icons from any Linux with X windows.
          and put default and DMZ-White folders to /usr/share/icons

          Comment

          Working...
          X