No announcement yet.

No text in 3d games (Matrox)

  • Filter
  • Time
  • Show
Clear All
new posts

  • No text in 3d games (Matrox)

    I got a Matrox G450 PCI card with 32mb ram to replace an old Ati Rage - to get a decent resolution, plus 2d and 3d acceleration.

    Using latest mga (1.4.9) and supposedly latest drm (, and mga drivers in general don't see a lot of changes) on Xorg 7.2. I have direct rendering working.
    Using XAA or EXA does not matter (though in EXA I see other corruption, likely due to early EXA in 7.2)

    I see no text in games, see screenshot at:

    This happens in some other games too, common factors being SDL and Mesa.

    So, I've heard the early Ati binary drivers had this too, any hints? How did you solve it there?

  • #2
    Xorg bug report filed, number 17672


    • #3
      Do you use the binary hal?


      Copied into same dir as from your install, usually



      • #4
        No, should I?
        The manpage mentions the DVI output, and I know it has Macrovision, and I only need the VGA.

        I did try to compile Matrox's official driver, but being for Xorg 7.0, it wouldn't compile.

        Edit: I also would strongly prefer not to use binary drivers.


        • #5
          Then buy motherboard with intel vga onboard and don't use matrox


          • #6
            Do you have some insight on what does the blob do, besides DVI and crippling tv-out?

            Cause that'd be nice to know, instead of a snide remark about Intel


            • #7
              Well, just for you hon, I tried both the HAL blob and the full blob.

              HAL did not get loaded at all with OSS mga. Not even when explicitly saying "NoHAL" "false".

              The full binary did get X up, and load the HAL, but without DRI. So I couldn't test the Matrox binary for this bug, as Mesa software rendering does not have it.


              • #8
                I have the same problems with g450 pci.
                Compiling latest code from git:// made things slightly better.
                Using mga_hal via the drivers provided by // didn't help too much.
                If you want to try them though have a look in the howto section at
                on how to use and install them.
                Also in my case the Videoram of the card was detected erraticly.
                Using the driver from git and setting VideoRam in xorg.conf made the problem nearly vanish. 3d performance is still very bad though.


                • #9
                  Thanks for your response. What do you mean with nearly vanished?
                  Are there still letters missing for example?


                  • #10
                    Letters in etrcacer are looking normal now, but still some gliches with some of the screensavers. And any games are still too slow to play and often make X crash (or at least unresponsive).


                    • #11
                      I wonder why the git driver helps, seeing the latest git commit being the tag for 1.4.9?


                      • #12
                        I'm not familar with gitversion control, but I guess, there might be code in the master branch that didn't make it into the release. Moreover distros tend to include their own patches, so if your driver shipped with thed distro, there migth be small differences.


                        • #13
                          I compiled my own straight from I'll check the git ver out when I have time.


                          • #14
                            Tried out the driver you pointed out. No big difference in behaviur to the git driver.

                            Additionally I found out that using the 1.4.9 or the git driver I only get no texture (and text) problems if I set
                            VideoRam	 16384
                            in the device section of xorg.conf.
                            Srtange enough as my card should have 32 MB ram and is listed so by lspci.

                            Forgot to revert the experimental entry when I tried out git. Sorry for that.

                            So I guess some memory stuff is done strangely on pci cards.

                            I read somewhere that the "original" mga driver just sopported dri on agp cards. So it might be that direct rendering is still poor on pci.

                            Actually glxgears are here faster without direct rendering, but badly rendered.


                            • #15
                              Glxgears is the same for me; more fps, but true 3d accel looks way better, less jerky.

                              Also, my card is recognized as 32mb as it should be, VideoRam's one more thing to test..
                              Edit: VideoRam tested (on 1.4.9). No change whether forcing 16mb or 32mb.
                              Last edited by curaga; 09-22-2008, 07:35 AM.