Announcement

Collapse
No announcement yet.

Debian + radeonsi

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Debian + radeonsi

    Hi all.
    This is my first post, I hope it's the right section. (and sorry for my poor english)

    I've never compiled anything from mesa.
    Yesterday I bought a r7 265 ati card. Now I boot up my debian box and it started with raster driver.

    I googled a lot and finally found this thread. Seems a very good solution.

    I followed all steps and finally all compiling stuff came to an end.
    But I have a problem. When I try to install: mesa-i386_10.3.0-devel-1_i386.deb (32-lib for steam, compiled in a chroot with 32bit stuff) I run into a problem.

    This package try to overwrite file and config from: mesa_10.3.0-devel-1_amd64.deb

    I'm doing it wrong, but I can't find a solution.

    Now I have a running mesa 10.3 (with llvm3.5) on amd64, but nothing on 32bit side.

    EDIT: this is going to be a disaster. I've tried to revert from mesa 10.3 to the standard realease of debian and now:
    Code:
    # glxinfo
    name of display: :0
    Error: couldn't find RGB GLX visual or fbconfig
    Error: couldn't find RGB GLX visual or fbconfig

  • #2
    For radeonsi acceleration in Debian to work at all, you need glamor enabled xserver-xorg-video-radeon from experimental.

    Comment


    • #3
      Originally posted by chithanh View Post
      For radeonsi acceleration in Debian to work at all, you need glamor enabled xserver-xorg-video-radeon from experimental.
      Mmmm, I'm sorry but I can't find any version of radeon in experimental.

      https://packages.debian.org/search?s...g-video-radeon

      Comment


      • #4
        Originally posted by chithanh View Post
        For radeonsi acceleration in Debian to work at all, you need glamor enabled xserver-xorg-video-radeon from experimental.
        I can't find that package in experimental. Where did you find it?

        Comment


        • #5
          xserver-xorg-core and mesa from experimental + xserver-xorg-video-ati from sid should be enougth.

          Comment


          • #6
            Originally posted by towo2099 View Post
            xserver-xorg-core and mesa from experimental + xserver-xorg-video-ati from sid should be enougth.
            Actually no, ddx in sid is builded for xserver 1.15... he needs one rebuilded for xserver 1.16 .

            That package was uploaded in experimental, but seems like ftp-masters rejected it for some reason .

            https://lists.debian.org/debian-x/2014/06/msg00323.html

            Comment


            • #7
              Originally posted by towo2099 View Post
              xserver-xorg-core and mesa from experimental + xserver-xorg-video-ati from sid should be enougth.
              I'm on sid.
              Upgrading xserver-xorg-core (to experimental) breaks all xserver-xorg-video*, xserver-xorg and xorg.
              I can upgrade only xserver-xorg-common to 1.15.99 (experimental).

              sorry for the double post.

              Comment


              • #8
                It's not hard to rebuild xserver-xorg-video-ati/xserver-xorg-video-radeon against xserver 1.16 from experimental.

                Comment


                • #9
                  Originally posted by towo2099 View Post
                  It's not hard to rebuild xserver-xorg-video-ati/xserver-xorg-video-radeon against xserver 1.16 from experimental.
                  Yup it is not hard at all (for me and you at least ) but what i point out currently that is *a must* (proper binary package is not there) so user must do it .

                  Comment


                  • #10
                    Originally posted by dungeon View Post
                    Yup it is not hard at all (for me and you at least ) but what i point out currently that is *a must* (proper binary package is not there) so user must do it .
                    Can you point me to a guide? So I can try?

                    I have another problem now.

                    I'm back on my APU CPU. A8-3870k with FOSS radeon driver.
                    But steam prompt me:
                    Code:
                    Error: OpenGL GLX context is not using direct rendering, which may cause performance problems.
                    But:
                    Code:
                    glxinfo | grep rendering
                    direct rendering: Yes
                    I have installed all the steam related stuff.
                    The problem appeared when I switched from self-compiled mesa+glamor+ati to the standard set from debian.

                    What can I do?

                    Comment


                    • #11
                      I have installed all the steam related stuff.
                      You have libgl1-mesa-glx:i386 installed?

                      Comment


                      • #12
                        Originally posted by towo2099 View Post
                        You have libgl1-mesa-glx:i386 installed?
                        yeah.

                        Code:
                        aptitude search libgl1-mesa-glx
                        i A libgl1-mesa-glx
                        i   libgl1-mesa-glx:i386

                        Comment


                        • #13
                          Originally posted by lorenzoz View Post
                          Can you point me to a guide? So I can try?
                          Maybe this:

                          http://raphaelhertzog.com/2010/12/15...bian-packages/

                          Originally posted by lorenzoz View Post
                          I have another problem now.

                          I'm back on my APU CPU. A8-3870k with FOSS radeon driver.
                          But steam prompt me:
                          Code:
                          Error: OpenGL GLX context is not using direct rendering, which may cause performance problems.
                          Look at this thread, basically you need to make sure not to use shipped gcc library (and stdc++ too):

                          http://www.phoronix.com/forums/showt...ian-Steam-r600

                          Comment


                          • #14
                            Originally posted by lorenzoz View Post
                            The problem appeared when I switched from self-compiled mesa+glamor+ati to the standard set from debian.
                            Ah this one , yes self compiled can be different and with/without some problems distro packages can have . But distros prefer shared libraries, i guess you compile with --disable-llvm-shared-libs ?
                            Last edited by dungeon; 07-02-2014, 07:17 PM.

                            Comment


                            • #15
                              Originally posted by dungeon View Post
                              Maybe this:

                              http://raphaelhertzog.com/2010/12/15...bian-packages/



                              Look at this thread, basically you need to make sure not to use shipped gcc library (and stdc++ too):

                              http://www.phoronix.com/forums/showt...ian-Steam-r600
                              Solved, renamed libstdc and libgcc and now is ok.

                              Originally posted by dungeon View Post
                              Ah this one , yes self compiled can be different and with/without some problems distro packages can have . But distros prefer shared libraries, i guess you compile with --disable-llvm-shared-libs ?
                              Oh.
                              Can't see that line.

                              Code:
                              #--with-llvm-shared-libs \
                              PKG_CONFIG_PATH=/usr/lib/x86_64-linux-gnu/pkgconfig:/usr/lib/pkgconfig:/usr/local/share/pkgconfig ./autogen.sh --sysconfdir=/etc --prefix=/usr --libdir=/usr/lib/x86_64-linux-gnu \
                              --enable-debug \
                              CPPFLAGS="-m64" \
                              CXXFLAGS="-m64" \
                              --enable-64-bit --disable-32-bit \
                              --enable-texture-float \
                              --with-gallium-drivers=r600,swrast,radeonsi \
                              --with-dri-drivers="" \
                              --enable-vdpau \
                              --enable-egl --enable-gles1 --enable-gles2 \
                              --enable-glx-tls \
                              --with-egl-platforms=x11,drm \
                              --enable-gbm \
                              --enable-gallium-egl \
                              --enable-gallium-osmesa \
                              --with-osmesa-bits=32 \
                              --disable-dri3 \
                              --disable-opencl \
                              --enable-shared-glapi \
                              --disable-r600-llvm-compiler \
                              --enable-gallium-llvm
                              Anyway, solved. I aptitude-listed all my installed packages in a file. Removed libgl1-mesa-* and it removed half my system (basically everything related to X11).
                              Then I reinstalled them pointing at that file.

                              That's probably a rude way, but I don't have time to dig more.

                              Now I'm back, a stock debian sid with my APU.

                              I'll look to another guide to compile necessary stuff for my pitcairn GPU.

                              Comment

                              Working...
                              X