Announcement

Collapse
No announcement yet.

Debian + radeonsi

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #41
    Looks OK, but i don't checked those replaces ... that is yours, you can make it there how you like it .

    Comment


    • #42
      Originally posted by dungeon View Post
      Looks OK, but i don't checked those replaces ... that is yours, you can make it there how you like it .
      Ok. It works now, I've compiled lidrm, mesa, ati-driver and xserver.
      There is only a problem with xserver. When I install my self-compiled version I can't build xf86-video-ati because can't find libglamor.

      Code:
      git fetch git://anongit.freedesktop.org/xorg/xserver
      ./autogen.sh --prefix=/usr --enable-xorg --enable-glamor --disable-dmx --disable-xvfb --disable-xnest --disable-xwin
      Code:
      $locate glamor
      /usr/lib/xorg/modules/libglamoregl.so
      Do I miss any option?
      Last edited by lorenzoz; 07-29-2014, 05:59 AM.

      Comment


      • #43
        Sorry for double post, this is the entire script.

        Code:
        cat build.sh
        #!/bin/bash
        ./prepare.sh
        
        cd /drm/drm
        git fetch git://anongit.freedesktop.org/git/mesa/drm
        ./autogen.sh --prefix=/usr
        
        fakeroot checkinstall --install=no --replaces libdrm2,libdrm-intel1,libdrm-nouveau2,libdrm-radeon1 --pkgname=libdrm --pkgversion=2.4.55-git --pkgarch=amd64 --backup=no --default
        
        cd /xserver/xserver
        git fetch git://anongit.freedesktop.org/xorg/xserver
        ./autogen.sh --prefix=/usr --enable-xorg --enable-glamor --disable-dmx --disable-xvfb --disable-xnest --disable-xwin
        
        fakeroot checkinstall --install=no --replaces xserver-xorg,xserver-xorg-core,xserver-common,xserver-xorg-dev --pkgname=xserver --pkgversion=1.16-git --pkgarch=amd64 --backup=no --default
        
        cd /mesa/mesa
        git fetch git://anongit.freedesktop.org/mesa/mesa
        PKG_CONFIG_PATH=/usr/lib/x86_64-linux-gnu/pkgconfig:/usr/lib/pkgconfig:/usr/local/share/pkgconfig ./autogen.sh --sysconfdir=/etc --prefix=/usr --libdir=/usr/lib/x86_64-linux-gnu --enable-debug \
        CPPFLAGS="-m64" \
        CXXFLAGS="-m64" \
        --with-llvm-prefix=/usr/lib/llvm-3.5 \
        --enable-64-bit --disable-32-bit \
        --enable-texture-float \
        --with-gallium-drivers=swrast,radeonsi \
        --with-dri-drivers="" \
        --enable-vdpau \
        --enable-egl --enable-gles1 --enable-gles2 \
        --enable-glx-tls \                                                                                                                                                                                                                                                             
        --with-egl-platforms=x11,drm \                                                                                                                                                                                                                                                 
        --enable-gbm \                                                                                                                                                                                                                                                                 
        --enable-gallium-egl \                                                                                                                                                                                                                                                         
        --enable-gallium-osmesa \                                                                                                                                                                                                                                                      
        --with-osmesa-bits=32 \                                                                                                                                                                                                                                                        
        --enable-gallium-llvm \                                                                                                                                                                                                                                                        
        --disable-dri3 \                                                                                                                                                                                                                                                               
        --enable-shared-glapi \                                                                                                                                                                                                                                                        
        --enable-llvm-shared-libs \                                                                                                                                                                                                                                                    
                                                                                                                                                                                                                                                                                       
        fakeroot checkinstall --install=no --replaces libgles1-mesa:amd64,libgl1-mesa-dev,libglapi-mesa:amd64,libgles2-mesa:amd64,libgbm1:amd64,libegl1-mesa-dev,libgl1-mesa-dri:i386,libgl1-mesa-dri:amd64,libgl1-mesa-glx:amd64,libegl1-mesa:amd64,libgl1-mesa-swx11:amd64,libegl1-mesa-drivers:amd64,libosmesa6-dev:amd64,mesa-common-dev,libgbm-dev,libosmesa6 --pkgname=mesa --pkgversion=10.3-git --pkgarch=amd64 --backup=no --default                                                                                                                         
                                                                                                                                                                                                                                                                                       
        cd /xf86-video-ati/xf86-video-ati                                                                                                                                                                                                                                              
        git fetch git://anongit.freedesktop.org/xorg/driver/xf86-video-ati                                                                                                                                                                                                             
        ./autogen.sh --prefix=/usr --enable-glamor                                                                                                                                                                                                                                     
                                                                                                                                                                                                                                                                                       
        fakeroot checkinstall --install=no --pkgarch=amd64 --backup=no --pkgname=xf86-video-ati --pkgversion=7.4-git --replaces=xserver-xorg-video-radeon,xserver-xorg-video-ati --default                                                                                             
                                                                                                                                                                                                                                                                                       
        exit
        * prepare.sh only check I have needed packages to build correctly.

        Comment


        • #44
          I'm really sorry for these noob problems, but I don't know how to solve them.

          Today I've compiled mesa from git. It fails because now requires libdrm=>2.4.56 and I have only 2.4.55.
          So I've compiled and installed libdrm from git (2.4.56), but mesa continues to complain about libdrm lower than 2.4.56. Why?

          This is my lidrm deb builder:
          Code:
           ...
          pkgversion=$(git describe --tags) &&
          pkgversion=${pkgversion#libdrm-} &&
          fakeroot checkinstall --install=no --replaces libdrm-intel1,libdrm-nouveau2,libdrm-radeon1,libdrm-dev --pkgname=libdrm --pkgversion="${pkgversion}" --pkgarch=amd64 --backup=no --default && ...
          what's wrong?

          Comment


          • #45
            Originally posted by lorenzoz View Post
            I'm really sorry for these noob problems, but I don't know how to solve them.

            Today I've compiled mesa from git. It fails because now requires libdrm=>2.4.56 and I have only 2.4.55.
            So I've compiled and installed libdrm from git (2.4.56), but mesa continues to complain about libdrm lower than 2.4.56. Why?

            This is my lidrm deb builder:
            Code:
             ...
            pkgversion=$(git describe --tags) &&
            pkgversion=${pkgversion#libdrm-} &&
            fakeroot checkinstall --install=no --replaces libdrm-intel1,libdrm-nouveau2,libdrm-radeon1,libdrm-dev --pkgname=libdrm --pkgversion="${pkgversion}" --pkgarch=amd64 --backup=no --default && ...
            what's wrong?
            None can help?

            Comment


            • #46
              Originally posted by lorenzoz View Post
              None can help?
              I am not here every day . As i see drm libs goes to wrong dir, which is actually fine for upstream but not for debian, so you need to adjust that with something like --libdir=/usr/lib/x86_64-linux-gnu

              BTW, why don't you build proper packages when they are there as i see

              http://anonscm.debian.org/cgit/pkg-xorg/lib/libdrm.git/

              Comment


              • #47
                Originally posted by dungeon View Post
                I am not here every day . As i see drm libs goes to wrong dir, which is actually fine for upstream but not for debian, so you need to adjust that with something like --libdir=/usr/lib/x86_64-linux-gnu

                BTW, why don't you build proper packages when they are there as i see

                http://anonscm.debian.org/cgit/pkg-xorg/lib/libdrm.git/
                Thank you very much dungeon
                Now it works without any issue. Here it is my script:

                Code:
                #!/bin/bash
                
                ./prepare.sh || exit $?
                aptitude update && aptitude upgrade || exit $?
                mv -- /completed/*.deb /backup &&
                rm -r /completed
                mkdir /completed
                
                cd /build/drm/drm &&
                git reset --hard &&
                git clean -xdf &&
                git pull &&
                ./autogen.sh --prefix=/usr --enable-radeon --enable-udev --libdir=/usr/lib/x86_64-linux-gnu &&
                pkgversion=$(git describe --tags) &&
                pkgversion=${pkgversion#libdrm-} &&
                fakeroot checkinstall --install=no --replaces=libdrm-radeon1,libdrm-dev,libdrm2,libdrm-intel1,libdrm-radeon1,libdrm-nouveau2 --pkgname=libdrm --pkgversion="${pkgversion}" --pkgarch=amd64 --backup=no --default &&
                mv -- ./*.deb /completed &&
                dpkg -i /completed/libdrm*.deb || exit $?
                
                cd /build/xf86-video-ati/xf86-video-ati &&
                git reset --hard &&
                git clean -xdf &&
                git pull &&
                ./autogen.sh --prefix=/usr &&
                pkgversion=$(git describe --tags) &&
                pkgversion=${pkgversion#xf86-video-ati-} &&
                fakeroot checkinstall --install=no --replaces=xserver-xorg-video-ati,xserver-xorg-video-radeon --pkgname=xserver-radeon --pkgversion=1:"${pkgversion}" --pkgarch=amd64 --backup=no --default &&
                mv -- ./*.deb /completed &&
                dpkg -i /completed/xserver-radeon*.deb || exit $?
                
                cd /build/mesa/mesa &&
                git reset --hard &&
                git clean -xdf &&
                git pull &&
                ./autogen.sh --sysconfdir=/etc --prefix=/usr --enable-debug CPPFLAGS="-m64" CXXFLAGS="-m64" --with-llvm-prefix=/usr/lib/llvm-3.5 --enable-64-bit --disable-32-bit --enable-texture-float --enable-gles1 --enable-gles2 --with-gallium-drivers="swrast,radeonsi" --with-dri-drivers="" --enable-vdpau --enable-gallium-egl --enable-glx-tls --with-egl-platforms="drm,x11" --enable-gbm --enable-gallium-egl --enable-osmesa --enable-shared-glapi --enable-llvm-shared-libs --disable-dri3 --libdir=/usr/lib/x86_64-linux-gnu &&
                pkgversion=$(git describe --tags) &&
                pkgversion=${pkgversion#mesa-} &&
                fakeroot checkinstall --install=no --replaces libgbm-dev,libgles1-mesa:amd64,libgl1-mesa-dev,libglapi-mesa:amd64,libgles2-mesa:amd64,libgbm1:amd64,libegl1-mesa-dev,libgl1-mesa-dri:amd64,libgl1-mesa-glx:amd64,libegl1-mesa:amd64,libegl1-mesa-drivers:amd64,libosmesa6:amd64,libosmesa6-dev,mesa-common-dev --pkgname=mesa --pkgversion="${pkgversion}" --pkgarch=amd64 --backup=no --default &&
                mv -- ./*.deb /completed &&
                dpkg -i /completed/mesa*.deb || exit $?
                
                cd /build/xserver/xserver &&
                git reset --hard &&
                git clean -xdf &&
                git pull &&
                ./autogen.sh --prefix=/usr --with-xkb-output=/var/lib/xkb --enable-glamor &&
                pkgversion=$(git describe --tags) &&
                pkgversion=${pkgversion#xorg-server-} &&
                fakeroot checkinstall --install=no --replaces xserver-xorg-core,xserver-common,xserver-xorg-dev,xserver-xorg,xorg --pkgname=xserver --pkgversion="${pkgversion}" --pkgarch=amd64 --backup=no --default &&
                mv -- ./*.deb /completed &&
                dpkg -i /completed/xserver*.deb || exit $?
                
                exit 0

                Comment


                • #48
                  I'm sorry for re-use this 3d but I think it's related with my current problem.

                  My building script is working like a charme (again thanks dungeon), but I tried to compile my own kernel and I run into trouble.
                  Long story short :
                  - self compiled kernel+stock mesa/ddx/xserver/libdrm dota2 runs at ~60fps
                  - stock Debian kernel (from sid)+ self compiled mesa/ddx/xserver/libdrm dota2 runs at ~60fps
                  - self compiled kernel+self compiled mesa stack dota2 runs at 2fps.

                  Wtf???

                  Comment


                  • #49
                    Originally posted by lorenzoz View Post
                    I'm sorry for re-use this 3d but I think it's related with my current problem.

                    My building script is working like a charme (again thanks dungeon), but I tried to compile my own kernel and I run into trouble.
                    Long story short :
                    - self compiled kernel+stock mesa/ddx/xserver/libdrm dota2 runs at ~60fps
                    - stock Debian kernel (from sid)+ self compiled mesa/ddx/xserver/libdrm dota2 runs at ~60fps
                    - self compiled kernel+self compiled mesa stack dota2 runs at 2fps.

                    Wtf???
                    Well, kernel command what happens in userspace - eg. in mesa there is a code which depends how it will behave depending on what kernel you run. So it always depends what particular versions of software and drivers you run, some combinations works perfect, and some may bahave much worse or have bugs...

                    But at first look at the logs and outputs of some commands: Xorg.0.log, glxinfo, dmesg... those usually can say something. If not, look at the output of the game you run...

                    Comment


                    • #50
                      Originally posted by dungeon View Post
                      Well, kernel command what happens in userspace - eg. in mesa there is a code which depends how it will behave depending on what kernel you run. So it always depends what particular versions of software and drivers you run, some combinations works perfect, and some may bahave much worse or have bugs...

                      But at first look at the logs and outputs of some commands: Xorg.0.log, glxinfo, dmesg... those usually can say something. If not, look at the output of the game you run...
                      You mean running steam with MESA_DEBUG=1 variable and so on?
                      Running steam from terminal doesn't print out errors.
                      The only hint I've found is this error/warning in dmesg.
                      Code:
                      drm:si_dpm_set_power_state failed
                      But I don't know if it's related since graphics on 64bit run always flawlessly. I mean unigine benchmarks.
                      Last edited by lorenzoz; 09-25-2014, 02:38 AM.

                      Comment

                      Working...
                      X