Announcement

Collapse
No announcement yet.

Debian + radeonsi

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Originally posted by lorenzoz View Post
    Sorry for the double post but I can't edit my previous one.

    I've tried to build mesa (both 32 and 64 bit) with --enable-llvm-shared-library and work like a charme, so problems are related to that option.
    None can help me?

    Comment


    • #22
      Sorry for this late bump guys, but can anyone help me?
      Now debian has included glamor library but I really want to try latest stuff from git with an updated kernel too.

      Comment


      • #23
        Having built these things a few times, if you don't know what you're doing, it could take you a very long time to get it working...
        It'd be easier to use pre-made packages if they are available to you and they are available in many distribution (Arch Linux, Ubuntu, Suse).
        I don't use Debian so I can't help much with that.
        Maybe if you don't find them you could use the Ubuntu's ones?

        also maybe that can help: http://x.debian.net/howto/build-mesa.html

        Comment


        • #24
          Compiling mesa with --disable-llvm-shared-libs fails.

          This is the same error I get, but how can I solve it? Do I have to recompile llvm too?

          Comment


          • #25
            For latest radeonsi mesa you need latest LLVM (sometimes to the commit)

            Comment


            • #26
              Originally posted by geearf View Post
              For latest radeonsi mesa you need latest LLVM (sometimes to the commit)
              Mmm sorry.
              I've tried this path.

              Compiled both mesa 64bit and 32bit with --enable-llvm-shared-library; compiled without error.
              Tried installing both mesa packages, but 32bit said /etc/drirc is shared with 64bit and can't be installed. (so this option is useless??? --exclude=/etc/*,/usr/include/*)

              Now I'm running steam fine without a 32bit version of mesa and glxinfo:
              Code:
              OpenGL vendor string: X.Org
              OpenGL renderer string: Gallium 0.4 on AMD PITCAIRN
              OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.3.0-devel (git-74e100a)
              OpenGL core profile shading language version string: 3.30
              OpenGL core profile context flags: (none)
              OpenGL core profile profile mask: core profile
              Is it ok? why is steam running without a 32bit mesa? is because of this option? (fakeroot checkinstall --install=no --replaces ... libgl1-mesa-dri:i386 ... )

              Comment


              • #27
                Nevermind, steam runs on stock mesa 10.2.4 (sid version).

                So the problem is that 32bit tries to overwrite file from 64bit version.

                Comment


                • #28
                  Originally posted by lorenzoz View Post
                  So the problem is that 32bit tries to overwrite file from 64bit version.
                  You may try installing those checkinstall debs with dpkg --force-overwrite switch .

                  I mean if only that same conf file is the problem, you can install it that way. Not sure but seems like some checkinstall problem, does it work with:

                  Code:
                  checkinstall --exclude=/etc,/usr/include
                  Goal is to not have those for 32bit build checkinstall deb .

                  Comment


                  • #29
                    Originally posted by dungeon View Post
                    You may try installing those checkinstall debs with dpkg --force-overwrite switch .

                    I mean if only that same conf file is the problem, you can install it that way. Not sure but seems like some checkinstall problem, does it work with:

                    Code:
                    checkinstall --exclude=/etc,/usr/include
                    Goal is to not have those for 32bit build checkinstall deb .
                    Going to try right now.

                    I'm confused now. is it recommended to compile mesa with --disable-llvm-shared-library or is it an option?

                    Comment


                    • #30
                      Originally posted by lorenzoz View Post
                      I'm confused now. is it recommended to compile mesa with --disable-llvm-shared-library or is it an option?
                      It is not default and seems like recently does now work/compile . So no it is not recommended , you have warnings about that when you compile mesa:

                      NOTE: Mesa is attempting to use llvm shared libraries by default.
                      If you do not want to build with llvm shared libraries and instead want to
                      use llvm static libraries then add --disable-llvm-shared-libs to your configure
                      invocation and rebuild.
                      We don't need to update LLVM_LIBS in this case because the LLVM
                      install uses a shared object for each compoenent and we have
                      already added all of these objects to LLVM_LIBS.
                      Building mesa with staticly linked LLVM may cause compilation issues

                      Comment

                      Working...
                      X