Announcement

Collapse
No announcement yet.

Debian + radeonsi

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by dungeon View Post
    You may try installing those checkinstall debs with dpkg --force-overwrite switch .

    I mean if only that same conf file is the problem, you can install it that way. Not sure but seems like some checkinstall problem, does it work with:

    Code:
    checkinstall --exclude=/etc,/usr/include
    Goal is to not have those for 32bit build checkinstall deb .
    Love you!!!! DDDDD

    Gone, that hint worked!
    I installed self-compiled mesa 32bit without error.

    I rebooted and ... steam warns me that opengl glx is not using direct rendering. :crying:

    Comment


    • #32
      Originally posted by lorenzoz View Post
      I rebooted and ... steam warns me that opengl glx is not using direct rendering. :crying:
      That can be because steam shipped libraries , if some other 32bit game works fine, then problem is with that .

      Comment


      • #33
        Originally posted by dungeon View Post
        That can be because steam shipped libraries , if some other 32bit game works fine, then problem is with that .
        I've installed mesa-utils:i386.

        Code:
        $ glxinfo
        name of display: :0
        libGL error: unable to load driver: radeonsi_dri.so
        libGL error: driver pointer missing
        libGL error: failed to load driver: radeonsi
        libGL error: unable to load driver: swrast_dri.so
        libGL error: failed to load driver: swrast
        Not a steam issue I think.


        Edit:
        Code:
        locate radeonsi
        /usr/lib/i386-linux-gnu/dri/radeonsi_dri.so
        /usr/lib/i386-linux-gnu/gallium-pipe/pipe_radeonsi.la
        /usr/lib/i386-linux-gnu/gallium-pipe/pipe_radeonsi.so
        /usr/lib/i386-linux-gnu/vdpau/libvdpau_radeonsi.so
        /usr/lib/i386-linux-gnu/vdpau/libvdpau_radeonsi.so.1
        /usr/lib/i386-linux-gnu/vdpau/libvdpau_radeonsi.so.1.0
        /usr/lib/i386-linux-gnu/vdpau/libvdpau_radeonsi.so.1.0.0
        /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
        /usr/lib/x86_64-linux-gnu/gallium-pipe/pipe_radeonsi.la
        /usr/lib/x86_64-linux-gnu/gallium-pipe/pipe_radeonsi.so
        /usr/lib/x86_64-linux-gnu/vdpau/libvdpau_radeonsi.so
        /usr/lib/x86_64-linux-gnu/vdpau/libvdpau_radeonsi.so.1
        /usr/lib/x86_64-linux-gnu/vdpau/libvdpau_radeonsi.so.1.0
        /usr/lib/x86_64-linux-gnu/vdpau/libvdpau_radeonsi.so.1.0.0

        Comment


        • #34
          Code:
          LIBGL_DEBUG=verbose glxinfo
          That may say you what is wrong .

          Just keep in mind that only libraries and headers are multiarched in Debian, but not binaries
          Last edited by dungeon; 07-26-2014, 05:17 PM.

          Comment


          • #35
            Originally posted by dungeon View Post
            Code:
            LIBGL_DEBUG=verbose glxinfo
            That may say you what is wrong .

            Just keep in mind that only libraries and headers are multiarched in Debian, but not binaries
            Code:
            $ LIBGL_DEBUG=verbose glxinfo
            name of display: :0
            libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/radeonsi_dri.so
            libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/radeonsi_dri.so
            libGL: dlopen /usr/lib/i386-linux-gnu/dri/radeonsi_dri.so failed (libLLVM-3.5.so.1: cannot open shared object file: No such file or directory)
            libGL error: unable to load driver: radeonsi_dri.so
            libGL error: driver pointer missing
            libGL error: failed to load driver: radeonsi
            libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
            libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
            libGL: dlopen /usr/lib/i386-linux-gnu/dri/swrast_dri.so failed (libLLVM-3.5.so.1: cannot open shared object file: No such file or directory)
            libGL error: unable to load driver: swrast_dri.so
            libGL error: failed to load driver: swrast
            I miss LLVM-3.5:i386.
            But I can't install both LLVM-3.5:amd64 and LLVM-3.5:i386, they conflict each other.
            And without LLVM-3.5:amd64 I don't have OpenGL in my desktop.
            Hell.

            I have to manually recompile LLVM-3.5:i386?

            Comment


            • #36
              Originally posted by lorenzoz View Post
              [CODE]
              I miss LLVM-3.5:i386.
              But I can't install both LLVM-3.5:amd64 and LLVM-3.5:i386, they conflict each other.
              And without LLVM-3.5:amd64 I don't have OpenGL in my desktop.
              Hell.

              I have to manually recompile LLVM-3.5:i386?
              In last post i said and i will said again

              Just keep in mind that only libraries and headers are multiarched in Debian, but not binaries
              That means, DO NOT INSTALL PACKAGES WHICH CONTAINS I386 BINARIES!!! llvm-3.5:i386 contain binaries.

              You only need libllvm3.5:i386 package, that is installable as i see
              Last edited by dungeon; 07-27-2014, 05:19 AM.

              Comment


              • #37
                Originally posted by dungeon View Post
                In last post i said and i will said again



                That means, DO NOT INSTALL PACKAGES WHICH CONTAINS I386 BINARIES!!! llvm-3.5:i386 contain binaries.

                You only need libllvm3.5:i386 package, that is installable as i see
                LOL, sorry I'm noob, I will never forget from now on.
                Now is working fine.
                I will set up 2 chroot for compiling both mesa (32 and 64bit) and xf86-video-ati, so I can take my main system clean.

                Comment


                • #38
                  Mmm sorry.

                  I found this guide.

                  I'd like to compile also drm/xserver/glamor. But don't know how to properly build .deb, especially in "replaces" field.

                  drm
                  Code:
                  #!/bin/bash
                  fakeroot checkinstall --install=no --replaces libdrm2,libdrm-intel1,libdrm-nouveau2,libdrm-radeon1 --pkgname=libdrm --pkgversion=`cat VERSION` --pkgarch=amd64 --backup=no --default
                  xserver
                  Code:
                  #!/bin/bash
                  fakeroot checkinstall --install=no --replaces  xserver-xorg-core,xserver-common ---pkgname=xserver --pkgversion=`cat VERSION` --pkgarch=amd64 --backup=no --default
                  glamor
                  Code:
                  #!/bin/bash
                  fakeroot checkinstall --install=no --replaces  ??? ---pkgname=xserver --pkgversion=`cat VERSION` --pkgarch=amd64 --backup=no --default
                  Can you help me?

                  Comment


                  • #39
                    You don't need that separate glamor lib anymore, it is part of xserver .

                    Comment


                    • #40
                      Originally posted by dungeon View Post
                      You don't need that separate glamor lib anymore, it is part of xserver .
                      Oh ok, I understand only debian has glamor in xserver (not git one), my fault.

                      About 2 others packages? what do you think, right or wrong?

                      Comment


                      • #41
                        Looks OK, but i don't checked those replaces ... that is yours, you can make it there how you like it .

                        Comment


                        • #42
                          Originally posted by dungeon View Post
                          Looks OK, but i don't checked those replaces ... that is yours, you can make it there how you like it .
                          Ok. It works now, I've compiled lidrm, mesa, ati-driver and xserver.
                          There is only a problem with xserver. When I install my self-compiled version I can't build xf86-video-ati because can't find libglamor.

                          Code:
                          git fetch git://anongit.freedesktop.org/xorg/xserver
                          ./autogen.sh --prefix=/usr --enable-xorg --enable-glamor --disable-dmx --disable-xvfb --disable-xnest --disable-xwin
                          Code:
                          $locate glamor
                          /usr/lib/xorg/modules/libglamoregl.so
                          Do I miss any option?
                          Last edited by lorenzoz; 07-29-2014, 05:59 AM.

                          Comment


                          • #43
                            Sorry for double post, this is the entire script.

                            Code:
                            cat build.sh
                            #!/bin/bash
                            ./prepare.sh
                            
                            cd /drm/drm
                            git fetch git://anongit.freedesktop.org/git/mesa/drm
                            ./autogen.sh --prefix=/usr
                            
                            fakeroot checkinstall --install=no --replaces libdrm2,libdrm-intel1,libdrm-nouveau2,libdrm-radeon1 --pkgname=libdrm --pkgversion=2.4.55-git --pkgarch=amd64 --backup=no --default
                            
                            cd /xserver/xserver
                            git fetch git://anongit.freedesktop.org/xorg/xserver
                            ./autogen.sh --prefix=/usr --enable-xorg --enable-glamor --disable-dmx --disable-xvfb --disable-xnest --disable-xwin
                            
                            fakeroot checkinstall --install=no --replaces xserver-xorg,xserver-xorg-core,xserver-common,xserver-xorg-dev --pkgname=xserver --pkgversion=1.16-git --pkgarch=amd64 --backup=no --default
                            
                            cd /mesa/mesa
                            git fetch git://anongit.freedesktop.org/mesa/mesa
                            PKG_CONFIG_PATH=/usr/lib/x86_64-linux-gnu/pkgconfig:/usr/lib/pkgconfig:/usr/local/share/pkgconfig ./autogen.sh --sysconfdir=/etc --prefix=/usr --libdir=/usr/lib/x86_64-linux-gnu --enable-debug \
                            CPPFLAGS="-m64" \
                            CXXFLAGS="-m64" \
                            --with-llvm-prefix=/usr/lib/llvm-3.5 \
                            --enable-64-bit --disable-32-bit \
                            --enable-texture-float \
                            --with-gallium-drivers=swrast,radeonsi \
                            --with-dri-drivers="" \
                            --enable-vdpau \
                            --enable-egl --enable-gles1 --enable-gles2 \
                            --enable-glx-tls \                                                                                                                                                                                                                                                             
                            --with-egl-platforms=x11,drm \                                                                                                                                                                                                                                                 
                            --enable-gbm \                                                                                                                                                                                                                                                                 
                            --enable-gallium-egl \                                                                                                                                                                                                                                                         
                            --enable-gallium-osmesa \                                                                                                                                                                                                                                                      
                            --with-osmesa-bits=32 \                                                                                                                                                                                                                                                        
                            --enable-gallium-llvm \                                                                                                                                                                                                                                                        
                            --disable-dri3 \                                                                                                                                                                                                                                                               
                            --enable-shared-glapi \                                                                                                                                                                                                                                                        
                            --enable-llvm-shared-libs \                                                                                                                                                                                                                                                    
                                                                                                                                                                                                                                                                                                           
                            fakeroot checkinstall --install=no --replaces libgles1-mesa:amd64,libgl1-mesa-dev,libglapi-mesa:amd64,libgles2-mesa:amd64,libgbm1:amd64,libegl1-mesa-dev,libgl1-mesa-dri:i386,libgl1-mesa-dri:amd64,libgl1-mesa-glx:amd64,libegl1-mesa:amd64,libgl1-mesa-swx11:amd64,libegl1-mesa-drivers:amd64,libosmesa6-dev:amd64,mesa-common-dev,libgbm-dev,libosmesa6 --pkgname=mesa --pkgversion=10.3-git --pkgarch=amd64 --backup=no --default                                                                                                                         
                                                                                                                                                                                                                                                                                                           
                            cd /xf86-video-ati/xf86-video-ati                                                                                                                                                                                                                                              
                            git fetch git://anongit.freedesktop.org/xorg/driver/xf86-video-ati                                                                                                                                                                                                             
                            ./autogen.sh --prefix=/usr --enable-glamor                                                                                                                                                                                                                                     
                                                                                                                                                                                                                                                                                                           
                            fakeroot checkinstall --install=no --pkgarch=amd64 --backup=no --pkgname=xf86-video-ati --pkgversion=7.4-git --replaces=xserver-xorg-video-radeon,xserver-xorg-video-ati --default                                                                                             
                                                                                                                                                                                                                                                                                                           
                            exit
                            * prepare.sh only check I have needed packages to build correctly.

                            Comment


                            • #44
                              I'm really sorry for these noob problems, but I don't know how to solve them.

                              Today I've compiled mesa from git. It fails because now requires libdrm=>2.4.56 and I have only 2.4.55.
                              So I've compiled and installed libdrm from git (2.4.56), but mesa continues to complain about libdrm lower than 2.4.56. Why?

                              This is my lidrm deb builder:
                              Code:
                               ...
                              pkgversion=$(git describe --tags) &&
                              pkgversion=${pkgversion#libdrm-} &&
                              fakeroot checkinstall --install=no --replaces libdrm-intel1,libdrm-nouveau2,libdrm-radeon1,libdrm-dev --pkgname=libdrm --pkgversion="${pkgversion}" --pkgarch=amd64 --backup=no --default && ...
                              what's wrong?

                              Comment


                              • #45
                                Originally posted by lorenzoz View Post
                                I'm really sorry for these noob problems, but I don't know how to solve them.

                                Today I've compiled mesa from git. It fails because now requires libdrm=>2.4.56 and I have only 2.4.55.
                                So I've compiled and installed libdrm from git (2.4.56), but mesa continues to complain about libdrm lower than 2.4.56. Why?

                                This is my lidrm deb builder:
                                Code:
                                 ...
                                pkgversion=$(git describe --tags) &&
                                pkgversion=${pkgversion#libdrm-} &&
                                fakeroot checkinstall --install=no --replaces libdrm-intel1,libdrm-nouveau2,libdrm-radeon1,libdrm-dev --pkgname=libdrm --pkgversion="${pkgversion}" --pkgarch=amd64 --backup=no --default && ...
                                what's wrong?
                                None can help?

                                Comment

                                Working...
                                X