Announcement

Collapse
No announcement yet.

Mesa 10.0 Is Declared: OpenGL 3.2 Comes For Intel Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #51
    Originally posted by Pontostroy View Post
    sudo rm -rf /usr/local/lib*
    sudo ldconfig
    thx
    I do not understand the purpose of /usr/local/lib64 and why it interfered, but it seems to work now:

    Code:
    glxinfo | grep Open
    ATTENTION: default value of option force_s3tc_enable overridden by environment.
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD TAHITI
    OpenGL version string: 3.0 Mesa 10.0.0-devel
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:
    Code:
    cat /var/log/Xorg.0.log | grep -e glamor -e GLAMOR
    [  1457.633] (II) LoadModule: "glamoregl"
    [  1457.633] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
    [  1457.634] (II) Module glamoregl: vendor="X.Org Foundation"
    [  1457.641] (II) Loading sub module "glamoregl"
    [  1457.641] (II) LoadModule: "glamoregl"
    [  1457.641] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
    [  1457.641] (II) Module glamoregl: vendor="X.Org Foundation"
    [  1457.641] (II) glamor: OpenGL accelerated X.org driver based.
    [  1457.672] (II) glamor: EGL version 1.4 (DRI2):
    [  1457.683] (II) RADEON(0): glamor detected, initialising EGL layer.
    [  1457.952] (II) RADEON(0): Use GLAMOR acceleration.
    [  1457.952] (II) RADEON(0): Set up textured video (glamor)
    [  1457.952] (II) RADEON(0): [XvMC] Associated with GLAMOR Textured Video.
    note:
    - left 4 dead 2 now works perfect even with 8xMSAA
    - serious sam 3 still crashes after it showed the croteam-logo
    - x-albeon prelude crashes after the intro movie
    - kwin crashes when selecting openGL 3.1 as expected as only 3.0 is reached for now
    - xv with mplayer works fluently, but with color-displacement in many video files (not all) I did not recocnized a pattern of used codec, decoder, resolution, container...

    should I test something else for anyone?
    Last edited by tomtomme; 10-23-2013, 04:21 PM.

    Comment


    • #52
      Originally posted by tomtomme View Post
      xv with mplayer works fluently, but with color-displacement in many video files (not all) I did not recocnized a pattern of used codec, decoder, resolution, container...
      as a note, I get red blue colour swap on wmv based vids when using vdpau/uvd

      Comment


      • #53
        vdpau with xbmc?

        Originally posted by Tyler_K View Post
        as a note, I get red blue colour swap on wmv based vids when using vdpau/uvd
        with which player do you use vdpau+radeonsi? For AMD it was fglrx/xvba (vaapi) only a long time. The vdpau/oss solution is only some weeks old - right? And there is only a ubuntu-howto.

        I would like to test the new XBMC-vdpau/oss solution with my AMD E-350 on suse tumbleweed - if someone could help me a bit or says that it is working for him.
        Sadly pontostroy has no tumbleweed repo, but I would test it with 13.1rc or factory if this is known to work.
        And even if pontostry would build a tumbleweed repo, I first would have to learn how to apply all those (http://forum.xbmc.org/showthread.php...54&pid=1519639) patches to the 3.12 kernel. Is that complicated? I know how to compile from git and stuff but never worked with manual patches.

        And would all this work best with Tumbleweed, 13.1 or Factory (+pontostroy x11, drm-next)?
        Many questions, I know - but I am eager to test, debug and help to get this oss goodness working on suse.
        I would even write a suse-howto for the suse-SDB in the end, if someon holds my hand during the process !

        Comment


        • #54
          Originally posted by tomtomme View Post
          with which player do you use vdpau+radeonsi? For AMD it was fglrx/xvba (vaapi) only a long time. The vdpau/oss solution is only some weeks old - right? And there is only a ubuntu-howto.

          I would like to test the new XBMC-vdpau/oss solution with my AMD E-350 on suse tumbleweed - if someone could help me a bit or says that it is working for him.
          Sadly pontostroy has no tumbleweed repo, but I would test it with 13.1rc or factory if this is known to work.
          And even if pontostry would build a tumbleweed repo, I first would have to learn how to apply all those (http://forum.xbmc.org/showthread.php...54&pid=1519639) patches to the 3.12 kernel. Is that complicated? I know how to compile from git and stuff but never worked with manual patches.

          And would all this work best with Tumbleweed, 13.1 or Factory (+pontostroy x11, drm-next)?
          Many questions, I know - but I am eager to test, debug and help to get this oss goodness working on suse.
          I would even write a suse-howto for the suse-SDB in the end, if someon holds my hand during the process !
          pontonstroy repos for Mesa, and You should have it working
          (BTW Tumbleweed is not so good for Mesa+Kernel combo as Mesa is left behind too much)

          Comment


          • #55
            Originally posted by przemoli View Post
            pontonstroy repos for Mesa, and You should have it working
            (BTW Tumbleweed is not so good for Mesa+Kernel combo as Mesa is left behind too much)
            should? do you have this working? are you sure the mentioned kernel-patches are in there? I do not believe so, because then the ubuntu-guys would not have to aply these patches...

            I want to believe you, but I can NOT experiment on this HTPC. 3 other people depend on it to watch films etc....

            Comment


            • #56
              Originally posted by tomtomme View Post
              should? do you have this working? are you sure the mentioned kernel-patches are in there? I do not believe so, because then the ubuntu-guys would not have to aply these patches...

              I want to believe you, but I can NOT experiment on this HTPC. 3 other people depend on it to watch films etc....
              I have 5730M pontostroy repo contained needed Mesa, while kernel I got from Kernel:HEAD.

              Comment


              • #57
                Originally posted by przemoli View Post
                I have 5730M pontostroy repo contained needed Mesa, while kernel I got from Kernel:HEAD.
                and which xbmc branch? master?

                Comment

                Working...
                X