Announcement

Collapse
No announcement yet.

Mesa 10.0 Is Declared: OpenGL 3.2 Comes For Intel Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    mesa 10 but no radeonsi

    I compiled and installed drm 2.4.47 and then mesa 10, both from git.
    I also used the option

    Code:
     ./configure --with-gallium-drivers="radeonsi,svga,swrast"
    but still glxinfo says i am running on llvmpipe:

    Code:
    OpenGL vendor string: VMware, Inc.
    OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits)
    OpenGL version string: 2.1 Mesa 10.0.0-devel (git-975c6ce)
    OpenGL shading language version string: 1.30
    what is wrong?

    Comment


    • #22
      Originally posted by tomtomme View Post
      I compiled and installed drm 2.4.47 and then mesa 10, both from git.
      I also used the option

      Code:
       ./configure --with-gallium-drivers="radeonsi,svga,swrast"
      but still glxinfo says i am running on llvmpipe:

      Code:
      OpenGL vendor string: VMware, Inc.
      OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits)
      OpenGL version string: 2.1 Mesa 10.0.0-devel (git-975c6ce)
      OpenGL shading language version string: 1.30
      what is wrong?
      check that glamor is working, otherwise you won't be able to make use of the radeonsi, and you'll get the fallback.

      Comment


      • #23
        glamor not working...

        Originally posted by Tyler_K View Post
        check that glamor is working, otherwise you won't be able to make use of the radeonsi, and you'll get the fallback.
        thanks!
        you are right, glamor is not working:
        Code:
        cat /var/log/Xorg.0.log | grep glamor
        [     7.472] (II) LoadModule: "glamoregl"
        [     7.474] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
        [     7.478] (EE) Failed to load /usr/lib64/xorg/modules/libglamoregl.so: /usr/lib64/xorg/modules/libglamoregl.so: undefined symbol: _glapi_tls_Context
        [     7.478] (II) UnloadModule: "glamoregl"
        [     7.478] (II) Unloading glamoregl
        [     7.478] (EE) Failed to load module "glamoregl" (loader failed, 7)
        [     7.491] (WW) RADEON(0): glamor requires Load "glamoregl" in Section "Module", disabling.
        I have no clue how to enable it, or why it failed to load... so I will also try to compile it from git.

        press thumbs

        Comment


        • #24
          still not working

          I followed this howto to install glamor from git
          http://www.freedesktop.org/wiki/Software/Glamor/

          Additionaly I installed drm, mesa and xf86-video-ati from git.
          However even after creating the two glamor.conf files X11 crashes at login and glxinfo complains about unable to open display...

          if I would follow those bug report https://bugs.freedesktop.org/show_bug.cgi?id=69341
          comments I would additionaly have to compile
          - drm-next from kernel 3.12 for 3.11.3
          - llvm and clang git (now 3.3)

          to make it work on my HD 7950. Wow. Anyone know an easier solution? I do not have a clue how I extract drm-next from 3.12 - or is drm git the same? Then only llvm and clang would be missing.
          But maybe there is also something obvious that is wrong in the above glamor tutorial???
          In the arch-forums
          https://bbs.archlinux.org/viewtopic.php?id=163079
          they discuss if there must also be a radeon.conf and but nobody seems to know exactly what should be in there.

          Comment


          • #25
            back to llvmpipe

            Now I added a /etc/modules-load.d/radeon.conf file which contains "radeon" without the quotes - the arch-forum tells it should be there.

            But in combination with the 20-radeon.conf files in place I got a hard freeze and had to reset and load via failsafe. I deleted the 20-radeon.conf files as also suggested in the arch-forum and now I am back on KDE but with llvmpipe as before. At least no x11-crash or hard-freeze.

            Code:
            glxinfo | grep OpenGL
            OpenGL vendor string: VMware, Inc.
            OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits)
            OpenGL version string: 2.1 Mesa 10.0.0-devel (git-975c6ce)
            OpenGL shading language version string: 1.30
            OpenGL extensions:
            
            cat /var/log/Xorg.0.log | grep glamor
            [    27.160] (II) LoadModule: "glamoregl"
            [    27.162] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
            [    27.163] (II) Module glamoregl: vendor="X.Org Foundation"
            [    27.173] (**) RADEON(0): Option "AccelMethod" "glamor"
            cat /usr/share/X11/xorg.conf.d/glamor.conf
            cat /etc/X11/xorg.conf.d/glamor.conf

            both with
            Code:
            Section "Module"
                    Load  "dri2"
                    Load  "glamoregl"
            EndSection
            Section "Device"
                Identifier "Radeon"
                Driver "radeon"
                Option "AccelMethod" "glamor"
            EndSection

            so glamor seems to work now but I am still in falback mode... what the heck?
            any more hints are very much appreciated.

            specs:
            Radeon HD 7950 (radeonsi)
            opensuse 13.1 rc1 x64
            kernel 3.11.3
            mesa git
            xf86-video-ati git
            drm git
            glamor git
            llvm 3.3
            xserver 1.14


            cheers tomme
            Last edited by tomtomme; 10-13-2013, 09:13 AM.

            Comment


            • #26
              Originally posted by tomtomme View Post
              Code:
              cat /var/log/Xorg.0.log | grep glamor
              [    27.160] (II) LoadModule: "glamoregl"
              [    27.162] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
              [    27.163] (II) Module glamoregl: vendor="X.Org Foundation"
              [    27.173] (**) RADEON(0): Option "AccelMethod" "glamor"
              so glamor seems to work now
              No, that is not indicating that its working. Those are just the module loading and option selection acknowledgement messages. You'd get further, and explicit, messages in the log if glamor accel was enabled.

              but I am still in falback mode... what the heck?
              any more hints are very much appreciated.
              Others have found it to be finicky to get working too -- there are literally three other on-going threads related to AMD adaptors & glamor right now -- suggest you look to them for further clues (as well as being more appropriate spots (i.e. on topic) for further inquiry):

              Comment


              • #27
                Originally posted by tomtomme View Post
                Now I added a /etc/modules-load.d/radeon.conf file which contains "radeon" without the quotes - the arch-forum tells it should be there.

                But in combination with the 20-radeon.conf files in place I got a hard freeze and had to reset and load via failsafe. I deleted the 20-radeon.conf files as also suggested in the arch-forum and now I am back on KDE but with llvmpipe as before. At least no x11-crash or hard-freeze.

                Code:
                glxinfo | grep OpenGL
                OpenGL vendor string: VMware, Inc.
                OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits)
                OpenGL version string: 2.1 Mesa 10.0.0-devel (git-975c6ce)
                OpenGL shading language version string: 1.30
                OpenGL extensions:
                
                cat /var/log/Xorg.0.log | grep glamor
                [    27.160] (II) LoadModule: "glamoregl"
                [    27.162] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
                [    27.163] (II) Module glamoregl: vendor="X.Org Foundation"
                [    27.173] (**) RADEON(0): Option "AccelMethod" "glamor"
                cat /usr/share/X11/xorg.conf.d/glamor.conf
                cat /etc/X11/xorg.conf.d/glamor.conf

                both with
                Code:
                Section "Module"
                        Load  "dri2"
                        Load  "glamoregl"
                EndSection
                Section "Device"
                    Identifier "Radeon"
                    Driver "radeon"
                    Option "AccelMethod" "glamor"
                EndSection

                so glamor seems to work now but I am still in falback mode... what the heck?
                any more hints are very much appreciated.

                specs:
                Radeon HD 7950 (radeonsi)
                opensuse 13.1 rc1 x64
                kernel 3.11.3
                mesa git
                xf86-video-ati git
                drm git
                glamor git
                llvm 3.3
                xserver 1.14


                cheers tomme
                try this

                http://download.opensuse.org/reposit...openSUSE_13.1/ mesa drm llvm xf86-video-ati ftom git
                http://download.opensuse.org/reposit...openSUSE_13.1/ kernel

                Comment


                • #28
                  Originally posted by Pontostroy View Post
                  Is Kernel:HEAD behind with commits to this drm-next?

                  (And where can I find pkg for piglit ? )

                  Comment


                  • #29
                    Originally posted by Pontostroy View Post
                    thanks!
                    I tried and it gets me again the hard freeze saying something like

                    RIP fffffdf4938743fdffff radeon_vm_bo_add......

                    I tried with and without radeon.dpm=1 in grub2 and with and without the glamor.conf-files.
                    The glamor.conf files did not do anything, but with dpm=1 the freeze is at

                    ERROR radeon uvd

                    or so

                    I always have to reset and start the failsafe-mode and then the logs are gone - or is there a trick to get the old logs for you? I would like to help!
                    Here is the xorg-log from failsafe if this helps...http://pastebin.com/66ZbvUBx

                    thomas
                    Last edited by tomtomme; 10-13-2013, 04:25 PM.

                    Comment


                    • #30
                      Originally posted by tomtomme View Post
                      thanks!
                      I tried and it gets me again the hard freeze saying something like

                      RIP radeon_udo......

                      I tried with and without radeon.dpm=1 in grub2 and with and without the glamor.conf-files.
                      The glamor.conf files did not do anything, but with dpm=1 the freeze is at

                      ERROR radeon uvd

                      or so

                      I always have to reset and start the failsafe-mode and then the logs are gone - or is there a trick to get the old logs for you? I would like to help!
                      Here is the xorg-log from failsafe if this helps...http://pastebin.com/66ZbvUBx

                      thomas
                      Are You sure that proper FIRMWARE is on Your machine?

                      *_smc.bin

                      In:

                      /lib/firmware/radeon

                      Comment

                      Working...
                      X