Announcement

Collapse
No announcement yet.

Mesa 7.11 Release Candidate 1 Arrives

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by marek View Post
    Isn't your hardware slow?
    Not for OA or Q3. It was very smooth on my old GF2 MX 400. ;> I have Athlon X2 5000+, 2GB RAM and Ati x1600xt, now.

    Comment


    • #17
      Originally posted by ahlaht View Post
      That's what I had been wondering with my evergreen card for months until I found out the clock speeds are not set correctly on my system.

      If you haven't already make sure the clocks have been set to something reasonable:
      [CODE]
      cat /sys/kernel/debug/dri/0/radeon_pm_info
      Thanks, but it seems I don't have such option - there's no such file or directory

      Comment


      • #18
        Originally posted by kraftman View Post
        Thanks, but it seems I don't have such option - there's no such file or directory
        Make sure you have debugfs mounted.

        Comment


        • #19
          Originally posted by whizse View Post
          Make sure you have debugfs mounted.
          If it's enough to do: mount -t debugfs none /sys/kernel/debug

          then it doesn't work. I suppose my graphic card doesn't support the feature.

          Comment


          • #20
            Originally posted by kraftman View Post
            If it's enough to do: mount -t debugfs none /sys/kernel/debug

            then it doesn't work. I suppose my graphic card doesn't support the feature.
            It should be enough if your kernel has CONFIG_DEBUG_FS=y.

            From what I remember from the code I think radeon_pm_info should be available even if power management is disabled. (But I might be wrong too.)

            Comment


            • #21
              Originally posted by ahlaht View Post
              It should be enough if your kernel has CONFIG_DEBUG_FS=y.
              Yes, the option is enabled.

              Comment


              • #22
                Originally posted by kraftman View Post
                then it doesn't work.
                Right. With only 1 power state the file is disabled. But you could still enable it if you wanted. Just move these 3 lines:

                Code:
                diff --git a/drivers/gpu/drm/radeon/radeon_pm.c b/drivers/gpu/drm/radeon/radeon_pm.c
                index aaa19dc..d3ef691 100644
                --- a/drivers/gpu/drm/radeon/radeon_pm.c
                +++ b/drivers/gpu/drm/radeon/radeon_pm.c
                @@ -608,6 +608,10 @@ int radeon_pm_init(struct radeon_device *rdev)
                
                        INIT_DELAYED_WORK(&rdev->pm.dynpm_idle_work, radeon_dynpm_idle_work_handler);
                
                +       if (radeon_debugfs_pm_init(rdev)) {
                +               DRM_ERROR("Failed to register debugfs file for PM!\n");
                +       }
                +
                        if (rdev->pm.num_power_states > 1) {
                                /* where's the best place to put these? */
                                ret = device_create_file(rdev->dev, &dev_attr_power_profile);
                @@ -621,10 +625,6 @@ int radeon_pm_init(struct radeon_device *rdev)
                                rdev->acpi_nb.notifier_call = radeon_acpi_event;
                                register_acpi_notifier(&rdev->acpi_nb);
                 #endif
                -               if (radeon_debugfs_pm_init(rdev)) {
                -                       DRM_ERROR("Failed to register debugfs file for PM!\n");
                -               }
                -
                                DRM_INFO("radeon: power management initialized\n");
                        }
                If you try this be prepared for a crash once you read the file, but I suspect it has been disabled unnecessarily.

                Comment


                • #23
                  can't compile r300g with latest LLVM!

                  Hi,

                  for a few weeks I can't compile r300g drivers, using latest LLVM 3.0 (2.9.99.svn20110711-32.1). At the end of compiling I've got error message like this:
                  r300_dri.so.tmp: undefined reference to `LLVMAddTypeName'

                  So, any patch or help!?

                  Thanks.

                  Comment


                  • #24
                    Originally posted by ahlaht View Post
                    Right. With only 1 power state the file is disabled.
                    Thanks, but it was easier than I thought. I had to change CPU scaling governor from ondemand to performance and OpenArena just flies.

                    Comment


                    • #25
                      Originally posted by kraftman View Post
                      Thanks, but it was easier than I thought. I had to change CPU scaling governor from ondemand to performance and OpenArena just flies.
                      Thanks, that's very useful information. Just yesterday I noticed I may also have that problem. At least there is something shady about it. I didn't properly test it yet, because I also found some other bugs (sigh). I wonder if there is never end to these bugs...

                      Comment


                      • #26
                        Does this have any good changes for intel graphics? (i'm running ironlake on arch linux, so I will probably get this not too long after it goes stable)

                        Comment

                        Working...
                        X