Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dropping Ubuntu 13.10

    Ubuntu 13.10 reaches End of Life on July 17. PPAs for 13.10 will also be disabled, so if you still want to have updated drivers you should upgrade to 14.04.

    Comment


    • Hmm, is there anything I could do to use llvm 3.5 with Ubuntu 14.04, maybe from a PPA? From my limited understanding, it seems llvm 3.5 is required for SI hardware to avoid that LLVM register error with certain games, and for additional performance.

      Comment


      • Originally posted by Espionage724 View Post
        Hmm, is there anything I could do to use llvm 3.5 with Ubuntu 14.04, maybe from a PPA? From my limited understanding, it seems llvm 3.5 is required for SI hardware to avoid that LLVM register error with certain games, and for additional performance.
        Aside from manually compiling Mesa with llvm3.5, the only thing we can do is wait and hope that Oibaf will use llvm3.5 to build packages in his repo soon enough

        Comment


        • Hi guys. Today I've installed fresh Mint 17 Cinnamon x64. Also installed Oibaf drivers, Steam and Dota2.
          First, the problem was with 2 libraries that was already discussed and resolved here. I mean libgcc_s.so.1 and libstdc++.so.6 (caused direct rendering error on Steam startup), I resolved this problem.
          Second, trying to launch Dota2, I had issue with S3TC support. As it was said here, I launched steam with
          Code:
          force_s3tc_enable=true steam
          and Dota2 finally launched. But now the next problem - FPS. On Windows I have stable smooth 60 fps (Vsync on) even in big battles. But on Mint I have 25-30 FPS with same video settings.
          Is it possible to do something to increase FPS? I have Radeon HD7770.
          Help me please. Dota is the only thing why I'm not fully on Linux

          Comment


          • Originally posted by NightmareMan View Post
            Hi guys. Today I've installed fresh Mint 17 Cinnamon x64. Also installed Oibaf drivers, Steam and Dota2.
            First, the problem was with 2 libraries that was already discussed and resolved here. I mean libgcc_s.so.1 and libstdc++.so.6 (caused direct rendering error on Steam startup), I resolved this problem.
            Second, trying to launch Dota2, I had issue with S3TC support. As it was said here, I launched steam with
            Code:
            force_s3tc_enable=true steam
            and Dota2 finally launched. But now the next problem - FPS. On Windows I have stable smooth 60 fps (Vsync on) even in big battles. But on Mint I have 25-30 FPS with same video settings.
            Is it possible to do something to increase FPS? I have Radeon HD7770.
            Help me please. Dota is the only thing why I'm not fully on Linux
            Hmm, on my setup on Ubuntu 14.04 + 7850, I didn't have any issue with S3TC or have to do anything special with it with Dota 2. I would install mesa-utils and verify you're actually using oibaf's driver. Should have a line like OpenGL version string: 3.0 Mesa 10.3.0-devel (git-8ff1611 trusty-oibaf-ppa) (the trusty-oibaf-ppa part confirming the use of oibaf's driver).

            As for performance, it might help to also be using a relatively newer kernel. The newer the better (as long as it doesn't cause other issues; do keep your current kernel installed as a fallback); 3.16rc4 is pretty decent.

            Should also check if dpm is being used or not. /var/log/dmesg should mention something like [ 5.801096] [drm] radeon: dpm initialized at some point. If not, then you could try forcing the use of dpm by adding radeon.dpm=1 to /etc/default/grub and then running update-grub afterwards (if using grub bootloader). Although if dpm isn't activated by-default for you, there could be a reason why (likely instability).

            Another thing to try is to turn vsync off from within Dota 2. For some reason, Vsync is always automatically enabled for me on Dota 2, but unchecking the box turns it off. Could also try starting up Steam with vblank_mode=0 which in-turn should carry over to Dota 2.

            For another FPS trick, I heard that disabling SwapBuffersWait allows for framerate in fullscreen applications to go past the refresh rate. Not sure if this is true, but you could try it by creating a /usr/share/X11/xorg.conf.d/99-vblank.conf and adding the following to it:

            Code:
            Section "Device"
            	Identifier  "Radeon HD"
            	Driver	"radeon"
            	Option	"SwapBuffersWait"              "false"
            EndSection
            I know this works on Ubuntu + variants, but unsure of how it is on other distros.

            Could also try using R600_DEBUG=hyperz but I'm unsure if this would help performance with Dota 2 or not.

            And finally, someone mentioned the use of a boot command radeon.vm_block_size=12 which could help performance either slightly or significantly. Just add it in the same manner as that radeon.dpm=1 command above.

            Those are just some of the various tweaks I've come across; some may or may not be needed or do anything. If anything listed isn't right, feel free to correct me
            Last edited by Espionage724; 07-08-2014, 02:57 PM.

            Comment


            • Originally posted by NightmareMan View Post
              Hi guys. Today I've installed fresh Mint 17 Cinnamon x64. Also installed Oibaf drivers, Steam and Dota2.
              First, the problem was with 2 libraries that was already discussed and resolved here. I mean libgcc_s.so.1 and libstdc++.so.6 (caused direct rendering error on Steam startup), I resolved this problem.
              Second, trying to launch Dota2, I had issue with S3TC support. As it was said here, I launched steam with
              Code:
              force_s3tc_enable=true steam
              and Dota2 finally launched. But now the next problem - FPS. On Windows I have stable smooth 60 fps (Vsync on) even in big battles. But on Mint I have 25-30 FPS with same video settings.
              Is it possible to do something to increase FPS? I have Radeon HD7770.
              Help me please. Dota is the only thing why I'm not fully on Linux
              Try:
              Code:
              vblank_mode=0 force_s3tc_enable=true steam

              Comment


              • Originally posted by NightmareMan View Post
                On Windows I have stable smooth 60 fps (Vsync on) even in big battles. But on Mint I have 25-30 FPS with same video settings.
                Is it possible to do something to increase FPS? I have Radeon HD7770.
                Help me please. Dota is the only thing why I'm not fully on Linux
                Using the 3.16 kernel should give a big boost to your FPS, although i doubt it goes all the way up to 60.

                Comment


                • My glxinfo is
                  Code:
                  # glxinfo | grep OpenGL
                  OpenGL vendor string: X.Org
                  OpenGL renderer string: Gallium 0.4 on AMD CAPE VERDE
                  OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.3.0-devel (git-8ff1611 trusty-oibaf-ppa)
                  OpenGL core profile shading language version string: 3.30
                  OpenGL core profile context flags: (none)
                  OpenGL core profile profile mask: core profile
                  OpenGL core profile extensions:
                  OpenGL version string: 3.0 Mesa 10.3.0-devel (git-8ff1611 trusty-oibaf-ppa)
                  OpenGL shading language version string: 1.30
                  OpenGL context flags: (none)
                  OpenGL extensions:
                  Now I still didn't ever try to install another kernel, so decided to try other ways that you guys gave me.
                  As for the DPM - it's enabled. I checked dmesg log and there was a string that you mentioned.
                  Launching Steam with vblank_mode=0 force_s3tc_enable=true steam and disabling Vsync also didn't help
                  A trick with 99-vblank.conf file also didn't help
                  Adding command radeon.vm_block_size=12 to grub file failed, I don't know why
                  Here's output
                  Code:
                  # gedit /etc/default/grub
                  # update-grub
                  /usr/sbin/grub-mkconfig: 13: /etc/default/grub: radeon.vm_block_size=12: not found
                  As for R600_DEBUG=hyperz string, I didn't understand where to place it. To grub file?

                  So tried everything except another kernel. Will try to google now how to install it. Big thanks guys for your support

                  Comment


                  • Originally posted by asdfblah View Post
                    Try:
                    Code:
                    vblank_mode=0 force_s3tc_enable=true steam
                    Why not just make that a steam launch option for the game?

                    Code:
                    vblank_mode=0 force_s3tc_enable=true %command%

                    Comment


                    • Updated kernel to 3.16 RC4. No changes
                      P.S. Can't edit previous post

                      Comment


                      • Hi all,

                        I've added this repository on my Ubuntu 14.04 64-bits installed on a system with an AMD APU A10-6800K (richland, comes with an Integrated HD-8670D). It works pretty well for daily use (I'm not a gamer), however I'm unable to run Firefox with Hardware acceleration. It's this known on the current state of the drivers, or it's there something I'm missing?

                        Thanks.

                        Comment


                        • Originally posted by NightmareMan View Post
                          Adding command radeon.vm_block_size=12 to grub file failed, I don't know why
                          Here's output
                          Code:
                          # gedit /etc/default/grub
                          # update-grub
                          /usr/sbin/grub-mkconfig: 13: /etc/default/grub: radeon.vm_block_size=12: not found
                          As for R600_DEBUG=hyperz string, I didn't understand where to place it. To grub file?
                          The radeon.vm_block_size=12 boot command should only work on 3.16+ kernels btw, but it's inserted in the same area as the quiet splash commands (so that area should have quiet splash radeon.vm_block_size=12).

                          As for R600_DEBUG=hyperz, you use it in the same way as vblank_mode=0 (they're both enviroment variables).

                          I'm not too up-to-date as to the state of the 7770, but it could also be possible the open-source drivers just aren't up to par on it (although I doubt that's the case). Might need someone with such a card or someone more knowledgable to chime in. I know Dota 2 works great on my 7850, but it was pretty sub-par on my 7660G + 7670M laptop with supposedly more-mature open-source drivers (not radeonsi; apparently 6xxx rebrands) last I checked...

                          Comment


                          • Hi! Sorry for a late reply. I did everything what you offered, but nothing helped. And that's very strange for me....

                            Comment


                            • Hi, cann't install this drivers

                              I did
                              Code:
                              apt-add-repository ppa:oibaf/graphics-drivers
                              apt-get update
                              apt-get dist-upgrade
                              apt-get install mesa-vdpau-drivers
                              then i try to start "steam" or "LIBGL_DRIVERS_PATH=/usr/lib/{different here} steam"(i don't know what i've to add as PATH)
                              and steam says
                              Code:
                              libGL error: unable to load driver: r600_dri.so
                              libGL error: driver pointer missing
                              libGL error: failed to load driver: r600
                              libGL error: unable to load driver: swrast_dri.so
                              libGL error: failed to load driver: swrast
                              I have Radeon 7670m + 7540G and I have dancing lines when I start any linux with open drivers, so I'd like to solve this.
                              Could anybody help me?

                              Comment


                              • Originally posted by luntik2012 View Post
                                I have Radeon 7670m + 7540G and I have dancing lines when I start any linux with open drivers, so I'd like to solve this.
                                Could anybody help me?
                                As far as I remember this problem related to incompatibility between LLVM and Steam runtime dependencies (libgcc_s.so.1).
                                https://github.com/ValveSoftware/ste...time/issues/13

                                Comment

                                Working...
                                X