Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • I am also using bash scripts to update the packages, mine are also a bit hacky, but I am overall satisfied with them.

    Comment


    • Originally posted by reCAPTCHA View Post
      For FF Preferences -> Advanced -> General -> Use hw accel when avail

      For Chromium have no idea. Try installing Google Chrome, and go to Settings, show advanced settings, Use hardware acceleration when available.

      Also, what I have noticed. The issue will sooner appear if I have lots of tabs (not really ~ 20 tabs in chrome.) open. I am also on 13.10 64 bit and i7-2600K Sandy, which I think has HD Graphics 3000.

      EDIT:

      It looks like one of the latest updates from oibaf repo has solved the issue for me : )).
      have hw accel if available on for both, ff and chromium and NEVER had any issues with that. i am updateing every day and it i hand not any issues for at least 2 months.
      running an intel haswell btw.

      Comment


      • Originally posted by a user View Post
        does anybody know if there is a plan to add GL_NV_vdpau_interop to the intel drivers capabilities?

        once in the past it was possible to get VDPAU working with intel graphics.
        quoted myself in the jope that somebody knows something about it.

        Comment


        • updates from today broke mesa. gnome shell is segfaulting in mesa_dri_drivers.so
          nothing graphical works anymore.

          Comment


          • Originally posted by a user View Post
            updates from today broke mesa. gnome shell is segfaulting in mesa_dri_drivers.so
            nothing graphical works anymore.
            It works here, no problems with mesa. I just updated a minute ago, and rebooted.

            Comment


            • Originally posted by reCAPTCHA View Post
              It works here, no problems with mesa. I just updated a minute ago, and rebooted.
              maybe it is hardware dependend. am on intel haswell.

              here nothing works anymore, X can't start anymore, nothing. and the only update i did was this ppa's mesa updates.

              Comment


              • Originally posted by a user View Post
                maybe it is hardware dependend. am on intel haswell.

                here nothing works anymore, X can't start anymore, nothing. and the only update i did was this ppa's mesa updates.
                i must correct myself... x is running, only gnome shell is crashing in the mesa_dir_dirvers.so

                due to configured hotkeys i can start xbmc or firefox. the strange thing is, that these hotkeys have been configured IN gnome shell. i am missing the window frame and titlebar though.

                Comment


                • also some other programms are causing segfaults in mesa_dri_drivers.so, not only gnomeshell. 3D games fail too.

                  Comment


                  • today's update fixed it again... puh!

                    Comment


                    • Originally posted by a user View Post
                      today's update fixed it again... puh!
                      It didn't brake for me at all, and I was updating quite often. Yesterday 2 or three times actually. It happened to me that I was having problems, and no one else was reporting it. In such cases purging oibaf, and adding it again usually solves the issue.

                      Comment


                      • Originally posted by reCAPTCHA View Post
                        It didn't brake for me at all, and I was updating quite often. Yesterday 2 or three times actually. It happened to me that I was having problems, and no one else was reporting it. In such cases purging oibaf, and adding it again usually solves the issue.
                        purging oibafs ppa and readding it didn't helped. i had several programms crashing, all segfault in mesa_dri_drivers.so
                        and the mesa updates from today fixed it again. as i previously said, it may be hardware dependend, i.e. it may depend if you were having an intel, amd or nvidia graphics...

                        but in my case it broke yesterday with only updating mesa and got resolved today with only updating mesa, both from oibaf.
                        so my best bet is that the mesa git got a bug and the automated oibaf builds catched it and the next build got the fix.

                        Comment


                        • I have a MSI R7970 Lightning on Ubuntu 13.10 and it works well with the PPA, except for one thing: the fans seems to be stuck around 50-70% all the time, making my desktop too noisy to be usable.
                          I enabled dpm but it changed nothing.

                          Is there a setting somewhere that I should tweak or is it a bug?


                          For the record, here is the sensor output:
                          Code:
                          $ sensors
                          acpitz-virtual-0
                          Adapter: Virtual device
                          temp1:        +27.8C  (crit = +106.0C)
                          temp2:        +29.8C  (crit = +106.0C)
                          
                          radeon-pci-0100
                          Adapter: PCI adapter
                          temp1:        +33.0C  
                          
                          coretemp-isa-0000
                          Adapter: ISA adapter
                          Physical id 0:  +34.0C  (high = +85.0C, crit = +105.0C)
                          Core 0:         +32.0C  (high = +85.0C, crit = +105.0C)
                          Core 1:         +34.0C  (high = +85.0C, crit = +105.0C)
                          Core 2:         +30.0C  (high = +85.0C, crit = +105.0C)
                          Core 3:         +32.0C  (high = +85.0C, crit = +105.0C)
                          
                          pkg-temp-0-virtual-0
                          Adapter: Virtual device
                          temp1:        +34.0C

                          Comment


                          • Originally posted by Malizor View Post
                            I have a MSI R7970 Lightning on Ubuntu 13.10 and it works well with the PPA, except for one thing: the fans seems to be stuck around 50-70% all the time, making my desktop too noisy to be usable.
                            I enabled dpm but it changed nothing.

                            Is there a setting somewhere that I should tweak or is it a bug?


                            For the record, here is the sensor output:
                            Code:
                            $ sensors
                            acpitz-virtual-0
                            Adapter: Virtual device
                            temp1:        +27.8C  (crit = +106.0C)
                            temp2:        +29.8C  (crit = +106.0C)
                            
                            radeon-pci-0100
                            Adapter: PCI adapter
                            temp1:        +33.0C  
                            
                            coretemp-isa-0000
                            Adapter: ISA adapter
                            Physical id 0:  +34.0C  (high = +85.0C, crit = +105.0C)
                            Core 0:         +32.0C  (high = +85.0C, crit = +105.0C)
                            Core 1:         +34.0C  (high = +85.0C, crit = +105.0C)
                            Core 2:         +30.0C  (high = +85.0C, crit = +105.0C)
                            Core 3:         +32.0C  (high = +85.0C, crit = +105.0C)
                            
                            pkg-temp-0-virtual-0
                            Adapter: Virtual device
                            temp1:        +34.0C
                            IIRC this is a known bug, but I can't find the bug report... search for it in https://bugs.freedesktop.org/

                            Comment


                            • Originally posted by ultij View Post
                              Hello oibaf, are you planning to enable openmax in your builds for testing?
                              Thanks!
                              OpenMAX is now enabled.

                              Comment


                              • Originally posted by oibaf View Post
                                OpenMAX is now enabled.
                                Thanks, I updated your mesa build, installed the libomxil-bellagio packages, but it doesn't seem to work with VLC because libomx_r600.so is missing. Any thoughts?

                                Comment

                                Working...
                                X