Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Only for fun.
    nothing serious.
    But I'm missing something here?

    "...
    DISPLAY=:0.1 LD_PRELOAD=/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so firefox
    /bin/sh: symbol lookup error: /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so: undefined symbol: _glapi_tls_Dispatch
    ..."

    "...
    nash@nash:~$ DRI_PRIME=1 VDPAU_DRIVER=radeonsi vdpauinfo
    display: :0 screen: 0
    EE ../../../../../../src/gallium/drivers/radeonsi/radeonsi_pipe.c:184 r600_create_context - Unsupported chip class 6.
    Segmentation fault
    nash@nash:~$ VDPAU_DRIVER=radeonsi DRI_PRIME=1 vdpauinfo
    display: :0 screen: 0
    EE ../../../../../../src/gallium/drivers/radeonsi/radeonsi_pipe.c:184 r600_create_context - Unsupported chip class 6.
    Segmentation fault
    ..."


    Latest ubuntu 13.10 and oibaf ppa.

    Comment


    • Originally posted by Dzony.Kalafut View Post
      yes i have white screen in unigine too. If you run it from terminal you can see shader compilation errors being printed out.
      oh, indeed

      Comment


      • Updated but not much changed on my side :

        OpenGL vendor string: Intel Open Source Technology Center
        OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
        OpenGL version string: 3.0 Mesa 10.0.0-devel
        OpenGL shading language version string: 1.30
        OpenGL context flags: (none)
        OpenGL extensions:

        but might be related either to the distribution (mint15) or the hardware (hd3000).
        Does anyone else have hd3000 running properly on openGL3.2 ?
        L.

        Comment


        • For those with white screen issues: I'd be very interested, if it works with my mesa packages from https://launchpad.net/~wsnipex/+archive/test

          They are built with llvm-3.4 and also include DRI3 support. Raring and Saucy packages available.

          Comment


          • Originally posted by wsnipex View Post
            For those with white screen issues: I'd be very interested, if it works with my mesa packages from https://launchpad.net/~wsnipex/+archive/test

            They are built with llvm-3.4 and also include DRI3 support. Raring and Saucy packages available.
            Hi,

            I just tried packages from your ppa and results are the same as with olibafs ppa. Shaders are still not getting compiled. I don't know if some parts needed by mesa are still missing or there is some problem with intel drivers. Does anyone got opengl 3.2 working with ati or nvidia card and mesa 10?

            Comment


            • The latest intel drivers are causing frequent (albeit brief) compositor lockups on Sandy Bridge ... I think there was a regression, this hasn't happened to me in close to a year.

              Comment


              • Originally posted by wsnipex View Post
                For those with white screen issues: I'd be very interested, if it works with my mesa packages from https://launchpad.net/~wsnipex/+archive/test

                They are built with llvm-3.4 and also include DRI3 support. Raring and Saucy packages available.
                do you suggest using it instead of oibaf's ppa or in addition to it?
                i ask because you don't seem to have a needed new xserver package, only mesa and the device drivers.


                has anybody with an intel (especially with an haswell) been able to properly run the current unigine demos?

                Comment


                • The white and messed up screen also happens with Metro: Last Light. Any idea how to fix that on HD 4000?

                  Comment


                  • I have toshiba satellite l20-183 with xpress 200m with xubuntu 13.10. All is ok, but fullscreen youtube 360p is very slow-15-18 fps. How can i repair it?

                    $ glxinfo | grep OpenGL
                    OpenGL vendor string: X.Org R300 Project
                    OpenGL renderer string: Gallium 0.4 on ATI RC410
                    OpenGL version string: 2.1 Mesa 10.0.0-devel (git-08122e1 saucy-oibaf-ppa)
                    OpenGL shading language version string: 1.20
                    OpenGL extensions:
                    spci -v | grep VGA
                    01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RC410M [Mobility Radeon Xpress 200M] (prog-if 00 [VGA controller])
                    $ glxinfo | grep render
                    direct rendering: Yes
                    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
                    OpenGL renderer string: Gallium 0.4 on ATI RC410
                    GL_NV_blend_square, GL_NV_conditional_render, GL_NV_fog_distance,

                    Comment


                    • Originally posted by Annik View Post
                      I have toshiba satellite l20-183 with xpress 200m with xubuntu 13.10. All is ok, but fullscreen youtube 360p is very slow-15-18 fps. How can i repair it?
                      Use chrome/chromium.

                      Comment


                      • Originally posted by Annik View Post
                        I have toshiba satellite l20-183 with xpress 200m with xubuntu 13.10. All is ok, but fullscreen youtube 360p is very slow-15-18 fps. How can i repair it?
                        Adobe flash does not make use of any hardware accelerated APIs by default. You can force flash to use VDPAU in some cases, but your chips does not have the necessary hardware to accelerate it.

                        Comment


                        • white screen

                          white in some games too, some erros we need to wait for 10.0

                          Comment


                          • Is there an expected date for MESA 10.0 / 10.1 to be released?

                            Comment


                            • mesa 10

                              Originally posted by cRaZy-bisCuiT View Post
                              Is there an expected date for MESA 10.0 / 10.1 to be released?
                              mesa 10- 27 november

                              mesa 10.1- February

                              Comment


                              • Hmm, on my 7660G + 7670M dual graphics laptop (with Ubuntu 13.10 + kernel 3.12 daily), I seem to have color banding. It's mostly noticeable when I open up the dash on Ubuntu.

                                Any ideas as what I could do to fix it? The banding doesn't exist on fglrx.

                                Comment

                                Working...
                                X