Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by Bushido_root View Post
    Wait, why would you disable updates for 12.04 LTS and 12.10 when they're not EOL until for another good 5-8 months?
    Because I am providing this for free in my free time, I am now only personally interested in 13.10, nobody is willing to sponsor the work needed to support old releases and anyway if someone really want to use experimental drivers could upgrade to latest version which offer a better base.

    Comment


    • Originally posted by oibaf View Post
      Because I am providing this for free in my free time, I am now only personally interested in 13.10, nobody is willing to sponsor the work needed to support old releases and anyway if someone really want to use experimental drivers could upgrade to latest version which offer a better base.
      I see.... Okay, I respect your choice.

      But the truth is that 13.10 is still buggy and there are a lot more who still use the previous releases (especially 12.04 and 12.10), and 13.04 is EOL in Jan....

      Anyways thanks for the update and providing this PPA, I guess I'll look into using Raring packages on Quantal.

      Comment


      • I am using a i5-3320M CPU with i5-3320M CPU with a HD4000. Is OpenGL 3.2 already supported for that model? The output of glxinfo states that I still use OpenGL 3.0. Any ideas?

        Comment


        • Originally posted by cRaZy-bisCuiT View Post
          I am using a i5-3320M CPU with i5-3320M CPU with a HD4000. Is OpenGL 3.2 already supported for that model? The output of glxinfo states that I still use OpenGL 3.0. Any ideas?
          Which Ubuntu version do you use?

          Comment


          • Here you go:
            arch@8470p:~$ lsb_release -a
            No LSB modules are available.
            Distributor ID: Ubuntu
            Description: Ubuntu 13.10
            Release: 13.10
            Codename: saucy
            arch@8470p:~$ uname -a
            Linux 8470p 3.11.0-13-generic #20-Ubuntu SMP Wed Oct 23 07:38:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

            Comment


            • @oibaf:

              As i am stuck on 13.04 because of other packages (ROS). Do you think i could use the packages for 13.10 ?
              If so which Xserver packages would i need to install?

              Thank you in advance.

              bajo

              Comment


              • Originally posted by oibaf View Post
                I uploaded a xorg version which should fix the Intel issues and hopefully enable OpenGL 3.3, please test.

                Also I disabled updating packages for 12.04 and 12.10, and I'll also remove all the packages on the PPA soon.
                Should this work on 13.04 ?
                Because i can not move to 13.10 and have problems with my i5-4200U.

                Thank you for your work.

                bajo

                Comment


                • Originally posted by oibaf View Post
                  I uploaded a xorg version which should fix the Intel issues and hopefully enable OpenGL 3.3, please test.
                  I have an Intel ci5 2405s cpu and would like some feedback as to the resolution for the render ring errors. I haven't seen anyone say that it is fixed but more like it is better.
                  Thanks

                  Comment


                  • first, thanks oibaf, i see now core profile of 3.3 with my i3 haswell.

                    finally i even can run the uniigen heaven benchmark, ... though it is all white. yes, when the actuall rd demo runs (or benchmark) the whole screen is just plain white, except for the gui elements (buttons, configuration dialog etc.). the 3d rendering is just plain white.

                    anybody an idea?

                    Comment


                    • Originally posted by a user View Post
                      first, thanks oibaf, i see now core profile of 3.3 with my i3 haswell.

                      finally i even can run the uniigen heaven benchmark, ... though it is all white. yes, when the actuall rd demo runs (or benchmark) the whole screen is just plain white, except for the gui elements (buttons, configuration dialog etc.). the 3d rendering is just plain white.

                      anybody an idea?
                      I am on radeonsi (different driver) but my system renders Heaven and even Valley perfectly (I need the MESA_GL_VERSION_OVERRIDE=3.2 MESA_GLSL_VERSION_OVERRIDE=150 args though). Do you have libtxc-dxtn installed?

                      Comment


                      • Originally posted by jsa1983 View Post
                        I am on radeonsi (different driver) but my system renders Heaven and even Valley perfectly (I need the MESA_GL_VERSION_OVERRIDE=3.2 MESA_GLSL_VERSION_OVERRIDE=150 args though). Do you have libtxc-dxtn installed?
                        those overrides have no effect.

                        i have libtxc-dxtn-s2tc0 installed.

                        Comment


                        • Hi,

                          Thanks for the driver updates. I think there is still something wrong with the drivers. there are now two opengl versions reported by glxinfo. One is 3.0 with glsl 1.3 and the other one is 3.3 with glsl 3.3(should be 1.5 i think). I tried running unigine heaven and linux version of doom 3 bfg edition and they do not work. In both cases shaders do not get compiled.

                          Here is my glxinfo:
                          http://www.pasteall.org/47210/bash

                          Doom errors:
                          http://www.pasteall.org/47211

                          Unigine errors:
                          http://www.pasteall.org/47212

                          Comment


                          • Hi,

                            Thanks for the builds olibaf. even now that mesa is reporting gl 3.3 on iwy bridge, there is still something wrong with the intel graphics. I tried running Linux build of Doom 3 BFG and Unigine Heaven and in both cases shaders do not get compiled. I am currently doing some school work in LWJGL and my program that is using oppen gl 3.2 is not working with this build either.

                            Comment


                            • Originally posted by Dzony.Kalafut View Post
                              Hi,

                              Thanks for the builds olibaf. even now that mesa is reporting gl 3.3 on iwy bridge, there is still something wrong with the intel graphics. I tried running Linux build of Doom 3 BFG and Unigine Heaven and in both cases shaders do not get compiled. I am currently doing some school work in LWJGL and my program that is using oppen gl 3.2 is not working with this build either.
                              is this related to the issue i mentioned above?

                              i have the whole screen rendered in plain white when running the unigine demo/benchmark.

                              Comment


                              • Originally posted by a user View Post
                                is this related to the issue i mentioned above?

                                i have the whole screen rendered in plain white when running the unigine demo/benchmark.
                                yes i have white screen in unigine too. If you run it from terminal you can see shader compilation errors being printed out.

                                Comment

                                Working...
                                X