Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by lolren View Post
    Mesa warning: couldn't open libtxc_dxtn.so, software DXTn compression/decompression unavailable
    r300: DRM version: 2.22.0, Name: ATI RV530, ID: 0x71c5, GB: 1, Z: 2
    r300: GART size: 509 MB, VRAM size: 128 MB
    r300: AA compression RAM: YES, Z compression RAM: YES, HiZ RAM: YES
    Mesa warning: couldn't open libtxc_dxtn.so, software DXTn compression/decompression unavailable
    fixme:win:EnumDisplayDevicesW ((null),0,0x195f200,0x00000000), stub!
    X Error of failed request: BadWindow (invalid Window parameter)
    Major opcode of failed request: 10 (X_UnmapWindow)
    Resource id in failed request: 0x5800001
    Serial number of failed request: 110
    Current serial number in output stream: 113
    lolren@lolren-iMac:~/.wine/drive_c/Program Files (x86)/Serious Sam 2/Bin$ \

    why libxtc could not be opened? kubuntu 12.10 user here 10x
    Seems like you're running a 32-bit Windows program in Wine. You would need the 32-bit version of the package as well, which you can see in the repository as :i386.

    Comment


    • Intel drivers

      I just installed your ppa on my Ubuntu 12.10 which is installed on ASUS K53E laptop that comes with 2nd gen i5 and Intel HD3000 video. Earlier on I had the stock drivers and had SNA enabled via xorg. I updated to your driver via PPA and before that I removed the xorg so as not to cause any conflict. However after upgrading and rebooting, I noticed that SNA was not activated and I had to resort to creating the xorg to get SNA enabled. While this is fine, the xorg ppa intel drivers don't seem to need the xorg hack as they come with SNA enabled by default.

      Comment


      • Originally posted by linuxforall View Post
        I just installed your ppa on my Ubuntu 12.10 which is installed on ASUS K53E laptop that comes with 2nd gen i5 and Intel HD3000 video. Earlier on I had the stock drivers and had SNA enabled via xorg. I updated to your driver via PPA and before that I removed the xorg so as not to cause any conflict. However after upgrading and rebooting, I noticed that SNA was not activated and I had to resort to creating the xorg to get SNA enabled. While this is fine, the xorg ppa intel drivers don't seem to need the xorg hack as they come with SNA enabled by default.
        Yes, I am just providing the -intel default here, no SNA forcing.

        Comment


        • Originally posted by oibaf View Post
          Yes, I am just providing the -intel default here, no SNA forcing.
          Thank you, so I presume its safe to enable it via xorg, if so how can we disable vsync to get glxgears to do more than 60fps?

          Comment


          • I think you can just disable GLXVBlank in xorg.conf (Option "GLXVBlank" "False"), which is probably in the Device section.

            Comment


            • Originally posted by AlbertP View Post
              I think you can just disable GLXVBlank in xorg.conf (Option "GLXVBlank" "False"), which is probably in the Device section.
              Thanks will give that a try.

              Comment


              • Originally posted by linuxforall View Post
                Thank you, so I presume its safe to enable it via xorg, if so how can we disable vsync to get glxgears to do more than 60fps?
                You can disable it with .drirc file in your home
                <driconf>
                <device screen="0" driver="dri2">
                <application name="Default">
                <option name="vblank_mode" value="0" />
                </application>
                </device>
                </driconf>

                Consider vblank_mode option 0 or 1 disable vblank, 2 or 3 enable it; you need to reboot after the configuration of .drirc file.

                by

                Comment


                • Originally posted by dentaku65 View Post
                  You can disable it with .drirc file in your home
                  <driconf>
                  <device screen="0" driver="dri2">
                  <application name="Default">
                  <option name="vblank_mode" value="0" />
                  </application>
                  </device>
                  </driconf>

                  Consider vblank_mode option 0 or 1 disable vblank, 2 or 3 enable it; you need to reboot after the configuration of .drirc file.

                  by
                  Thanks.

                  Will give this a try, so far xorg edit seems to be holding.

                  Comment


                  • Any chance for this ppa to host the latest released intel-vaapi driver 1.19, it has many improvements over the one thats included in Ubuntu 12.10, that one is version 1.17

                    Thanks.

                    Comment


                    • Originally posted by linuxforall View Post
                      Any chance for this ppa to host the latest released intel-vaapi driver 1.19, it has many improvements over the one thats included in Ubuntu 12.10, that one is version 1.17

                      Thanks.
                      I can easily backport 1.19 as soon as it's in Debian, currently still at 1.17: http://packages.debian.org/source/si...l-vaapi-driver

                      If you care you may ask the Debian maintainer to update to 1.19.

                      Comment

                      Working...
                      X