Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by oibaf View Post
    Did the packages install cleanly? You lose the borders in KDE?
    Yes exactly, first of all I did an ppa-purge of xorg edgers. Reboot, all run fine. Later I add your ppa, and update, dist-upgrade, reboot, no effects , no bordes in kde, with unity all run fine! When I see on muon, I see that I have installed wayland 1.0.5, can be this the problem o.o?

    I have kde 4.11 on kubuntu 13.04.

    Comment


    • Originally posted by pandev92 View Post
      Yes exactly, first of all I did an ppa-purge of xorg edgers. Reboot, all run fine. Later I add your ppa, and update, dist-upgrade, reboot, no effects , no bordes in kde, with unity all run fine! When I see on muon, I see that I have installed wayland 1.0.5, can be this the problem o.o?

      I have kde 4.11 on kubuntu 13.04.
      I forget to say that you should enable both PPAs (https://launchpad.net/~oibaf/+archive/graphics-drivers/ and https://launchpad.net/~oibaf/+archive/test/). Can you also post the output of:
      apt-cache rdepends libwayland0 libwayland-client0 libwayland-server0 libwayland-dev libwayland-cursor0
      with kde 4.11 installed?

      Comment


      • Originally posted by oibaf View Post
        I forget to say that you should enable both PPAs (https://launchpad.net/~oibaf/+archive/graphics-drivers/ and https://launchpad.net/~oibaf/+archive/test/). Can you also post the output of:

        with kde 4.11 installed?
        I will try now

        Comment


        • Originally posted by oibaf View Post
          Try again this PPA, hopefully the wayland problem should be fixed. Let me know if there are problems (e.g. error installing packages): https://launchpad.net/~oibaf/+archive/test/
          I missed this message. I will give it a try tonight to see if it works. At least, by looking at the build log, libwayland-egl.so is included in the libegl-drivers package. I could not get that library compiled when trying to build your mesa ppa source package with libwayland-*-1.2 from your test ppa... I just don't know why, even though I uncommented the debian/rules line relating to wayland as an egl platform.

          Regards

          Comment


          • Originally posted by jsa1983 View Post
            I missed this message. I will give it a try tonight to see if it works. At least, by looking at the build log, libwayland-egl.so is included in the libegl-drivers package. I could not get that library compiled when trying to build your mesa ppa source package with libwayland-*-1.2 from your test ppa... I just don't know why, even though I uncommented the debian/rules line relating to wayland as an egl platform.

            Regards
            I am posting this from a KDE 4.11 session while admiring kwin's window decorations... so it works. However, the package kde-window-manager requires libwayland0 (>= 1.0.2) and libwayland 1.2 seems to be split across three different libs, none of them libwayland0-1.2, so in order to install kde-window-manager its .deb control file must be edited in order to delete that dependency or to change it to (I assume) libwayland-client0.

            For those that do not know how to edit the control file, see below. Note however, that the upgrade process may result in your screwing your KDE installation, so first be sure you know how to revert to raring's KDE-4.10 packages.

            Code:
            wget https://launchpad.net/~kubuntu-ppa/+archive/backports/+files/kde-window-manager_4.11.1-0ubuntu1%7Eubuntu13.04%7Eppa2_amd64.deb
            or

            Code:
            wget https://launchpad.net/~kubuntu-ppa/+archive/backports/+files/kde-window-manager_4.11.1-0ubuntu1%7Eubuntu13.04%7Eppa2_i386.deb
            and then:

            Code:
            mkdir tmp
            dpkg-deb -x your_package_name.deb tmp
            dpkg-deb --control your_package_name.deb tmp/DEBIAN
            Then edit tmp/DEBIAN/control and change the requirements accordingly. After the edit, do:

            Code:
            mv your_package_name.deb your_package_name.deb.old
            dpkg -b tmp your_package_name.deb
            And install the new package with dpkg. Manual install of packages could be required, but once a few dependencies have been installed, a apt-get dist-upgrade runs nice and everything installs OK.

            Regards,

            Comment


            • Originally posted by Espionage724 View Post
              Hmm, so I tried to enable the use of Glamor, but was only presented with a black screen and mouse pointer. Glamor loads properly it seems by looking at /var/log/Xorg.0.log. I heard that Glamor might be incompatible with X Server 1.13 though (I have 1.13.3), is this true?
              Any ideas from anyone about this?

              Comment


              • Originally posted by Espionage724 View Post
                Any ideas from anyone about this?
                Well, glamor is compatible with xserver-xorg 1.13. I am using raring's 1.13.3 and glamor 0.5+git(around April 2013) from oibaf's ppa and my desktop loads nicely. So probably it is another bug or a misconfiguration. Are you sure the xorg.conf options are in place (i.e. Load "glamoregl" in the Module section and Option "AccelMethod" "glamor" in the Device section, although per this commit http://cgit.freedesktop.org/xorg/dri...9ec50ef3b769f1 glamor should be enabled by default on radeonsi hardware)?

                Comment


                • Originally posted by pali View Post
                  And you planning in future add radeonsi support also to precise? Because precise is supported until 2017.
                  @oibaf: Is there any problem to compile radeonsi also for precise in your ppa?

                  Comment


                  • Originally posted by jsa1983 View Post
                    Well, glamor is compatible with xserver-xorg 1.13. I am using raring's 1.13.3 and glamor 0.5+git(around April 2013) from oibaf's ppa and my desktop loads nicely. So probably it is another bug or a misconfiguration. Are you sure the xorg.conf options are in place (i.e. Load "glamoregl" in the Module section and Option "AccelMethod" "glamor" in the Device section, although per this commit http://cgit.freedesktop.org/xorg/dri...9ec50ef3b769f1 glamor should be enabled by default on radeonsi hardware)?
                    I use raring (Xubuntu), these drivers, and I'm on Norther Island hardware (7660G + 7670M). I also installed the xorg glamor package (and dependencies).

                    Here's my xorg.conf:
                    Code:
                    Section "Module"
                            Load "dri2"
                            Load "glamoregl"
                    EndSection
                    
                    Section "Device"
                            Identifier "radeon"
                            Driver "radeon"
                            Option "AccelMethod" "glamor"
                    EndSection
                    And my Xorg.0.log: http://pastebin.com/raw.php?i=LQFfrqKF

                    But after I reboot after setting my xorg.conf to use Glamor, I'm presented only with a black screen, with a mouse pointer on it. It's almost as if Xfce isn't loading fully or something.

                    Just a quick question though about the Device section. Would I need to add another device section and somehow specify both devices in a dual graphics setup for glamor? Or does the Device section cover all devices?

                    And also a general question; if I start 3D applications with DRI_PRIME=1 (my dGPU), they don't actually show anything at all if I have Xfce set to use no composting. If I enable composting though, the applications show up. Any ideas why, or what I could do to fix this (I don't want composting; I only want performance essentially)

                    Comment


                    • Originally posted by Espionage724 View Post
                      I use raring (Xubuntu), these drivers, and I'm on Norther Island hardware (7660G + 7670M). I also installed the xorg glamor package (and dependencies).

                      Here's my xorg.conf:
                      Code:
                      Section "Module"
                              Load "dri2"
                              Load "glamoregl"
                      EndSection
                      
                      Section "Device"
                              Identifier "radeon"
                              Driver "radeon"
                              Option "AccelMethod" "glamor"
                      EndSection
                      And my Xorg.0.log: http://pastebin.com/raw.php?i=LQFfrqKF

                      But after I reboot after setting my xorg.conf to use Glamor, I'm presented only with a black screen, with a mouse pointer on it. It's almost as if Xfce isn't loading fully or something.

                      Just a quick question though about the Device section. Would I need to add another device section and somehow specify both devices in a dual graphics setup for glamor? Or does the Device section cover all devices?

                      And also a general question; if I start 3D applications with DRI_PRIME=1 (my dGPU), they don't actually show anything at all if I have Xfce set to use no composting. If I enable composting though, the applications show up. Any ideas why, or what I could do to fix this (I don't want composting; I only want performance essentially)
                      I am afraid I cannot give you any advice regarding prime or dual gpus. My systems have a single gpu.
                      With regard to your log, to me it seems normal. There are no errors and glamor seems to be initialized correctly. So the black screen with the cursos looks more like a bug. There seem to be some bug reports over there with more or less similar problems: http://lists.x.org/archives/xorg-dri...st/025084.html https://bugzilla.redhat.com/show_bug.cgi?id=998175
                      Maybe you should look for similar bug reports and if none of them resemble to your problem, open a bug report.

                      Just out of curiosity, if NI cards use r600g, and thus do not require glamor, why do you want to try glamor if you can launch Xorg just with the radeon DDX?

                      Comment


                      • Originally posted by jsa1983 View Post
                        I am afraid I cannot give you any advice regarding prime or dual gpus. My systems have a single gpu.
                        With regard to your log, to me it seems normal. There are no errors and glamor seems to be initialized correctly. So the black screen with the cursos looks more like a bug. There seem to be some bug reports over there with more or less similar problems: http://lists.x.org/archives/xorg-dri...st/025084.html https://bugzilla.redhat.com/show_bug.cgi?id=998175
                        Maybe you should look for similar bug reports and if none of them resemble to your problem, open a bug report.

                        Just out of curiosity, if NI cards use r600g, and thus do not require glamor, why do you want to try glamor if you can launch Xorg just with the radeon DDX?
                        Thanks for the suggestion; I'll try looking through some bug reports a bit later.

                        Hmm, not too sure, just thought Glamor would be helpful to overall performance or possibly fix that issue I mentioned about the dGPU not rendering anything without desktop compositing. I'm pretty new to most of this stuff

                        Comment


                        • I just wanted to note that on Tomasz Makarewicz's ppa there is a glamor 0.5.1 version already (https://launchpad.net/~makson96/+archive/mesa). However, from the glamor git log (http://cgit.freedesktop.org/xorg/driver/glamor/log/) it seems that 0.5.1 is only two revisions ahead of oibaf's ppa build.

                          @Espionage724, maybe you could try that 0.5.1 version and see if it solves the problem you were describing.

                          Edit: Oops, sorry, I had not realized that ppa does not have builds for raring, so it may not install properly.
                          Last edited by jsa1983; 09-14-2013, 06:37 AM. Reason: Additional information

                          Comment


                          • hi

                            /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_amd64.deb
                            trying to overwrite '/usr/lib/x86_64-linux-gnu/libwayland-client.so.0.1.0', which is also in package libwayland0:amd64 1.0.5-0ubuntu1

                            /var/cache/apt/archives/libwayland-server0_1.2.1-1~r~gd_amd64.deb
                            trying to overwrite '/usr/lib/x86_64-linux-gnu/libwayland-server.so.0', which is also in package libwayland0:amd64 1.0.5-0ubuntu1
                            vincenzo@AthlonII-X4-640:~$ sudo apt-get dist-upgrade
                            Lettura elenco dei pacchetti... Fatto
                            Generazione albero delle dipendenze
                            Lettura informazioni sullo stato... Fatto
                            utile eseguire "apt-get -f install" per correggere ci.
                            I seguenti pacchetti hanno dipendenze non soddisfatte:
                            libegl1-mesa : Dipende: libwayland-client0 (>= 1.2.1) ma non installato
                            Dipende: libwayland-server0 (>= 1.2.1) ma non installato
                            libegl1-mesa-drivers : Dipende: libwayland-client0 (>= 1.2.1) ma non installato
                            Dipende: libwayland-server0 (>= 1.2.1) ma non installato
                            libgbm1 : Dipende: libwayland-client0 (>= 1.2.1) ma non installato
                            Dipende: libwayland-server0 (>= 1.2.1) ma non installato
                            E: Dipendenze non trovate. Riprovare usando -f.
                            vincenzo@AthlonII-X4-640:~$ sudo apt-get -f install
                            Lettura elenco dei pacchetti... Fatto
                            Generazione albero delle dipendenze
                            Lettura informazioni sullo stato... Fatto
                            Correzione delle dipendenze... Fatto
                            I seguenti pacchetti saranno inoltre installati:
                            libwayland-client0 libwayland-server0
                            I seguenti pacchetti NUOVI saranno installati:
                            libwayland-client0 libwayland-server0
                            0 aggiornati, 2 installati, 0 da rimuovere e 23 non aggiornati.
                            9 non completamente installati o rimossi.
                            necessario scaricare 0 B/52,7 kB di archivi.
                            Dopo quest'operazione, verranno occupati 188 kB di spazio su disco.
                            Continuare [S/n]? s
                            (Lettura del database... 202732 file e directory attualmente installati.)
                            Estrazione di libwayland-client0:amd64 (da .../libwayland-client0_1.2.1-1~r~gd_amd64.deb)...
                            dpkg: errore nell'elaborare /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_amd64.deb (--unpack):
                            tentata sovrascrittura di "/usr/lib/x86_64-linux-gnu/libwayland-client.so.0.1.0" presente anche nel pacchetto libwayland0:amd64 1.0.5-0ubuntu1
                            Estrazione di libwayland-server0:amd64 (da .../libwayland-server0_1.2.1-1~r~gd_amd64.deb)...
                            dpkg: errore nell'elaborare /var/cache/apt/archives/libwayland-server0_1.2.1-1~r~gd_amd64.deb (--unpack):
                            tentata sovrascrittura di "/usr/lib/x86_64-linux-gnu/libwayland-server.so.0" presente anche nel pacchetto libwayland0:amd64 1.0.5-0ubuntu1
                            Si sono verificati degli errori nell'elaborazione:
                            /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_amd64.deb
                            /var/cache/apt/archives/libwayland-server0_1.2.1-1~r~gd_amd64.deb
                            E: Sub-process /usr/bin/dpkg returned an error code (1)
                            vincenzo@AthlonII-X4-640:~$

                            Comment


                            • Originally posted by Vincenzov View Post
                              hi

                              /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_amd64.deb
                              trying to overwrite '/usr/lib/x86_64-linux-gnu/libwayland-client.so.0.1.0', which is also in package libwayland0:amd64 1.0.5-0ubuntu1

                              /var/cache/apt/archives/libwayland-server0_1.2.1-1~r~gd_amd64.deb
                              trying to overwrite '/usr/lib/x86_64-linux-gnu/libwayland-server.so.0', which is also in package libwayland0:amd64 1.0.5-0ubuntu1
                              vincenzo@AthlonII-X4-640:~$ sudo apt-get dist-upgrade
                              Lettura elenco dei pacchetti... Fatto
                              Generazione albero delle dipendenze
                              Lettura informazioni sullo stato... Fatto
                              utile eseguire "apt-get -f install" per correggere ci.
                              I seguenti pacchetti hanno dipendenze non soddisfatte:
                              libegl1-mesa : Dipende: libwayland-client0 (>= 1.2.1) ma non installato
                              Dipende: libwayland-server0 (>= 1.2.1) ma non installato
                              libegl1-mesa-drivers : Dipende: libwayland-client0 (>= 1.2.1) ma non installato
                              Dipende: libwayland-server0 (>= 1.2.1) ma non installato
                              libgbm1 : Dipende: libwayland-client0 (>= 1.2.1) ma non installato
                              Dipende: libwayland-server0 (>= 1.2.1) ma non installato
                              E: Dipendenze non trovate. Riprovare usando -f.
                              vincenzo@AthlonII-X4-640:~$ sudo apt-get -f install
                              Lettura elenco dei pacchetti... Fatto
                              Generazione albero delle dipendenze
                              Lettura informazioni sullo stato... Fatto
                              Correzione delle dipendenze... Fatto
                              I seguenti pacchetti saranno inoltre installati:
                              libwayland-client0 libwayland-server0
                              I seguenti pacchetti NUOVI saranno installati:
                              libwayland-client0 libwayland-server0
                              0 aggiornati, 2 installati, 0 da rimuovere e 23 non aggiornati.
                              9 non completamente installati o rimossi.
                              necessario scaricare 0 B/52,7 kB di archivi.
                              Dopo quest'operazione, verranno occupati 188 kB di spazio su disco.
                              Continuare [S/n]? s
                              (Lettura del database... 202732 file e directory attualmente installati.)
                              Estrazione di libwayland-client0:amd64 (da .../libwayland-client0_1.2.1-1~r~gd_amd64.deb)...
                              dpkg: errore nell'elaborare /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_amd64.deb (--unpack):
                              tentata sovrascrittura di "/usr/lib/x86_64-linux-gnu/libwayland-client.so.0.1.0" presente anche nel pacchetto libwayland0:amd64 1.0.5-0ubuntu1
                              Estrazione di libwayland-server0:amd64 (da .../libwayland-server0_1.2.1-1~r~gd_amd64.deb)...
                              dpkg: errore nell'elaborare /var/cache/apt/archives/libwayland-server0_1.2.1-1~r~gd_amd64.deb (--unpack):
                              tentata sovrascrittura di "/usr/lib/x86_64-linux-gnu/libwayland-server.so.0" presente anche nel pacchetto libwayland0:amd64 1.0.5-0ubuntu1
                              Si sono verificati degli errori nell'elaborazione:
                              /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_amd64.deb
                              /var/cache/apt/archives/libwayland-server0_1.2.1-1~r~gd_amd64.deb
                              E: Sub-process /usr/bin/dpkg returned an error code (1)
                              vincenzo@AthlonII-X4-640:~$
                              Try updating again, maybe it is a problem of a package still not fully build when you updated. If not then complain to who didn't the tests when I asked some days ago

                              Comment


                              • @jsa1983: I backported glamor 0.5.1 (which is the same of what already was there but with a new version number, which is now required anyway by updated ati).

                                I am posting this from a KDE 4.11 session while admiring kwin's window decorations... so it works. However, the package kde-window-manager requires libwayland0 (>= 1.0.2) and libwayland 1.2 seems to be split across three different libs, none of them libwayland0-1.2, so in order to install kde-window-manager its .deb control file must be edited in order to delete that dependency or to change it to (I assume) libwayland-client0.
                                Yes, this is why I asked the output of apt-cache rdepends a few posts ago. I'll see to backport that package in my test PPA if you identified the package (not on the main PPA so to not overwrite kde 4.10 package). Which PPA is that package from so that I can backport and recompile from it?

                                @pali:
                                And you planning in future add radeonsi support also to precise? Because precise is supported until 2017.
                                @oibaf: Is there any problem to compile radeonsi also for precise in your ppa?
                                Yes, the lack of free time

                                Comment

                                Working...
                                X