Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Updated MESA packages

    Finally all the mesa build issues are fixed now. Updated mesa packages are building now.

    Comment


    • Originally posted by oibaf View Post
      Finally all the mesa build issues are fixed now. Updated mesa packages are building now.
      As reported by someone there is a link problem with the classic drivers (r200 radeon i915 i965) so you may want to revert to mesa ubuntu packages if you use any of them. Hopefully it will be fixed in some way.

      Comment


      • Originally posted by oibaf View Post
        As reported by someone there is a link problem with the classic drivers (r200 radeon i915 i965) so you may want to revert to mesa ubuntu packages if you use any of them. Hopefully it will be fixed in some way.
        Fixed in the updated packages.

        Comment


        • Mesa config

          Hi,

          Can you share what arguments you use for ./configure ? Thanks.

          Comment


          • Why do people still use Ubuntu?

            Comment


            • Originally posted by sandy8925 View Post
              Hi,

              Can you share what arguments you use for ./configure ? Thanks.
              All the source are available in the PPA, see the PPA page for how to download them. The easiest way to see the configure arguments see the various build log, e.g. https://launchpadlibrarian.net/11465...UILDING.txt.gz

              Comment


              • I have enabled again the LLVM compiler on r600. See here for more info:
                http://dri.freedesktop.org/wiki/R600ToDo#LLVM

                Comment


                • I thought I posted before, but maybe it didn't go through?

                  After yesterday's updated, OpenGL stopped working, so Gnome-shell gave me a garbled screen of corruption(as did Gnome Classic with effects).

                  I seem to be affected by this bug: https://bugs.freedesktop.org/show_bug.cgi?id=55217

                  Downgrading libgl1-mesa-dri to the official repository's version solved the problem, which is lucky because the other packages I tried to downgrade wanted to remove half my system.

                  Hopefully they get this figured out soon.

                  Comment


                  • Last driver version is broken.

                    On last version of driver I'm getting nasty GPU lockups:
                    Code:
                    [ 4062.294642] radeon 0000:01:00.0: GPU lockup CP stall for more than 10000msec
                    [ 4062.294653] radeon 0000:01:00.0: GPU lockup (waiting for 0x00000000000dfa1e last fence id 0x00000000000dfa1d)
                    [ 4062.794470] radeon 0000:01:00.0: GPU lockup CP stall for more than 10500msec
                    [ 4062.794478] radeon 0000:01:00.0: GPU lockup (waiting for 0x00000000000dfa1e)
                    [ 4062.794484] radeon 0000:01:00.0: failed to get a new IB (-35)
                    [ 4062.794488] [drm:radeon_cs_ib_chunk] *ERROR* Failed to get ib !
                    [ 4062.795587] radeon 0000:01:00.0: Saved 2455 dwords of commands on ring 0.
                    [ 4062.795595] radeon 0000:01:00.0: GPU softreset 
                    [ 4062.795600] radeon 0000:01:00.0:   GRBM_STATUS=0xA2731828
                    [ 4062.795604] radeon 0000:01:00.0:   GRBM_STATUS_SE0=0x1C000003
                    [ 4062.795608] radeon 0000:01:00.0:   GRBM_STATUS_SE1=0x00000007
                    [ 4062.795613] radeon 0000:01:00.0:   SRBM_STATUS=0x200000C0
                    [ 4062.795617] radeon 0000:01:00.0:   R_008674_CP_STALLED_STAT1 = 0x00000000
                    [ 4062.795621] radeon 0000:01:00.0:   R_008678_CP_STALLED_STAT2 = 0x00010800
                    [ 4062.795624] radeon 0000:01:00.0:   R_00867C_CP_BUSY_STAT     = 0x00028006
                    [ 4062.795628] radeon 0000:01:00.0:   R_008680_CP_STAT          = 0x80038647
                    [ 4062.795634] radeon 0000:01:00.0:   GRBM_SOFT_RESET=0x00007F6B
                    [ 4062.795739] radeon 0000:01:00.0:   GRBM_STATUS=0x00003828
                    [ 4062.795743] radeon 0000:01:00.0:   GRBM_STATUS_SE0=0x00000007
                    [ 4062.795746] radeon 0000:01:00.0:   GRBM_STATUS_SE1=0x00000007
                    [ 4062.795750] radeon 0000:01:00.0:   SRBM_STATUS=0x200000C0
                    [ 4062.795753] radeon 0000:01:00.0:   R_008674_CP_STALLED_STAT1 = 0x00000000
                    [ 4062.795757] radeon 0000:01:00.0:   R_008678_CP_STALLED_STAT2 = 0x00000000
                    [ 4062.795761] radeon 0000:01:00.0:   R_00867C_CP_BUSY_STAT     = 0x00000000
                    [ 4062.795764] radeon 0000:01:00.0:   R_008680_CP_STAT          = 0x00000000
                    [ 4062.796761] radeon 0000:01:00.0: GPU reset succeeded, trying to resume
                    [ 4062.851793] [drm] probing gen 2 caps for device 1002:5a16 = 2/0
                    [ 4062.851797] [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
                    [ 4062.854347] [drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
                    [ 4062.854434] radeon 0000:01:00.0: WB enabled
                    [ 4062.854438] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0xffff88041bccbc00
                    [ 4062.872386] [drm] ring test on 0 succeeded in 1 usecs
                    [ 4063.646428] [drm] ib test on ring 0 succeeded in 0 usecs
                    [ 4063.647510] radeon 0000:01:00.0: GPU reset succeeded, trying to resume
                    [ 4063.702761] [drm] probing gen 2 caps for device 1002:5a16 = 2/0
                    [ 4063.702764] [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
                    [ 4063.705380] [drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
                    [ 4063.705484] radeon 0000:01:00.0: WB enabled
                    [ 4063.705487] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0xffff88041bccbc00
                    [ 4063.721528] [drm] ring test on 0 succeeded in 1 usecs
                    [ 4065.977682] [drm] ib test on ring 0 succeeded in 0 usecs
                    [ 4076.673451] radeon 0000:01:00.0: GPU lockup CP stall for more than 10000msec
                    [ 4076.673460] radeon 0000:01:00.0: GPU lockup (waiting for 0x00000000000dfa7e last fence id 0x00000000000dfa7d)
                    [ 4077.173271] radeon 0000:01:00.0: GPU lockup CP stall for more than 10500msec
                    [ 4077.173278] radeon 0000:01:00.0: GPU lockup (waiting for 0x00000000000dfa7e)
                    [ 4077.173284] radeon 0000:01:00.0: failed to get a new IB (-35)
                    [ 4077.173289] [drm:radeon_cs_ib_chunk] *ERROR* Failed to get ib !
                    [ 4077.174397] radeon 0000:01:00.0: Saved 2535 dwords of commands on ring 0.
                    [ 4077.174405] radeon 0000:01:00.0: GPU softreset 
                    [ 4077.174410] radeon 0000:01:00.0:   GRBM_STATUS=0xA2731828
                    [ 4077.174414] radeon 0000:01:00.0:   GRBM_STATUS_SE0=0x1C000003
                    [ 4077.174419] radeon 0000:01:00.0:   GRBM_STATUS_SE1=0x00000007
                    [ 4077.174423] radeon 0000:01:00.0:   SRBM_STATUS=0x200000C0
                    [ 4077.174426] radeon 0000:01:00.0:   R_008674_CP_STALLED_STAT1 = 0x00000000
                    [ 4077.174430] radeon 0000:01:00.0:   R_008678_CP_STALLED_STAT2 = 0x00010800
                    [ 4077.174434] radeon 0000:01:00.0:   R_00867C_CP_BUSY_STAT     = 0x00028006
                    [ 4077.174438] radeon 0000:01:00.0:   R_008680_CP_STAT          = 0x80038647
                    [ 4077.174444] radeon 0000:01:00.0:   GRBM_SOFT_RESET=0x00007F6B
                    [ 4077.174549] radeon 0000:01:00.0:   GRBM_STATUS=0x00003828
                    [ 4077.174553] radeon 0000:01:00.0:   GRBM_STATUS_SE0=0x00000007
                    [ 4077.174556] radeon 0000:01:00.0:   GRBM_STATUS_SE1=0x00000007
                    [ 4077.174560] radeon 0000:01:00.0:   SRBM_STATUS=0x200000C0
                    [ 4077.174564] radeon 0000:01:00.0:   R_008674_CP_STALLED_STAT1 = 0x00000000
                    [ 4077.174567] radeon 0000:01:00.0:   R_008678_CP_STALLED_STAT2 = 0x00000000
                    [ 4077.174571] radeon 0000:01:00.0:   R_00867C_CP_BUSY_STAT     = 0x00000000
                    [ 4077.174575] radeon 0000:01:00.0:   R_008680_CP_STAT          = 0x00000000
                    [ 4077.175571] radeon 0000:01:00.0: GPU reset succeeded, trying to resume
                    [ 4077.230795] [drm] probing gen 2 caps for device 1002:5a16 = 2/0
                    [ 4077.230799] [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
                    [ 4077.233361] [drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
                    [ 4077.233443] radeon 0000:01:00.0: WB enabled
                    [ 4077.233446] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0xffff88041bccbc00
                    [ 4077.253001] [drm] ring test on 0 succeeded in 1 usecs
                    [ 4078.812640] [sched_delayed] sched: RT throttling activated
                    [ 4078.823230] [drm] ib test on ring 0 succeeded in 0 usecs
                    [ 4078.824312] radeon 0000:01:00.0: GPU reset succeeded, trying to resume
                    [ 4078.879309] [drm] probing gen 2 caps for device 1002:5a16 = 2/0
                    [ 4078.879312] [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
                    [ 4078.883379] [drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
                    [ 4078.883492] radeon 0000:01:00.0: WB enabled
                    [ 4078.883499] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0xffff88041bccbc00
                    [ 4078.899594] [drm] ring test on 0 succeeded in 1 usecs
                    [ 4082.193265] [drm] ib test on ring 0 succeeded in 0 usecs
                    [ 4092.978295] radeon 0000:01:00.0: GPU lockup CP stall for more than 10120msec
                    [ 4092.978304] radeon 0000:01:00.0: GPU lockup (waiting for 0x00000000000dfadf)
                    It locks up with the very same error all the time in certain situation (3d scene in game). Earlier version had no such issues. Message about GPU lockup repeats itself all the time - GPU recovery fails and no picture appears on display as the result. The only way to fix it is a reboot.

                    Any hints what "failed to get a new IB (-35)" means?

                    Comment


                    • news

                      Any news about updating?

                      is it possible to use this updating on all of ubuntu distro previous 12.04

                      obliaf how can you update all the necessary dependencies?! and if the latest are curretly 8.04 version why you named them 8.1?! thanks for your patiance

                      Comment

                      Working...
                      X