Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by thob View Post
    OK, I'm back to 7.10.2 and the 3D software works again.
    Use google to find how to:
    - add linux 3.2 kernel to your ppa
    - add xorg-edgers to your ppa

    Install driconf to configure the driver.

    All this are - three commands in terminal.

    Reboot and have fun.

    Comment


    • Originally posted by Nedanfor View Post
      oibaf, there will be an update for this? Thank you for your work
      It's building now

      Comment


      • Originally posted by thob View Post
        hello,

        I ran into troubles since the last update with SweetHome3D – a java-based 3D program

        it crashes with this the error message

        Code:
        thuxi@tux:~/Programm/SweetHome3D-3.4$ ./SweetHome3D
        Mesa: Initializing x86-64 optimizations
        Mesa: User error: GL_INVALID_VALUE in glOrtho
        intel_do_flush_locked failed: Das Argument ist ungültig
        Is there anything I can do? I just recently switched to Linux.
        If it's still not fixed you should report a bug, see my first post.

        Comment


        • Originally posted by oibaf View Post
          It's building now
          I updated the driver (now it is git-f9f8ce3), but I have still OpenGL 2.1/GLSL 1.20. Did you use enviromental variables R600_GLSL130=1 and R600_STREAMOUT=1? If you don't, why? I hope it's not a problem of Turks (AMD 6570). Thank you

          Comment


          • Originally posted by Nedanfor View Post
            I updated the driver (now it is git-f9f8ce3), but I have still OpenGL 2.1/GLSL 1.20. Did you use enviromental variables R600_GLSL130=1 and R600_STREAMOUT=1? If you don't, why? I hope it's not a problem of Turks (AMD 6570). Thank you
            Uh? The env variables must be set by you before running the OpenGL app...

            Comment


            • Originally posted by oibaf View Post
              Uh? The env variables must be set by you before running the OpenGL app...
              Sorry, I think I misunderstood However...
              Code:
              OpenGL version string: 3.0 Mesa 8.0-devel (git-f9f8ce3 oneiric-oibaf-ppa)
              OpenGL shading language version string: 1.30
              Thank you oibaf

              Comment


              • i set this options in /etc/default/grub/ R600_GLSL130=1 R600_STREAMOUT=1

                GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1 radeon.pcie_gen2=1 R600_GLSL130=1 R600_STREAMOUT=1"

                what do i wrong ?

                Comment


                • Originally posted by Qaridarium View Post
                  i set this options in /etc/default/grub/ R600_GLSL130=1 R600_STREAMOUT=1

                  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1 radeon.pcie_gen2=1 R600_GLSL130=1 R600_STREAMOUT=1"

                  what do i wrong ?
                  Those are the kernel options. Try with:
                  Code:
                  R600_GLSL130=1 R600_STREAMOUT=1 glxinfo

                  Comment


                  • Originally posted by oibaf View Post
                    Those are the kernel options. Try with:
                    Code:
                    R600_GLSL130=1 R600_STREAMOUT=1 glxinfo
                    now i get:'

                    "OpenGL vendor string: X.Org
                    OpenGL renderer string: Gallium 0.4 on AMD RV740
                    OpenGL version string: 3.0 Mesa 8.0-devel (git-f9f8ce3 oneiric-oibaf-ppa)
                    OpenGL shading language version string: 1.30
                    "

                    do i need set this option for every app i start ?

                    or can i turn on this for general ?

                    Comment


                    • Originally posted by Qaridarium View Post
                      now i get:'

                      "OpenGL vendor string: X.Org
                      OpenGL renderer string: Gallium 0.4 on AMD RV740
                      OpenGL version string: 3.0 Mesa 8.0-devel (git-f9f8ce3 oneiric-oibaf-ppa)
                      OpenGL shading language version string: 1.30
                      "

                      do i need set this option for every app i start ?

                      or can i turn on this for general ?
                      https://help.ubuntu.com/community/EnvironmentVariables

                      scroll all way down to "persistant environiment variables".

                      Comment

                      Working...
                      X