Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by Nedanfor View Post
    oibaf, if you need more data from glxinfo tell me, I would like to help.
    There is no magic in my packages and I am not very familiar with r600 driver. If R600_STREAMOUT is broken open a bug on freedesktop, for the OpenGL version it probably require some other thing to enable.

    Comment


    • https://bugs.freedesktop.org/show_bug.cgi?id=47281 is causing problems for me. The fix was supposed to be released on 2012-04-27, and there has been two releases of the ubuntu driver debs since then. But still, I'm getting the same errors.

      Before I go back to the bug saying that the fix doesn't work, is it really included in the latest driver packages?

      The versions on my machine are

      $ dpkg -l|grep radeon
      ii libdrm-radeon1 2.4.34+git1205110954.86451a~gd~p Userspace interface to radeon-specific kernel DRM services -- runtime
      ii xserver-xorg-video-radeon 1:6.14.99+git1205111032.4b9bad~gd~p X.Org X server -- AMD/ATI Radeon display driver

      Comment


      • I always had problems to do with chrome's native client applications. Ultimatly most 3D objects in the game appeared all black. Now that I've updated mesa using your PPA those long time problems have stopped. Thanks oibaf!

        Comment


        • Originally posted by tpievila View Post
          https://bugs.freedesktop.org/show_bug.cgi?id=47281 is causing problems for me. The fix was supposed to be released on 2012-04-27, and there has been two releases of the ubuntu driver debs since then. But still, I'm getting the same errors.

          Before I go back to the bug saying that the fix doesn't work, is it really included in the latest driver packages?

          The versions on my machine are

          $ dpkg -l|grep radeon
          ii libdrm-radeon1 2.4.34+git1205110954.86451a~gd~p Userspace interface to radeon-specific kernel DRM services -- runtime
          ii xserver-xorg-video-radeon 1:6.14.99+git1205111032.4b9bad~gd~p X.Org X server -- AMD/ATI Radeon display driver
          The linked bug is an xserver bug, for which I don't provide packages. You have to search (and eventually file a new one) bug for this in launchpad and follow there.

          Comment


          • Hi oibaf,

            i915 and i915g both don't seem to work anymore. Instead i get llvmpipe and /usr/lib/dri-alternates doesn't exist anymore.

            glxinfo shows this:

            OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x301)
            OpenGL version string: 2.1 Mesa 8.1-devel (git-c2f1fbf precise-oibaf-ppa)
            OpenGL shading language version string: 1.20

            Comment


            • @derdestiller: compiz on a 915GM is still working for me with the PPA. Not yet tried other programs, but glxgears was indeed stuttering when I last tried it.

              Comment


              • Originally posted by derdestiller View Post
                Hi oibaf,

                i915 and i915g both don't seem to work anymore. Instead i get llvmpipe and /usr/lib/dri-alternates doesn't exist anymore.

                glxinfo shows this:
                Please post the output of:
                Code:
                LIBGL_DEBUG=verbose glxgears

                Comment


                • Originally posted by oibaf View Post
                  Please post the output of:
                  Code:
                  LIBGL_DEBUG=verbose glxgears
                  This is what i get:

                  libGL: screen 0 does not appear to be DRI2 capable
                  libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
                  libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
                  libGL: Can't open configuration file /home/reddevil/.drirc: No such file or directory.
                  I'm not sure, but as far as i can tell i didn't change anything relevant from my previous working configuration.

                  Comment


                  • Removing the PPA and adding it again solved my problem.

                    Comment


                    • Update

                      Mesa in the PPA now uses LLVM compiler for the r600 driver.

                      Comment


                      • graphical glitches since last update (LLVM for r600)

                        Originally posted by oibaf View Post
                        Mesa in the PPA now uses LLVM compiler for the r600 driver.
                        First, thank you oibaf for your excellent work about packaging those drivers to provide an easy to use ppa.

                        I'm using it for several month now with an AMD radeon HD 6950 (2GB). I can play lots of games with good fps (even unigine oil rush is running fine in medium details in 1920x1200).

                        But, unfortunately, since the last update (where mesa in the ppa uses llvm for r600), I encounter severe graphical glitches for every 3D application (2D desktop and videos are fine).

                        Here is a screenshot of glxgears :



                        I'm currently using ubuntu 12.04 64bit, unity 2D. Below are some glxinfo :

                        OpenGL vendor string: X.Org
                        OpenGL renderer string: Gallium 0.4 on AMD CAYMAN
                        OpenGL version string: 2.1 Mesa 8.1-devel (git-6404095 precise-oibaf-ppa)
                        OpenGL shading language version string: 1.30

                        I tried to revert to original distribution packages, wich solve the rendering problem, but cause performance and compatibility problems of course...

                        So I brought back the ppa and the faulty rendering is still here.

                        Have you got an idea to diagnose this problem ?

                        Comment


                        • after the last dist-upgrade: HON in wine crash after a game starts on the map

                          means graphic in the lobby works but not on the playmap...

                          ??,

                          Edit: ok after setting all settings to low the game dit not crash maybe i can find the option what makes it cash

                          i found the option : Display Foliage

                          this option crashes the game
                          Last edited by Qaridarium; 06-06-2012, 01:23 AM.

                          Comment


                          • Originally posted by Qaridarium View Post
                            after the last dist-upgrade: HON in wine crash after a game starts on the map

                            means graphic in the lobby works but not on the playmap...

                            ??,

                            Edit: ok after setting all settings to low the game dit not crash maybe i can find the option what makes it cash

                            i found the option : Display Foliage

                            this option crashes the game


                            i can't play a full game without crash the oibaf ppa is broken for hon right now.

                            it just crashes randomly...

                            now i tryed the openGL renderer instead of the directX one now it does not crash.

                            means the bug is a wine/directX bug with the radeon driver ..

                            Comment


                            • Hi oibaf. Can you please include "Don't wait on a CRTC which has been disabled via DPMS (bug #49761)" ati commit in your next update?

                              Thank you.
                              Last edited by schnelle; 06-06-2012, 07:31 AM.

                              Comment


                              • Originally posted by Qaridarium View Post
                                i can't play a full game without crash the oibaf ppa is broken for hon right now.

                                it just crashes randomly...

                                now i tryed the openGL renderer instead of the directX one now it does not crash.

                                means the bug is a wine/directX bug with the radeon driver ..
                                it just take longer to crash... is this a VRAM memory leak ?

                                HON is broken with oibaf on my hd4770 right now..

                                plesse update the ppa

                                Comment

                                Working...
                                X