Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    I'm getting some screen freezes using this PPA.
    It started happening when I added this PPA, then I tried reverting to the standard packages in Natty and it went away. I started using this PPA again yesterday and the freezes are back.

    What happens is that the screen freezes, nothing updates, but the cursor I am able to move around. I can switch to another VT and restart gdm, which then loads on a new VT and I am able to work again.
    Also, the freezes usually happen when I perform some action. It can be anything really, opening a new program, clicking something, in other words, they don't happen when the computer sits around doing nothing, it's as if some action triggers it. Usually it's a new window opening, if I recall correctly.

    Any idea how to debug this?

    Comment


    • #12
      What card/driver are you using?
      Do you have compiz enabled?
      Which Ubuntu version are you running?

      You may want to post the dmesg output and /var/log/Xorg.0.log (the one relative to the freeze). If you have compiz enabled you could try installing only the x driver from this PPA (keeping the Ubuntu mesa) to try to identify the source of the problem (mesa or x driver).

      Comment


      • #13
        OK, I added to the mesa package the patch from fdo bug #35268, which may be related to this problem. Let me know if you are still experiencing it after upgrading to mesa 7.11.0~git1105101331.d6b248 or later.

        Comment


        • #14
          Originally posted by oibaf View Post
          What card/driver are you using?
          Do you have compiz enabled?
          Which Ubuntu version are you running?

          You may want to post the dmesg output and /var/log/Xorg.0.log (the one relative to the freeze). If you have compiz enabled you could try installing only the x driver from this PPA (keeping the Ubuntu mesa) to try to identify the source of the problem (mesa or x driver).
          I am using a RV670 (HD3870) with r600g and running Natty with Compiz enabled.

          Neither dmesg nor the Xorg log seem like much help, here are the relevant lines of dmesg around the crash (the crash happened somewhere around 10500s post boot:
          Code:
          [ 7528.128984] usbcore: registered new interface driver snd-usb-audio
          [10051.040040] usb 4-1: USB disconnect, device number 8
          [10195.070019] usb 4-1: new full speed USB device number 9 using uhci_hcd
          [10195.262736] input: www.hirestech.com 2010 REV 1.5 Music Streamer II as /devices/pci0000:00/0000:00:1a.1/usb4/4-1/4-1:1.2/input/input5
          [10195.262831] generic-usb 0003:4852:0003.0004: input,hidraw1: USB HID v1.00 Device [www.hirestech.com 2010 REV 1.5 Music Streamer II] on usb-0000:00:1a.1-1/input2
          [10195.267839] generic-usb 0003:4852:0003.0005: hiddev0,hidraw2: USB HID v1.00 Device [www.hirestech.com 2010 REV 1.5 Music Streamer II] on usb-0000:00:1a.1-1/input3
          [10927.569177] r8169 0000:02:01.0: eth0: link down
          [10929.326813] r8169 0000:02:01.0: eth0: link up
          Xorg.0.log doesn't seem to have any relevant info either: http://pastebin.com/Qjp2m4UC. The crash seemed to have happened between these two lines in Xorg.0.log:
          Code:
          [ 10195.330] (**) Option "xkb_layout" "dk"
          [ 10562.922] (II) AIGLX: Suspending AIGLX clients for VT switch
          The first line being when I plugged in a USB DAC (before the freeze happened), and the second line being me switching to VT1 after the freeze has happened.

          I will try with the updated packages in your PPA. But the bug description in question seems to describe a crash, and all I'm seeing is a freeze.

          Since I'm using Compiz I think I will try restarting only compiz the next time the freeze happens, to see if this is the program that freezes.

          If the freeze still happens with your updated packages I'll try to switch out the X driver and mesa driver, one at a time, from your PPA with the one from Natty.

          Comment


          • #15
            hey i test out your ppa

            i first purge xorg-edgers and then install yours.

            the good side: HON shows the skins of the cratures/heroes and your ppa works as good as xorg-edgers

            the general bad but its not your fauld is hon is extremly slow less than 1 fps per second and shadowground suvivor do have the same ALL goes Withe bug as the normal Radeon...

            Comment


            • #16
              Originally posted by Qaridarium View Post
              the general bad but its not your fauld is hon is extremly slow less than 1 fps per second and shadowground suvivor do have the same ALL goes Withe bug as the normal Radeon...
              Is there already a bug opened on freedesktop? If not you may want to open one so that developers can have a chance to fix it.

              Comment


              • #17
                I'd like to test it, but is there a chance it will run Amnesia: Dark Descent on a radeon 4250 integrated card?

                Comment


                • #18
                  Originally posted by crispy View Post
                  I'd like to test it, but is there a chance it will run Amnesia: Dark Descent on a radeon 4250 integrated card?
                  Yes, according to http://wiki.x.org/wiki/RadeonProgram .

                  Anyway you can try yourself, it won't take more than 5 minutes. If you encounter any problem you can also quickly revert to original Ubuntu packages.

                  Comment


                  • #19
                    Originally posted by Qaridarium View Post
                    shadowground suvivor do have the same ALL goes Withe bug as the normal Radeon...
                    Update/install libtxc_dxtn

                    Comment


                    • #20
                      Originally posted by whizse View Post
                      Update/install libtxc_dxtn
                      If you enabled this PPA you should already have libtxc_dxtn which is Recommended by mesa. If you disabled installing Recommended packages you can install it with:
                      Code:
                      sudo apt-get install libtxc-dxtn0

                      Comment

                      Working...
                      X