Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is safe to purge this ppa? ppa-purge tries to remove a lot of packages due to the downgrade of these ones.

    Comment


    • Originally posted by alazar View Post
      Is safe to purge this ppa? ppa-purge tries to remove a lot of packages due to the downgrade of these ones.
      Can you list them?

      I only wrote the above because the title says "Updated and Optimized". If you --enable-debug, at least remove the "optimized" part from the title.
      I already replied to this, search in this thread.

      Comment


      • Originally posted by oibaf View Post
        Can you list them?
        Following actions will resolve dependencies.

        Remove following packages:
        1) flashplugin-downloader
        2) flashplugin-installer
        3) ia32-libs-multiarch
        4) libacl1
        5) libasound2
        6) libasound2-plugins
        7) libasyncns0
        8) libatk1.0-0
        9) libattr1
        10) libaudio2
        11) libavahi-client3
        12) libavahi-common3
        13) libc6
        14) libcairo2
        15) libcomerr2
        16) libcups2
        17) libcupsimage2
        18) libcurl3
        19) libdatrie1
        20) libdb5.1
        21) libdbus-1-3
        22) libdbusmenu-qt2
        23) libdrm-intel1
        24) libdrm-nouveau1a
        25) libdrm-radeon1
        26) libdrm2
        27) libexpat1
        28) libffi6
        29) libflac8
        30) libfontconfig1
        31) libfreetype6
        32) libgcc1
        33) libgcrypt11
        34) libgdbm3
        35) libgdk-pixbuf2.0-0
        36) libgl1-mesa-dri
        37) libgl1-mesa-glx
        38) libglapi-mesa
        39) libglib2.0-0
        40) libgnutls26
        41) libgpg-error0
        42) libgssapi-krb5-2
        43) libgtk2.0-0
        44) libice6
        45) libidn11
        46) libjack-jackd2-0
        47) libjasper1
        48) libjpeg62
        49) libjson0
        50) libk5crypto3
        51) libkeyutils1
        52) libkrb5-3
        53) libkrb5support0
        54) liblcms1
        55) libldap-2.4-2
        56) libllvm2.9
        57) libmng1
        58) libnspr4
        59) libnspr4-0d
        60) libnss3
        61) libnss3-1d
        62) libogg0
        63) libpango1.0-0
        64) libpciaccess0
        65) libpcre3
        66) libpixman-1-0
        67) libpng12-0
        68) libpulse0
        69) libqt4-dbus
        70) libqt4-declarative
        71) libqt4-designer
        72) libqt4-network
        73) libqt4-opengl
        74) libqt4-qt3support
        75) libqt4-script
        76) libqt4-scripttools
        77) libqt4-sql
        78) libqt4-svg
        79) libqt4-test
        80) libqt4-xml
        81) libqt4-xmlpatterns
        82) libqtcore4
        83) libqtgui4
        84) librtmp0
        85) libsamplerate0
        86) libsasl2-2
        87) libsasl2-modules
        88) libselinux1
        89) libsm6
        90) libsndfile1
        91) libspeexdsp1
        92) libsqlite3-0
        93) libssl1.0.0
        94) libstdc++6
        95) libtasn1-3
        96) libthai0
        97) libtiff4
        98) libtxc-dxtn0
        99) libuuid1
        100) libvorbis0a
        101) libvorbisenc2
        102) libwrap0
        103) libx11-6
        104) libxau6
        105) libxcb-render0
        106) libxcb-shm0
        107) libxcb1
        108) libxcomposite1
        109) libxcursor1
        110) libxdamage1
        111) libxdmcp6
        112) libxext6
        113) libxfixes3
        114) libxft2
        115) libxi6
        116) libxinerama1
        117) libxrandr2
        118) libxrender1
        119) libxss1
        120) libxt6
        121) libxv1
        122) libxxf86vm1
        123) nspluginviewer
        124) nspluginwrapper
        125) skype
        126) sni-qt
        127) virtualgl-libs
        128) zlib1g

        Leave these dependencies without resolving:
        129) ia32-libs recomienda ia32-libs-multiarch
        130) ubuntu-restricted-addons recomienda flashplugin-installer
        131) flashplugin-downloader recomienda libasound2-plugins (>= 1.0.16)
        132) libgl1-mesa-dri recomienda libtxc-dxtn0
        133) libgl1-mesa-glx recomienda libgl1-mesa-dri (>= 7.2)


        Do you accept this solution? [Y/n/q/?]
        I've translated the remove dependencies strings (it was in Spanish).

        Comment


        • Hi, i just updated to your ppa because i want to use software rendering with llvm.
          I downgraded from xorg edgers and installed your packages on 11.10.

          The system is still using the old software rasterizer. What am i doing wrong ?

          Thanks in advance

          Comment


          • Originally posted by iznogood View Post
            Hi, i just updated to your ppa because i want to use software rendering with llvm.
            I downgraded from xorg edgers and installed your packages on 11.10.

            The system is still using the old software rasterizer. What am i doing wrong ?

            Thanks in advance
            sudo apt-get install libgl1-mesa-dri-experimental

            then

            LIBGL_ALWAYS_SOFTWARE=1 LIBGL_DRIVERS_PATH=/usr/lib/(x86_64-linux-gnu or i386-linux-gnu)/dri-alternates yourappname

            most likely. That's how you use it with xorg-edgers

            Comment


            • Originally posted by iznogood View Post
              Hi, i just updated to your ppa because i want to use software rendering with llvm.
              I downgraded from xorg edgers and installed your packages on 11.10.

              The system is still using the old software rasterizer. What am i doing wrong ?

              Thanks in advance
              It should indeed be installed in the default libgl1-mesa-dri package. Can you post the output of:
              Code:
              LIBGL_ALWAYS_SOFTWARE=1

              Comment


              • Originally posted by alazar View Post
                I've translated the remove dependencies strings (it was in Spanish).
                The problem is caused by aptitude. It doesn't yet really handle multiarch well and breaks down when touching packages that have multiple versions installed. Unfortunately it seems like ppa-purge uses aptitude and there's no configuration to change the behaviour.

                Comment


                • i report a bug upstream

                  upstream developer recommend to test a fix (ait r600g). http://lists.freedesktop.org/archive...er/016612.html

                  is it included in this ppa already?

                  Comment


                  • i submit bug report upstream and those developer tell me fix available

                    http://lists.freedesktop.org/archive...er/016612.html

                    How long will it take for this kind of patch to include in this ppa so that i can test for the developer?

                    Comment


                    • Originally posted by unknown2 View Post
                      i submit bug report upstream and those developer tell me fix available

                      http://lists.freedesktop.org/archive...er/016612.html

                      How long will it take for this kind of patch to include in this ppa so that i can test for the developer?
                      Hey, that patch was just merged 3 hours ago

                      I pushed the update now, it should build in an hour.

                      Comment

                      Working...
                      X