Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by questioneer View Post
    in the first post you mentioned frozenbyte games support, but those games still wont work with those drivers enabled. trine wont start and shadowgrounds is unbearable slow..... is it broken again? (radeon 3850)
    I remember mesa get some fixes for them and they worked fine on some hardware. I'd suggest to file a detailed bug at https://bugs.freedesktop.org/enter_bug.cgi?product=Mesa so that developers can have a look at it.

    Comment


    • Originally posted by beew View Post
      Hi, just cut and paste Xorg.0.log1 to the URL above. Just have to connect the drive to another Ubuntu install and fish out the log, should have thought of it before.

      Thanks.
      Where are the links to your logs

      Comment


      • Originally posted by oibaf View Post
        Where are the links to your logs
        Oops, sorry, here it is. http://paste.ubuntu.com/680341/


        Comment


        • Try updating xserver-xorg-video-nouveau to 0.0.16+git1109021401.169512~gd~n (it should take some hours before the build is ready). I disabled a couple of old Ubuntu patches that should be no longer needed.

          Comment


          • llvmpipe on virtual machine

            Hi, great stuff oibaf!

            I cannot get llvmpipe/swrast going on an amazon virtual machine - that in itself might be out of scope for this thread.
            However out of curiosity, I can get package libgl1-mesa-swx11 working that replaces libgl1-mesa-glx. Is there a similar method for llvmpipe?
            The error is simply
            Code:
            $ LIBGL_ALWAYS_SOFTWARE=1 glxinfo | grep renderer
            Error: couldn't find RGB GLX visual or fbconfig
            However this used to say Mesa X11 with libgl1-mesa-swx11
            Using ubuntu 11.04
            thx
            PS: donation if possible

            Comment


            • Originally posted by cgltower View Post
              Hi, great stuff oibaf!

              I cannot get llvmpipe/swrast going on an amazon virtual machine - that in itself might be out of scope for this thread.
              However out of curiosity, I can get package libgl1-mesa-swx11 working that replaces libgl1-mesa-glx. Is there a similar method for llvmpipe?
              The error is simply
              Code:
              $ LIBGL_ALWAYS_SOFTWARE=1 glxinfo | grep renderer
              Error: couldn't find RGB GLX visual or fbconfig
              However this used to say Mesa X11 with libgl1-mesa-swx11
              Using ubuntu 11.04
              thx
              PS: donation if possible
              Dunno what may be the problem. I'd suggest asking on mesa-dev.

              Comment


              • Unigine on Radeon HD4250

                Hi!
                I am trying to run Heaven and Tropics demos on HD4250 with open-source drivers. I am using iobaf drivers but none is working correctly.
                Hevaen starts, but textures are missing. Tropics does not start and it says:
                http://pastebin.com/SjpWXP6D

                My glxinfo:
                http://pastebin.com/BM9Vw8vm

                Also FrozenByte games are missing textures.

                Comment


                • Unigine on Radeon HD4250

                  Hi!

                  I am using Radeon HS4250, iobaf drivers and I am trying to run Unigine tests.
                  Tropics fails to run and recieve this output
                  http://pastebin.com/SjpWXP6D

                  Heaven starts, but missing textures.

                  Here is my glxinfo. http://pastebin.com/BM9Vw8vm

                  Also, FrozenByte games misses testures. Shadowgrounds works on my Radeon 9600m (but slow).

                  Comment


                  • Originally posted by gsedej View Post
                    Hi!

                    I am using Radeon HS4250, iobaf drivers and I am trying to run Unigine tests.
                    Tropics fails to run and recieve this output
                    http://pastebin.com/SjpWXP6D

                    Heaven starts, but missing textures.

                    Here is my glxinfo. http://pastebin.com/BM9Vw8vm

                    Also, FrozenByte games misses testures. Shadowgrounds works on my Radeon 9600m (but slow).
                    Apparently you are not using my PPA with the game:
                    Code:
                    Engine::init(): clear video settings for "Gallium 0.4 on AMD RS880 2.1 Mesa 7.10.2"
                    glxinfo correctly detect it:
                    Code:
                    OpenGL version string: 2.1 Mesa 7.12-devel (git-4c84fbe natty-oibaf-ppa)
                    Are you on a 64 bit architecture? If yes you should also update the 32 bit mesa (I am on 32 bit so I can't help, I know it should be easier on oneiric, but my packages are still natty-only).

                    Comment


                    • Thanks for info! (and thanks for doing really good work!)
                      So your PPA does not have effect on 64bit Ubuntu? Any idea where could I get updated drivers for 64bit?

                      Comment

                      Working...
                      X