Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by oibaf View Post
    I could enable r600 llvm support but it will be enabled by default and since it's possibly buggy someone will complain. Best would be if mesa developers could make it disabled by default when compiled in and only enabled with an env variable. This way I could enable it and who want to try it could set the env var.
    So since now LLVM backend disabled by default:
    http://www.phoronix.com/scan.php?pag...tem&px=MTY2NjI

    Can you please enable it in your builds? Thanks.

    Comment


    • Originally posted by _SXX_ View Post
      So since now LLVM backend disabled by default:
      http://www.phoronix.com/scan.php?pag...tem&px=MTY2NjI

      Can you please enable it in your builds? Thanks.
      Done! Building now.

      Comment


      • Anyone know how to disable vsync in ubuntu? The "vblank_mode=0" gives a noticable performance increase in terminal, but I'm trying to make it global for every application I run.

        Comment


        • Originally posted by Dukenukemx View Post
          Anyone know how to disable vsync in ubuntu? The "vblank_mode=0" gives a noticable performance increase in terminal, but I'm trying to make it global for every application I run.
          add just that, as one line, to /etc/environment

          Comment


          • Thanks, I'll try it and see if it works.

            Comment


            • Don't forget to disable swapbufferswait in xorg.conf.

              Comment


              • Originally posted by oibaf View Post
                Done! Building now.
                according to that news and the forum discussion to the news it seems not to be a good idea to do so. not only has it compatibility issues it also seems to be slower.

                beside of this it is possible to enable it via an enviroment virable.

                it does sound good to enable it by default.

                Comment


                • Only software render unity with intel 4000

                  Hello,

                  just updated my Ubuntu to 14.04 and refreshened my drivers from Oibaf PPA, now I only have sofware render at Unity.

                  I have a Dell XPS 13 Ultranotebook (intel 3rd gen CPU - HD 4000 graphics).

                  Here is the test from unity:

                  # /usr/lib/nux/unity_support_test -p
                  OpenGL vendor string: VMware, Inc.
                  OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 256 bits)
                  OpenGL version string: 3.0 Mesa 10.2.0-devel (git-48fc270 trusty-oibaf-ppa)

                  Not software rendered: no
                  Not blacklisted: yes
                  GLX fbconfig: yes
                  GLX texture from pixmap: yes
                  GL npot or rect textures: yes
                  GL vertex program: yes
                  GL fragment program: yes
                  GL vertex buffer object: yes
                  GL framebuffer object: yes
                  GL version is 1.4+: yes

                  Unity 3D supported: no

                  This is the Xorg.0.log data: http://paste.ubuntu.com/7275610/

                  Any ideas?

                  Thanks

                  Comment


                  • Solved the issue...

                    After upgrading to 14.04, it seems that the xserver-xorg-video-intel was uninstalled by the ubuntu upgrade program.

                    So after the "apt-get install xserver-xorg-video-intel" command, everything is back to normal.

                    I hope I help anyone else with this same issue.

                    Comment


                    • upgrading to 14.04

                      To avoid breakage, before upgrading to 14.04 (as well as every new release) everyone should purge the PPA reverting to Ubuntu official packages, then adding the PPA again after the upgrade.

                      Comment

                      Working...
                      X