Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • No xserver-xorg-video-intel package for Trusty?

    Comment


    • since a week or so this drivers seem to have a strange bug.

      i was playing hearthstone with wine and since then it is unplayable as some of the texts are unreadable. in particular it is the the numbers for attack, health and mana costs and some others.

      The effect seen is as if the text color changes 100 times per second while it looks most of the time as transparent or similar to the background, thus unreadable.

      i already verified that its caused by these libs from the oibaf rep. i was hoping that it gets fixed in one of the following updates but it persists now since a week or more.

      anybody an idea?

      Comment


      • On a fresh install of 14.04 earlier, libwayland-egl1-mesa wants to be uninstalled. Doing this breaks glamor, and thus seems to lead to no 3d acceleration on my 7850 (using llvmpipe).

        Comment


        • Originally posted by Espionage724 View Post
          On a fresh install of 14.04 earlier, libwayland-egl1-mesa wants to be uninstalled. Doing this breaks glamor, and thus seems to lead to no 3d acceleration on my 7850 (using llvmpipe).
          Please retry in a hour with the updated mesa packages.

          Comment


          • Hi oibaf, a quick question if i may (apologies if it's been mentioned already, this is a very big thread and i only read ~90 pages in).

            On the ppa's page on launchpad, you mention:

            * First you need to install the libg3dvl-mesa (saucy) or mesa-vdpau-drivers (trusty) package:
            sudo apt-get install libg3dvl-mesa
            sudo apt-get install mesa-vdpau-drivers


            Both of these AND 'libvdpau1-drivers-mesa' are available to be installed for Ubuntu 14.04 (but with exclusivity).

            To help highlight a source of confusion:
            Quote Originally Posted by agd5f View Post
            Don't use libvdpau-va-gl1. That emulates vdpau using va-api and gl for drivers that don't support vdpau. The performance will not be good. The radeon driver supports vdpau natively. Install one of the libg3dvl-mesa and mesa-vdpau-drivers packages.

            As it is, the apt descriptions alone for each package don't exactly make it very clear which are required:
            libg3dvl-mesa - xvmc and vdpau Gallium3D video acceleration drivers
            mesa-vdpau-drivers These libraries provide the Video Decode and Presentation API for Unix.OpenMAX IL Bellagio and XvMC libraries are also included.They provide accelerated video playback (incl. H.264) and video
            post-processing for the supported graphics cards. This package enables support for VDPAU for some gallium drivers.
            libvdpau1-drivers-mesa - This package enables support for VDPAU, OpenMAX IL Bellagio and XvMC for some gallium drivers.


            Personally, I'll follow advice and stick to 'mesa-vdpau-drivers' here on Ubuntu 14.04 as instructed, but i was just curious about what the difference is between these packages (why does this new package exist?) and why is 'libg3dvl-mesa' also still available for trusty if it is necessary switch away from it?

            Much appreciated!
            Last edited by Linux_Chemist; 04-02-2014, 05:17 PM.

            Comment


            • Originally posted by oibaf View Post
              Please retry in a hour with the updated mesa packages.
              Works fine now; thanks!

              Comment


              • @Linux_Chemist:
                Unless you did something wrong libg3dvl-mesa and libvdpau1-drivers-mesa are just packages aliases for mesa-vdpau-drivers (to ease upgrade). They were used for saucy and initial official Ubuntu version.

                Comment


                • Originally posted by oibaf View Post
                  @Linux_Chemist:
                  Unless you did something wrong libg3dvl-mesa and libvdpau1-drivers-mesa are just packages aliases for mesa-vdpau-drivers (to ease upgrade). They were used for saucy and initial official Ubuntu version.
                  Ahh, i see, no worries then, thanks!

                  Comment


                  • Hi,

                    So I installed the Oibaf drivers (did apt-get dist-upgrade). But I have issues, can't run Dota2 per example, it says me to install S3TC texture support.

                    * Linux Mint 16 KDE (64b)
                    * Installed Trusty kernel, 3.14
                    * APU A6-HD8400

                    glxinfo:

                    Code:
                    OpenGL vendor string: VMware, Inc.
                    OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
                    OpenGL version string: 3.0 Mesa 10.2.0-devel (git-5d0b3ec saucy-oibaf-ppa)
                    OpenGL shading language version string: 1.30
                    OpenGL context flags: (none)
                    OpenGL extensions:
                    What I have in xorg.conf:

                    Code:
                    Section "Module"
                            Load  "glx"
                    Is that info right?

                    Comment


                    • Originally posted by LiLou View Post
                      Hi,

                      So I installed the Oibaf drivers (did apt-get dist-upgrade). But I have issues, can't run Dota2 per example, it says me to install S3TC texture support.
                      Is it saying something like this? "Required OpenGL extension "GL_EXT_texture_compression_s3tc" is not supported. Please install S3TC texture support."

                      I'm not sure if this is solved specificallu by installing the 64/32bit version but you can get that with

                      Code:
                      sudo apt-get install libtxc-dxtn-s2tc0
                      and/or
                      Code:
                      sudo apt-get install libtxc-dxtn-s2tc0:i386
                      It won't hurt to do both really, but something tells me it's the 32bit you probably want if steam focuses on using 32bit libraries for the time being.

                      Comment

                      Working...
                      X