Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OK, I figured it out after a lot of googling.

    Remove vdpau-va-gl and its configuration file
    Put in /etc/X11/xinit/xinitrc these two lines
    Code:
    VDPAU_DRIVER=r600
    LIBVA_DRIVER_NAME=vdpau
    Then reboot. Now vdpau works and vdpauinfo no longer complains about missing r600. I don't know if it is obvious to everyone to put those two lines in X's init file but I have a hard time finding any instruction other than that the driver is already there. Maybe this will help someone else with same problem. It may be good to say a few words about this in the instructions for using the ppa on launchpad. That would help the not so experienced users a lot.

    P.S. It seems that vdpau-va-gl is not very stable on this machine, apparently vdpau stops working randomly on reboot here. It might not be because of the update yesterday that vdpau was broken.
    Last edited by kmod; 03-21-2014, 03:27 AM.

    Comment


    • Originally posted by kmod View Post
      Put in /etc/X11/xinit/xinitrc these two lines
      Code:
      VDPAU_DRIVER=r600
      LIBVA_DRIVER_NAME=vdpau
      There is no need for this.

      Comment


      • Originally posted by kmod View Post
        P.S. It seems that vdpau-va-gl is not very stable on this machine, apparently vdpau stops working randomly on reboot here. It might not be because of the update yesterday that vdpau was broken.
        You shouldn't be using vdpau-va-gl. As I said before it's a vdapu emulator for systems that don't support vdpau.

        Comment


        • No xserver-xorg-video-intel package for Trusty?

          Comment


          • since a week or so this drivers seem to have a strange bug.

            i was playing hearthstone with wine and since then it is unplayable as some of the texts are unreadable. in particular it is the the numbers for attack, health and mana costs and some others.

            The effect seen is as if the text color changes 100 times per second while it looks most of the time as transparent or similar to the background, thus unreadable.

            i already verified that its caused by these libs from the oibaf rep. i was hoping that it gets fixed in one of the following updates but it persists now since a week or more.

            anybody an idea?

            Comment


            • On a fresh install of 14.04 earlier, libwayland-egl1-mesa wants to be uninstalled. Doing this breaks glamor, and thus seems to lead to no 3d acceleration on my 7850 (using llvmpipe).

              Comment


              • Originally posted by Espionage724 View Post
                On a fresh install of 14.04 earlier, libwayland-egl1-mesa wants to be uninstalled. Doing this breaks glamor, and thus seems to lead to no 3d acceleration on my 7850 (using llvmpipe).
                Please retry in a hour with the updated mesa packages.

                Comment


                • Hi oibaf, a quick question if i may (apologies if it's been mentioned already, this is a very big thread and i only read ~90 pages in).

                  On the ppa's page on launchpad, you mention:

                  * First you need to install the libg3dvl-mesa (saucy) or mesa-vdpau-drivers (trusty) package:
                  sudo apt-get install libg3dvl-mesa
                  sudo apt-get install mesa-vdpau-drivers


                  Both of these AND 'libvdpau1-drivers-mesa' are available to be installed for Ubuntu 14.04 (but with exclusivity).

                  To help highlight a source of confusion:
                  Quote Originally Posted by agd5f View Post
                  Don't use libvdpau-va-gl1. That emulates vdpau using va-api and gl for drivers that don't support vdpau. The performance will not be good. The radeon driver supports vdpau natively. Install one of the libg3dvl-mesa and mesa-vdpau-drivers packages.

                  As it is, the apt descriptions alone for each package don't exactly make it very clear which are required:
                  libg3dvl-mesa - xvmc and vdpau Gallium3D video acceleration drivers
                  mesa-vdpau-drivers These libraries provide the Video Decode and Presentation API for Unix.OpenMAX IL Bellagio and XvMC libraries are also included.They provide accelerated video playback (incl. H.264) and video
                  post-processing for the supported graphics cards. This package enables support for VDPAU for some gallium drivers.
                  libvdpau1-drivers-mesa - This package enables support for VDPAU, OpenMAX IL Bellagio and XvMC for some gallium drivers.


                  Personally, I'll follow advice and stick to 'mesa-vdpau-drivers' here on Ubuntu 14.04 as instructed, but i was just curious about what the difference is between these packages (why does this new package exist?) and why is 'libg3dvl-mesa' also still available for trusty if it is necessary switch away from it?

                  Much appreciated!
                  Last edited by Linux_Chemist; 04-02-2014, 04:17 PM.

                  Comment


                  • Originally posted by oibaf View Post
                    Please retry in a hour with the updated mesa packages.
                    Works fine now; thanks!

                    Comment


                    • @Linux_Chemist:
                      Unless you did something wrong libg3dvl-mesa and libvdpau1-drivers-mesa are just packages aliases for mesa-vdpau-drivers (to ease upgrade). They were used for saucy and initial official Ubuntu version.

                      Comment

                      Working...
                      X