Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    I dropped the kasanen-post-process-v2 branch from mesa since it merge-conflicts with master.

    Comment


    • #92
      Updates

      Mesa
      • kasanen-post-process-v2 branch was officially merged in mesa
      • new GL_ARB_conservative_depth extension (required by OpenGL 4.2)

      Also I backported libvpx 0.9.7.p1 from debian. It has many changes but I especially like this one:
      Decoder speed was not a priority for this release, but improved approximately 8.4% on x86.
      which should make playing WebM video a bit faster (e.g. when using YouTube HTML5 mode).

      Comment


      • #93
        Hi,

        I have upgraded from your ppa and now I cannot boot into the graphic desktop (it boots, but then somehow I think the booting process hangs and I cannot gets into the gui) The machine has a Nvidia G105M graphic card and it is a fresh install of Ubuntu 11.04 on an external drive.

        I have another partition on the same external hd with Ubuntu 11.04 using drivers from the xorg-edgers ppa and it boots with no problem. I have tried replacing xorg-edgers with your ppa on this install (purge xorg-edgers, add the Oibaf ppa and update and upgrade) before but I had the same problem in booting, removing oibaf and reinstalling xorg-edgers and booting problem disappeared.

        I thought the problem might have been due to some conflicting libraries left over from xorg-edgers or other ppas so I made a fresh install of Ubuntu 11.04 on a different partition and then upgrade with your ppa but still no luck (it boots into the gui desktop successfully if I purge oibaf from recovery mode and reboot) I have been keeping up on updating (from recovery mode) so I have the latest drivers from your ppa.

        Thanks in advance for any advice.
        Last edited by beew; 08-27-2011, 12:34 PM.

        Comment


        • #94
          Originally posted by beew View Post
          Hi,

          I have upgraded from your ppa and now I cannot boot into the graphic desktop (it boots, but then somehow I think the booting process hangs and I cannot gets into the gui) The machine has a Nvidia G105M graphic card and it is a fresh install of Ubuntu 11.04 on an external drive.

          I have another partition on the same external hd with Ubuntu 11.04 using drivers from the xorg-edgers ppa and it boots with no problem. I have tried replacing xorg-edgers with your ppa on this install (purge xorg-edgers, add the Oibaf ppa and update and upgrade) before but I had the same problem in booting, removing oibaf and reinstalling xorg-edgers and booting problem disappeared.

          I thought the problem might have been due to some conflicting libraries left over from xorg-edgers or other ppas so I made a fresh install of Ubuntu 11.04 on a different partition and then upgrade with your ppa but still no luck (it boots into the gui desktop successfully if I purge oibaf from recovery mode and reboot) I have been keeping up on updating (from recovery mode) so I have the latest drivers from your ppa.

          Thanks in advance for any advice.
          Do you see something relevant in /var/log/Xorg.0.log* or in dmesg when the system doesn't start?

          Comment


          • #95
            Originally posted by oibaf View Post
            Do you see something relevant in /var/log/Xorg.0.log* or in dmesg when the system doesn't start?
            Hi, maybe I don't know what to look at, I didn't find anything informative from dmesg or the log. In the log the last line was unloadmodule vesa, maybe that shouldn't be happening? It also complained that it couldn't find the Nvidia module and the "nv" module but I suppose that was normal (since they have not been installed)

            Just updated from the recovery mode, still no graphic.

            Comment


            • #96
              Can you paste these files at http://paste.ubuntu.com/

              Comment


              • #97
                Recent Updates

                Mesa:
                • the following drivers were officially removed from mesa and hence from my PPA package: i810, mga, r128, savage, sis, tdfx, unichrome
                • classic swrast, r300, r600 moved to libgl1-mesa-dri-experimental package (still installed in /usr/lib/dri-alternates)
                • added r300g ROUND v2 patch. Tested with PP filters here

                Comment


                • #98
                  Originally posted by oibaf View Post
                  Can you paste these files at http://paste.ubuntu.com/
                  I don't know how to. I can only access recovery mode.

                  Comment


                  • #99
                    Originally posted by oibaf View Post
                    Can you paste these files at http://paste.ubuntu.com/

                    Hi, just cut and paste Xorg.0.log1 to the URL above. Just have to connect the drive to another Ubuntu install and fish out the log, should have thought of it before.

                    Thanks.

                    Comment


                    • in the first post you mentioned frozenbyte games support, but those games still wont work with those drivers enabled. trine wont start and shadowgrounds is unbearable slow..... is it broken again? (radeon 3850)

                      Comment

                      Working...
                      X