Announcement

Collapse
No announcement yet.

Gallium3D / LLVMpipe With LLVM 2.8

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Starcraft or Starcraft 2?

    The former should work everywhere. The latter works e.g. with the R300 Gallium3D driver (r300g) to some extent. No idea about the other drivers. We got 2 bug reports against r300g running Starcraft 2 and we have fixed both.

    https://bugs.freedesktop.org/show_bug.cgi?id=29363
    https://bugs.freedesktop.org/show_bug.cgi?id=30337

    Comment


    • #62
      to have smooth SC 1 i need to use FGLRX + change from GDI to OPENGL in wine setting, both works slow on opendrivers:<

      SC 2 doesent even work, on both drivers

      i have radeon 4850 [r700]

      i really want to get rid of close source drivers :<

      Comment


      • #63
        Originally posted by marek View Post
        Mesa must be compiled with the parameter --enable-gallium-llvm to get the LLVM-compiled vertex shaders in Gallium.

        llvmpipe is definitely slower (about 10 times) unless you do a lot of data moves between RAM and VRAM.
        I checkout mesa repository, and configure/compile it:

        git clone git://anongit.freedesktop.org/git/mesa/mesa
        cd mesa
        ./autogen.sh
        ./configure --enable-glx-tls --with-dri-drivers= --enable-gallium-llvm --disable-gallium-nouveau --disable-gallium-i915 --disable-gallium-i965 --enable-gallium-radeon --enable-gallium-r600 --disable-gallium-svga --with-state-trackers=glx,dri
        make -j 2

        then I copied various libs from the ./mesa/lib/gallium overwriting the system lib. Restart the computer and run xbmc again. Only a very marginal improvement, 16-18fps over r300g 5 months ago. Maybe, r300g llvm usage for vertex shader is not included in the main mesa tree?

        Comment


        • #64
          Originally posted by ntt2010 View Post
          I checkout mesa repository, and configure/compile it:

          git clone git://anongit.freedesktop.org/git/mesa/mesa
          cd mesa
          ./autogen.sh
          ./configure --enable-glx-tls --with-dri-drivers= --enable-gallium-llvm --disable-gallium-nouveau --disable-gallium-i915 --disable-gallium-i965 --enable-gallium-radeon --enable-gallium-r600 --disable-gallium-svga --with-state-trackers=glx,dri
          make -j 2

          then I copied various libs from the ./mesa/lib/gallium overwriting the system lib. Restart the computer and run xbmc again. Only a very marginal improvement, 16-18fps over r300g 5 months ago. Maybe, r300g llvm usage for vertex shader is not included in the main mesa tree?
          I meant I got 16-18fps instead of 15fps (5 months ago, before llvm vertex shader was included). I remember with the old fglrx, I used to get 90fps.

          Comment


          • #65
            FWIW I don't think you need --enable-gallium-r600. It won't cause any problems, but you'll probably build faster and have fewer chances of picking up the wrong file if you omit it.

            Comment

            Working...
            X