Announcement

Collapse
No announcement yet.

Open-Source GPU Drivers Causing Headaches In KDE 4.5

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Martin touched briefly on the topics discussed here (points 9, 10) and covered some but not all of the core issues :

    - as a result of delays between introduction of DX standards and corresponding GL standards there are a lot of cards out there which "almost but not quite" meet GL 2.x requirements... put differently it means that the granularity of GL extensions doesn't align particularly well with the granularity of HW capabilities, particularly in the area of GL 2-ish HW (GL standard introduction has caught up as of GL4 so things should be better going forward)

    - combine the first point with the fact that GL2 development is happening right now, and you are likely to get cases where extensions are enabled but not fully implemented (and is subject to regressions)... partly because of the granularity issue and partly because the GL 2 support is work-in-process

    - the current (mostly temporary) situation argues for a bit more user/distro controllability of driver feature usage and maybe a bit less automatic extension-based configuration, simply because the extention reporting is *not* likely to be a reliable source of input in the short term

    Otherwise looked like a real good post. Sounds like part of the problem comes from the fact that the distro Martin is using doesn't include driver support for his r700 hardware... fixing that seems like the "low hanging fruit" here. Anyways, this is one of those "everyone is working real hard, pointing fingers wastes everyone's time, but probably some slight tweak in direction/approach is required to make everything work happy" situations.

    I HATE HATE HATE HATE HATE HATE HATE HATE that edit time limit. Just in case anyone didn't know that already.

    Comment


    • Okay well I just tried installed kde 4.5.1 (kubuntu maverick) with the latest radeon driver stack from xorg edgers. So far compositing works when disabling blur, but 2d performance is very sluggish?

      Anyone else experience this? I would love to stay with kde, if just I can make 2d perform better.

      Comment


      • Now I have installed ubuntu-desktop also, and the 2d performance is a world to difference.

        The 2d performance in gnome is much much more fluid, than it is in kde.

        Does anyone have a clue why that can be? The 2d performance without compositing is also better in gnome, than it is in kde.

        Comment


        • Originally posted by tball View Post
          Okay well I just tried installed kde 4.5.1 (kubuntu maverick) with the latest radeon driver stack from xorg edgers. So far compositing works when disabling blur, but 2d performance is very sluggish?

          Anyone else experience this? I would love to stay with kde, if just I can make 2d perform better.
          Hi there.
          What video adapter do you have? ( sorry if you already said that before )

          My Output of: glxinfo |grep -i opengl
          OpenGL vendor string: X.Org R300 Project
          OpenGL renderer string: Gallium 0.4 on RV410
          OpenGL version string: 2.1 Mesa 7.9-devel
          OpenGL shading language version string: 1.20
          OpenGL extensions:

          I'm on vacations and briefly use the laptop except to check from updates in Lucid Maverick and check my email. Since a few days even the taskbar thumbnails started to work, don't rebember exactly when but they do work now.
          As for the 2d perfomance, everything is fast.
          Can you check that with the recent xorg/edgers updates?

          Comment


          • Originally posted by tball View Post
            Okay well I just tried installed kde 4.5.1 (kubuntu maverick) with the latest radeon driver stack from xorg edgers. So far compositing works when disabling blur, but 2d performance is very sluggish?

            Anyone else experience this? I would love to stay with kde, if just I can make 2d perform better.
            I have found a work-around.

            http://kubuntuguide.org/Lucid#Kwin
            Compiz Fusion

            Compiz Fusion is also available as a separate Windows Manager to allow 3D desktop effects such as the rotating cube desktop. Some Kubuntu users choose to run Compiz instead of KWin. Install:

            sudo apt-get install compiz compizconfig-settings-manager compiz-kde compiz-fusion-plugins-main compiz-fusion-plugins-extra emerald librsvg2-common

            To change to Compiz as the Window Manager:

            K menu -> System Settings -> Advanced -> Session Manager -> Window Manager -> Compiz

            Note: You must logout and log back in for the change to take effect.

            Select Compiz Configuration:

            K menu -> Settings -> CompizConfig Settings Manager

            Fusion Icon

            Fusion Icon is a tray icon that allows you to easily switch between window managers (such as between KWin and Compiz), window decorators, and gives you quick access to the Settings Manager. This allows quick toggling of 3-D desktop effects (that may not be compatible with some applications).

            sudo apt-get install fusion-icon

            Start:
            K menu -> System -> Compiz Fusion Icon

            You can then easily access CompizConfig Settings Manager from the icon.
            Rotate the Compiz Cube

            Set the CompizConfig Settings Manager to enable the "Desktop Cube" and "Rotate Cube" and "Viewport Switching" options. Click on the icon for each to customize settings. For example, to change the appearance of the cube, click on the Desktop Cube icon to access its settings. You can set the hotkey buttons for rotating the cube in the "Viewport Switching" settings. Otherwise, hold down the Ctrl+Alt+Left mouse button and drag the mouse (or touchpad) the direction you want to rotate the cube.

            Remember, the cube rotates between desktops. It's not a cube unless you have at least 4 desktops running. You will not get a cube if you are only using 2 desktops (you will get a "plate"). You can still rotate the sides of the plate, of course, but it will not be a cube. (Recent users from the Windows OS may have no experience with the concept of simultaneous desktops, but they are nice once you learn how to use them).

            When running Compiz fusion as the Windows Manager, you must change the default number of desktops from within CompizConfig Settings Manger. To enable 4 desktops:

            K menu -> System -> CompizConfig Settings Manager -> General -> General Options -> Desktop -> Horizontal Virtual Size -> 4

            When you start an application, you can assign it to any one of the 4 desktops by right-clicking the upper left corner of the application window and choosing the "To Desktop..." option. Rotating the cube shows the different desktops. You can also go to a desktop using the taskbar icon which shows the 4 desktops.

            Emerald

            Emerald is the theme engine for Compiz Fusion. Multiple themes are available from KDE Look, some of which are used in KWin as well. Oxygen, a default theme in Kubuntu, is an Emerald theme, for example. (These themes originated from the Beryl project before it merged with Compiz to form Compiz Fusion.) The Emerald Theme Manager for Compiz Fusion can be installed:

            sudo apt-get install emerald
            Should work for maverick also.

            Comment


            • Originally posted by tball View Post
              Now I have installed ubuntu-desktop also, and the 2d performance is a world to difference.

              The 2d performance in gnome is much much more fluid, than it is in kde.

              Does anyone have a clue why that can be? The 2d performance without compositing is also better in gnome, than it is in kde.
              Apart from Kwin disabling compositing, absolutely no problem with maverick KDE using the as-delivered open source drivers here. One solution is to use compiz for KDE rather than Kwin.

              Apparently the Kwin developer does not do extensive hardware checking, and the driver he was using for his R700 ATI card on his distribution didn't work, so he has disabled Kwin compositing for everyone using the open source R600c driver.

              Another work-around for Kubuntu maverick:

              Code:
              Workaround - not a fix
              Using the force - don't worry, be happy settings
              
              Editing the ~/kde/share/config/kwinrc.
              
              Before:
              Code:
              
              ...
              DisableChecks=false
              ...
              OpenGLIsUnsafe=true
              
              
              After:
              Code:
              
              ...
              DisableChecks=true
              ...
              OpenGLIsUnsafe=false
              ...
              
              
              Konsole:
              Code:
              
              LIBGL_ALWAYS_INDIRECT=1 kwin --replace
              
              
              The desktop effects are working...

              Comment


              • Originally posted by hal2k1 View Post
                Apart from Kwin disabling compositing, absolutely no problem with maverick KDE using the as-delivered open source drivers here. One solution is to use compiz for KDE rather than Kwin.

                Apparently the Kwin developer does not do extensive hardware checking, and the driver he was using for his R700 ATI card on his distribution didn't work, so he has disabled Kwin compositing for everyone using the open source R600c driver.

                Another work-around for Kubuntu maverick:

                Code:
                Workaround - not a fix
                Using the force - don't worry, be happy settings
                
                Editing the ~/kde/share/config/kwinrc.
                
                Before:
                Code:
                
                ...
                DisableChecks=false
                ...
                OpenGLIsUnsafe=true
                
                
                After:
                Code:
                
                ...
                DisableChecks=true
                ...
                OpenGLIsUnsafe=false
                ...
                
                
                Konsole:
                Code:
                
                LIBGL_ALWAYS_INDIRECT=1 kwin --replace
                
                
                The desktop effects are working...
                Thx for your reply. Well my compositing works in kde, but I just think they are slower than compiz. But thx for the guide changing the default compositor to compiz.

                Comment


                • I tried kde 4.5.1 yesterday and everything works with radeon gallium, including blur. But compositing is slow, especially when scrolling documents. On the other hand, Compiz is almost as fast as no compositing, i.e. really fast. The problem is that Compiz is a neat tech demo, but not so good a window manager, definitely not comparable to kwin. Also, there's some kind of simplicity and good taste in kwin's effects that Compiz lacks. I guess KDE people need to work on the performance side of things...

                  Comment


                  • I got bitten by this last night, and it is worse than I expected. It's not just the blur plugin that's affected, and my drivers got blacklisted (for unknown reasons!) and I could not re-enable OpenGL compositing, while getting no error messages.

                    After deleting KWin config files and reconfiguring, everything worked. Including Blur. However, each change of settings crashes KWin, which is a known issue.

                    Looks like drivers get blacklisted way too quickly, and it is an annoyance. I do wish better communication between the KWin team and the Mesa developers in the future. Mistakes were made, it can't continue like this.

                    After setting it up properly, though, KDE 4.5.1 simply rocks. I've never used such a slick, enjoyable and user-friendly desktop anywhere, including Macintosh.

                    Comment

                    Working...
                    X