Announcement

Collapse
No announcement yet.

Intel's GLSL2 Branch Is Merged To Mesa Master

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Thanks for the reply. I tried that but though it allows me to pass the configure stage, it fails with undefined references at compile time.
    I set something like "TALLOC_CFLAGS='-I/usr/include -l/usr/lib64' TALLOC_LIBS='/usr/lib64/libtalloc.so.2'" before the configure command. I guess I'm not doing this right but couldn't find a proper reference in Google and I'm not a compiler expert at all.

    Comment


    • #22
      No, I think that's not quite it. Try using it like TALLOC_CFLAGS="-I/usr/include" TALLOC_LIBS="-L/usr/lib64 -ltalloc" or something along the lines.

      Comment


      • #23
        Note that another option is creating /usr/lib64/pkgconfig/talloc.pl with contents
        Code:
        prefix=/usr
        exec_prefix=/usr
        libdir=/usr/lib64
        includedir=/usr/include
        
        Name: talloc 
        Description: A hierarchical pool based memory system with destructors
        Version: 2.0.1
        Libs: -L${libdir} -ltalloc
        Cflags: -I${includedir} 
        URL: http://talloc.samba.org/
        But that requires maintenance, in theory anyway. Your distro should really just setup a working pkg-config setup.

        Comment


        • #24
          Code above is from Fedora package. Curse the edit window.

          Comment


          • #25
            Thanks, the talloc.pc file worked, though not the trick of passing the ENV variables to configure.
            I'll forward that to the Slack team. They do not give a .pc file yet because talloc is distributed within Samba and obviously used there only. I guess they'll have to adjust.

            Comment

            Working...
            X