Announcement

Collapse
No announcement yet.

Reworking OpenGL ES In Mesa, Gallium3D

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by bridgman View Post
    You don't need it for anything right now AFAIK, but it seems likely that an increasing number of tools and apps will be written to the GL ES 2.0 API rather than a regular GL version. I believe the latest changes to GL ES allow the GL ES and GL APIs to co-exist, which is handy.
    It's semi-required by browsers for the new WebGL API. You can emulate OpenGL ES over OpenGL, although the shading languages are slightly different so it's just a lot easier to have a proper OpenGL ES implementation. The shading language for ES was a little different than regular GLSL, in particular, and I don't think they aligned until GLSL 1.40 or so which Mesa doesn't yet support.

    Comment


    • #12
      Yeah, good point. Some browsers require GL ES for WebGL, others implement it over regular GL, but the trend seems to be towards pushing the work down into the driver stack.

      Comment

      Working...
      X