Announcement

Collapse
No announcement yet.

NVIDIA Releases Updated VDPAU LIbrary

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • NVIDIA Releases Updated VDPAU LIbrary

    Phoronix: NVIDIA Releases Updated VDPAU LIbrary

    NVIDIA on Tuesday released the open-source libvdpau 0.5 library for their Video Decode and Presentation API for Unix...

    http://www.phoronix.com/vr.php?view=MTE3NTg

  • #2
    One fix is to workaround the Flash blob passing color arguments to a function in an incorrect order, which can lead to some Flash videos having a bluish tint.
    Yes!, finally no more bad colored videos on youtube.

    Comment


    • #3
      Originally posted by Thaodan View Post
      Yes!, finally no more bad colored videos on youtube.
      Yes, I suspect that was hurting anyone using the driver from nvidia (myself included). Luckily, when Adobe drops support, they really drop it, they can't be bothered to fix stuff like this

      Comment


      • #4
        I just upgraded to a GTX660 Ti from a HD3870 Radeon. One of the problems I am experiencing is the video layer for flash is drawing not only int he browser but sometimes to the desktop. Not sure if it's a fault with the transparent layer used or problem with clipping/redraw.

        I say the above as maybe this will fix the problem.

        EDIT: "One fix is to workaround the Flash blob passing color arguments to a function in an incorrect order, which can lead to some Flash videos having a bluish tint. The other fix is for colors bleeding through to other windows. Lastly, there's a small memory leak fix when unloading libvdpau. "

        Yes that's the problem... I have also noticed videos playing in smurf mode.

        Comment


        • #5
          Just updated the lib. So far no smurf videos, and the once overlay problem has gone.

          A new issue I've noticed is the video layer isn't very good with scrolling. I see lime green transparent layer late to shift from the once video overlay area when scrolling in firefox.

          Comment


          • #6
            I get the blue videos also with OSS radeon driver on HD4350. What's up with that? I am not sure I even have this vdpau library installed.

            Comment


            • #7
              A nice example how crappy the Flash is. Instead of fixing bug in flash (and it would certainly be a very simple fix), others have to work around Adobe's incompetency.

              Comment


              • #8
                Originally posted by aceman View Post
                I get the blue videos also with OSS radeon driver on HD4350. What's up with that? I am not sure I even have this vdpau library installed.
                See stativ's post above. It's Adobe's bug, Nvidia just worked around it.

                Comment


                • #9
                  These two bugs are awful. Nice to hear they've fixed them. I don't understand why the author is not excited - life on Linux does get better even when just bugs get fixed.

                  By the way, I can't log into phoronix with Konqueror... only with Firefox; I guess another bug I'm going to be excited when it gets fixed

                  Comment


                  • #10
                    Originally posted by aceman View Post
                    I get the blue videos also with OSS radeon driver on HD4350. What's up with that?
                    For gentoo libvdpau is a mesa dependency if you want to use radeon + vdpau. So yes: The flash bug should be fixed for the free radeon driver, too.

                    Comment

                    Working...
                    X