Announcement

Collapse
No announcement yet.

Nouveau NVD0-Fermi Is Still A Busted Mess

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Nouveau NVD0-Fermi Is Still A Busted Mess

    Phoronix: Nouveau NVD0-Fermi Is Still A Busted Mess

    If after reading about the recent Nouveau DRM improvements, you were hoping the kernel driver updates fixed-up the situation for the Fermi "NVD0" graphics processors, you are sadly mistaken: it is still a busted mess.

    http://www.phoronix.com/vr.php?view=16856

  • #2
    WTF did you expect to happen when you overrode the acceleration disable? I don't disable acceleration by default for the fun of it you know, there's *always* a good reason. Testing it anyway when it's known broken and reporting is a waste of time!

    Comment


    • #3
      Jesus MIchael, you are getting more retarded with every article,

      you forced on known broken acceleration and then wrote an article about it being broken?

      wow Pulitzer winning material there.

      (not sure what the Pulitzer equivalent for click journalists is).

      Comment


      • #4
        Phoronix Tabloid Blog - still a busted mess

        Comment


        • #5
          Ok, no idea how this double post happened... sorry.
          Last edited by Serafean; 12-21-2011, 07:09 AM. Reason: double post

          Comment


          • #6
            Seriously? Reporting that an OSS driver written entirely through reverse-engineering doesn't work on hardware it doesn't even advertise as supported... Nice way to discourage the developers. If it was the official driver recommended for use by the hardware manufacturer or even most distros then maybe this post would've made some sense; but this is just... I don't know what it is. (Low does come to mind)
            Didn't anything happen today to warrant an article?

            PS : now thanks to this article it's virtually impossible to search for NVD0 and nouveau using google for useful information.

            To the nouveau devs : Keep on rocking! Thanks to you XBMC doesn't crash (binary blob makes it crash).

            Comment


            • #7
              Originally posted by Serafean View Post
              Seriously? Reporting that an OSS driver written entirely through reverse-engineering doesn't work on hardware it doesn't even advertise as supported... Nice way to discourage the developers. If it was the official driver recommended for use by the hardware manufacturer or even most distros then maybe this post would've made some sense; but this is just... I don't know what it is. (Low does come to mind)
              Didn't anything happen today to warrant an article?

              PS : now thanks to this article it's virtually impossible to search for NVD0 and nouveau using google for useful information.

              To the nouveau devs : Keep on rocking! Thanks to you XBMC doesn't crash (binary blob makes it crash).
              What would you like to know? I've written all the code to support GF119 (what we call "NVD9" due to how the card reports itself to us) thus far. Currently the status is: it should work just as well as other fermi chips - except for acceleration (which can probably work if you know which hoops to jump through), and DisplayPort (which i have no hw to implement it).

              Comment


              • #8
                What would you like to know? I've written all the code to support GF119 (what we call "NVD9" due to how the card reports itself to us) thus far. Currently the status is: it should work just as well as other fermi chips - except for acceleration (which can probably work if you know which hoops to jump through), and DisplayPort (which i have no hw to implement it).
                Actually this is more or less what I wanted to find. I simply didn't want to to post shouting "FUD!" without backing it up by some status data
                Thanks!

                Comment


                • #9
                  Yea, I think it needs to be made clear that the reason the driver works so poorly is entirely nvidia's fault...

                  No open source drivers + No support for nVidia Optimus on Linux.. Looks like nvidia is 0 and 2 in my book, at this point.

                  Comment

                  Working...
                  X