Announcement

Collapse
No announcement yet.

Nouveau Interface Breaks, Updates Needed

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Nouveau Interface Breaks, Updates Needed

    Phoronix: Nouveau Interface Breaks, Updates Needed

    While Nouveau's initial DRM (Direct Rendering Manager) code has landed in the Linux 2.6.33 kernel, changes made today to the Nouveau driver stack will cause grief for some users. The Nouveau user-space driver code will now not work with the DRM found in the Linux 2.6.33 kernel, which isn't even officially released yet but will be in a week or two. The user-space driver interface for the Nouveau driver has been changed (with a version bump to 0.0.16)...

    http://www.phoronix.com/vr.php?view=Nzk4Nw

  • #2
    Ok so if I am understanding this correctly... an development version of an experimental driver architecture that splits the driver into two parts, is currently not working for endusers that like to run an unstable version of a development release of an OS kernel...

    Seriously Phoronix... I realy like the fact that you report on the development of graphics drivers on unix like operating systems in detail, but this has got to be the biggest non news ever....

    Comment


    • #3
      Originally posted by V!NCENT View Post
      Ok so if I am understanding this correctly... an development version of an experimental driver architecture that splits the driver into two parts, is currently not working for endusers that like to run an unstable version of a development release of an OS kernel...

      Seriously Phoronix... I realy like the fact that you report on the development of graphics drivers on unix like operating systems in detail, but this has got to be the biggest non news ever....
      I'm sorry but I don't agree with your post. There is nothing wrong with this news. There are important news, and less important ones. If you want only important ones then 60% of phoronix news wouldn't exist simply because there isn't something to talk about it.

      I like phoronix in all its aspects.

      Comment


      • #4
        some news weeks are better than others. We can only hope that next week will 1up the previous.

        Comment


        • #5
          These things do happen from time to time, and they're easy to deal with *if* everyone knows about them. This seems news-worthy to me...

          Comment


          • #6
            And this is on the eve of Gallium3D-Nouveau benchmarks coming out in the morning...
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              Hey, it's better than fglrx news

              Comment


              • #8
                This is definitely a worthy headsup for Nouveau aficionados, as when interfaces break with DRM code updates then many people will be pissy when the driver behaves badly as a result of the update

                Comment


                • #9
                  Thanks!

                  Hm, I think that this news is important in several ways:

                  1) Everyone using GIT and reading this site should know that updating becomes useless - as there is currently (except the nouveau/linux-2.6 kernel which is based upon 2.6.32 [and since 2.6.32 no further updates except the nouveau patches afaik]) no supported kernel

                  2) The drm interface change is a big step - but it was too early in my opinion for benchmarking. I don't know if and how it affects NVIDIA, but raising the maximum pushbuffer from 64 to 512 is imho a big step...

                  3) Out of 2, I'm very curious what's happening in 2.6.34 - Ben Skeggs is working for Fedora, hm... I think Fedora 13 will be bug-squashing and testing out, maybe Fedora 14 and 2.6.34 will be already much faster than before... I think this isn't too unrealistic - the mass of mesa commits and the fact that there is a solid foundation [in the driver] is an good sign imho ^^

                  I'll hope that there are more good news too come - but benchmarking this driver is imho at least one kernel release too early.

                  Comment


                  • #10
                    Basically it is more important that old cards which would require older drivers at least work with compiz & co. Some legacy drivers do not work with 2.6.32 correctly, 2.6.28 works however. The same card on other board can work with a newer kernel however. Testing new cards where the driver support is best might be interesting for benchmarking, but basically it would be stupid not to use the binary driver which would provide even vdpau on the tested cards. If your card is so old that it only runs with 71.xx then you certainly will have got more fun with it now.

                    Comment

                    Working...
                    X