Announcement

Collapse
No announcement yet.

Double buffering fail on r500 dri

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by towo2099 View Post
    This is not true.
    The actual version of xserver-xorg-core in experimental is
    2:1.4.99.906-2 and work without problem with mesa 7.1 final.
    Indeed, I just checked on this site and it says 2:1.4.99.906-2 as the newest version.

    But, I can not get this package! Only 2:1.4.99.906-1.

    Would you mind to share your experimental repositories with us?

    Thanks for reading.

    Comment


    • #17
      Nevermind, I just noticed that there is no 2:1.4.99.906-2 package to amd64 SID.

      Architecture Version Package Size Installed Size Files

      amd64 2:1.4.99.906-1 2,541.9 kB 5624 kB no current information

      i386 2:1.4.99.906-2 2,374.2 kB 5036 kB no current information

      link
      Last edited by hobbes; 09-02-2008, 03:16 PM. Reason: URL

      Comment


      • #18
        On R500 use the radeon (git master), NOT the radeonhd driver.

        Comment


        • #19
          Originally posted by RealNC View Post
          On R500 use the radeon (git master), NOT the radeonhd driver.
          I Just did that and also git clone Mesa/drm but the problem persists.

          $glxinfo | egrep direct
          direct rendering: Yes

          $glxinfo | egrep OpenGL
          OpenGL vendor string: DRI R300 Project
          OpenGL renderer string: Mesa DRI R300 20060815 AGP 8x TCL
          OpenGL version string: 1.3 Mesa 7.1

          $egrep "(EE)" /var/log/Xorg.0.log
          (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
          (II) Loading extension MIT-SCREEN-SAVER

          _ _ _ _ _

          Xorg.0.log:

          X.Org X Server 1.4.99.906 (1.5.0 RC 6)
          Release Date:
          X Protocol Version 11, Revision 0
          Build Operating System: Linux 2.6.17.7 x86_64 Debian
          Current Operating System: Linux debian-desktop 2.6.26-1-amd64 #1 SMP Thu Aug 28 11:13:42 UTC 2008 x86_64
          Build Date: 27 July 2008 11:54:00PM

          more info: http://pastebin.com/m6f3a915
          _________
          $ dmesg | grep drm
          [ 88.324998] [drm] Initialized drm 1.1.0 20060810
          [ 88.333001] [drm] Initialized radeon 1.29.0 20080613 on minor 0
          [ 88.792977] [drm] Setting GART location based on new memory map
          [ 88.793007] [drm] Loading R500 Microcode
          [ 88.793049] [drm] Num pipes: 1
          [ 88.793060] [drm] writeback test succeeded in 2 usecs

          $glxgears
          Error: couldn't get an RGB, Double-buffered visual


          Any thoughts would be appreciated.
          Last edited by hobbes; 09-02-2008, 09:29 PM. Reason: added dmesg output

          Comment


          • #20
            Just an update.

            xserver-xorg-core 2:1.4.99.906-2 AMD64 hit the experimental repositories today.

            Problem solved.

            Thanks for reading.

            Comment

            Working...
            X