Announcement

Collapse
No announcement yet.

need help with ati driver and xrandr dual head setup

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • need help with ati driver and xrandr dual head setup

    Hello Folks,

    I'm new at configuring Linux so please have some patience with me. I'm trying to set up a dual head display with one desktop stretched out on both screens. I have an ATI X800 and due to recommendations from this guide https://help.ubuntu.com/community/RadeonDriver I'm trying to achieve this with the open source ati driver and xrandr.

    It's actually sort of working, I do have the desktop stretched out over both screens and I can drag windows from one screen to another. The thing is that on the right side of the right screen these is a wide stripe, that doesn't show the desktop backgroud, but rather some kind of "shadows" of the windows being dragged over it. Can anyone please help me a bit?

    Here is my xorg.conf

    Code:
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"de"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    	Driver          "ati"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    	HorizSync	39.0 - 69.0
    	VertRefresh	59.0 - 61.0
    	Option		"DPMS"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    	DefaultDepth	24
            SubSection "Display"
                    Depth	24
                    Modes	"1280x1024"
    		Virtual	2560 1024 
            EndSubSection
    EndSection
    
    Section "DRI"
            Mode 0666
    EndSection
    
    Section "ServerLayout"
    	Option		"AIGLX" "true"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    EndSection

    The output of xrandr -q:
    Code:
    Screen 0: minimum 320 x 200, current 2560 x 1024, maximum 2560 x 1024
    VGA-0 connected 1280x1024+1280+0 (normal left inverted right x axis y axis) 0mm x 0mm
       1600x1024      60.0  
       1280x1024      59.9*    60.0  
       1440x900       60.2  
       1280x960       60.0  
       1280x800       60.0  
       1280x768       60.0  
       1024x768       60.0  
    S-video disconnected (normal left inverted right x axis y axis)
    DVI-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 376mm x 301mm
       1280x1024      60.0*+   75.0     59.9  
       1152x864       75.0  
       1024x768       74.9     75.1     60.0  
       832x624        74.6  
       800x600        75.0     74.9     60.3  
       640x480        75.0     74.8     60.0  
       720x400        70.1

    And what I did to switch the dual screen desktop on was:

    Code:
    xrandr --output DVI-0 --left-of VGA-0

    Thanks
    Cruz

  • #2
    Originally posted by Cruz View Post
    It's actually sort of working, I do have the desktop stretched out over both screens and I can drag windows from one screen to another. The thing is that on the right side of the right screen these is a wide stripe, that doesn't show the desktop backgroud, but rather some kind of "shadows" of the windows being dragged over it. Can anyone please help me a bit?
    Can you pastebin your xorg log and post a picture of the problem?

    Comment


    • #3
      Are you using compiz at the time? That card has a maximum 3D texture size of 2048, which means that any texture larger than 2048x2048 (such as your wallpaper image at 2560x1024) will not display properly paste the 2048th pixel.

      You could try disabling gnome/xfce/kde from drawing the wallpaper and simply let compiz draw it's own. Then you wouldn't see this problem.

      Adam

      Comment


      • #4
        I can't reproduce the same error anymore and I'm getting inconsistent results with every reboot. Sometimes both screens are showing either only the left half or only the right half of the desktop, depending if I use the --right-of or the --left-of option. Sometimes one of the screens shows both halves of the desktop squeezed down to a width of 1280 pixels. Sometimes my mouse doesn't get recognized. All this with the same configuration.

        Then I used Gnome's System -> Preferences -> Screen Resolution and unchecked the "Clone Screens" options there and aligned the two screens next to each other. Right now the whole thing works without the graphical error I described in my OP, the desktop background tiles nicely. But now I can't enable the Visual Effects in System -> Preferences -> Appearance.

        I feel so lost in this. I don't know if I'm using compiz, how can I find it out? And well, here is my xorg log marcell.missura.de/Xorg.0.log

        Comment


        • #5
          If you start compiz before you extend your screen to the second monitor, you should not get any error messages when trying to start it. If you extend your screen first, and then try to start compiz, you will get an error.

          If you want to see if you are currently using compiz, you can bring up a terminal and run 'ps ax | grep compiz'. That will show you the compiz process, if it's running.

          Comment


          • #6
            Here's my "radeon" open source driver dual monitor config, static with xorg.conf:

            # Xorg configuration created by pyxf86config

            Section "ServerLayout"
            Identifier "Default Layout"
            Screen 0 "Screen0" 0 0
            InputDevice "Keyboard0" "CoreKeyboard"
            EndSection

            Section "InputDevice"
            # keyboard added by rhpxl
            Identifier "Keyboard0"
            Driver "kbd"
            Option "XkbModel" "pc105"
            Option "XkbLayout" "us"
            EndSection

            Section "Monitor"
            Identifier "DVI-0"
            Option "PreferredMode" "1280x1024"
            # Option "Left-Of" "VGA-0"
            EndSection

            Section "Monitor"
            Identifier "VGA-0"
            Option "PreferredMode" "1280x1024"
            Option "RightOf" "DVI-0"
            EndSection

            Section "Device"
            Identifier "Videocard0"
            Driver "radeon"
            Option "RROutputOrder" "DVI-0"
            EndSection

            Section "Screen"
            Identifier "Screen0"
            Device "Videocard0"
            Monitor "VGA-0"
            DefaultDepth 24
            SubSection "Display"
            Virtual 2560 1024
            Viewport 0 0
            Depth 24
            Modes "1280x1024"
            EndSubSection
            EndSection

            Comment


            • #7
              Thanks a lot for the help so far. The dual head setup is working now, but I still have the problem that compiz won't start:

              Code:
              marcell@miles:~$ compiz
              Checking for Xgl: not present. 
              Detected PCI ID for VGA: 01:00.0 0300: 1002:4a49 (prog-if 00 [VGA controller])
              Checking for texture_from_pixmap: not present. 
              Trying again with indirect rendering:
              Checking for texture_from_pixmap: present. 
              Checking for non power of two support: present. 
              Checking for Composite extension: present. 
              Comparing resolution (2560x1024) to maximum 3D texture size (2048): Failed.
              aborting and using fallback: /usr/bin/metacity
              adamk already pointed out:

              Originally posted by adamk View Post
              That card has a maximum 3D texture size of 2048, which means that any texture larger than 2048x2048 (such as your wallpaper image at 2560x1024) will not display properly
              What can I do about this? I would really like to keep the 1280x1024 resolution on both screens and not go down to 1024x768. Is maybe the xrandr approach not the right one for me?

              Thanks
              Cruz

              Comment


              • #8
                The real approach is: buy a new card

                Comment


                • #9
                  Originally posted by Cruz View Post
                  Thanks a lot for the help so far. The dual head setup is working now, but I still have the problem that compiz won't start:

                  Code:
                  marcell@miles:~$ compiz
                  Checking for Xgl: not present. 
                  Detected PCI ID for VGA: 01:00.0 0300: 1002:4a49 (prog-if 00 [VGA controller])
                  Checking for texture_from_pixmap: not present. 
                  Trying again with indirect rendering:
                  Checking for texture_from_pixmap: present. 
                  Checking for non power of two support: present. 
                  Checking for Composite extension: present. 
                  Comparing resolution (2560x1024) to maximum 3D texture size (2048): Failed.
                  aborting and using fallback: /usr/bin/metacity
                  adamk already pointed out:



                  What can I do about this? I would really like to keep the 1280x1024 resolution on both screens and not go down to 1024x768. Is maybe the xrandr approach not the right one for me?

                  Thanks
                  Cruz
                  xrandr is the *only* approach. And, even if there were others, you're still going to hit that hardware limit.

                  As a workaround, you could run two monitors in a virtual vertical setup, with one above or below the other. If they are both 1280x1024, that would give you a total of 1280x2048, which is within the limits of the video card.

                  Another option is to simply bypass that check by running this command: 'mkdir -p ~/.config/compiz; echo SKIP_CHECKS=yes >> ~/.config/compiz/compiz-manager'

                  However, your wallpaper beyond the 2048th pixel will be corrupted, and any windows past that point will leave a neat looking trail, just as you described in your first post. Disabling gnome from drawing it's own desktop, and using compiz to draw the wallpaper, will improve things a little. You can do that via gconf-editor --> apps/nautilus/preferences, disable "show_desktop".

                  Adam

                  Comment


                  • #10
                    Why is xrandr the only approach? In this guide https://help.ubuntu.com/community/RadeonDriver there are two alternative approaches explained, MergedFB and Xinerama. It must be possible to circumvent the hardware limit somehow, since the dual screen works perfectly on Win XP.

                    Comment


                    • #11
                      Originally posted by Cruz View Post
                      Why is xrandr the only approach? In this guide https://help.ubuntu.com/community/RadeonDriver there are two alternative approaches explained, MergedFB and Xinerama. It must be possible to circumvent the hardware limit somehow, since the dual screen works perfectly on Win XP.
                      MergedFB has been replaced by xrandr. The radeon driver does not support 3D acceleration at the same time as xinerama. Again, xrandr is the only approach.

                      The windows drivers may tile textures in a way that is not possible with the radeon driver, or the XP compositor may do the tiling.

                      Adam

                      Comment

                      Working...
                      X