Announcement

Collapse
No announcement yet.

Problem with google earth and opengl apps with x1650 PRO

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with google earth and opengl apps with x1650 PRO

    After installing the latest (git) ati open source driver I got compiz and vlc to work very nicely.


    However, I have a problem with googleearth and other opengl applications.
    With googleearth if I click on the "world" to drag it I get a flash. Same happens with other apps. If I click on one of the photos icons in the googleearth the window that opens with the photo is flicking back and forth and sometimes I get it stable so I can see it other times it just disappears. If I drag the googleearth window the part of the window that shows the earth is stuck in the same place like it is in the background and not really part of the window. If I drag the vlc window this doesn't happen.

    Do I need to tweak my xorg.conf to solve this or is it a bug in the ati driver?

  • #2
    If you are using compiz at the same time as these opengl applications, this is a known issue with Xorg's direct rendering infrastructure. It should be resolved with DRI2. Only intel has DRI2 drivers at the moment, and they are in the testing stages.

    If the windows are fullscreen, and you enable the "unredirect fullscreen windows" option in ccsm, this might be less of an issue.

    Adam

    Comment


    • #3
      Originally posted by adamk View Post
      If you are using compiz at the same time as these opengl applications, this is a known issue with Xorg's direct rendering infrastructure. It should be resolved with DRI2. Only intel has DRI2 drivers at the moment, and they are in the testing stages.

      If the windows are fullscreen, and you enable the "unredirect fullscreen windows" option in ccsm, this might be less of an issue.

      Adam
      I see. When I tested now without Compiz I don't have this problem... Maybe running fullscreen is a compromise. Must check it out. If not I'll guess I'll remove the eycandy (compiz)...

      Thanks!

      Comment

      Working...
      X