Announcement

Collapse
No announcement yet.

Radeon x550/x700 Dri with radeon driver?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by marq View Post
    dmesg | grep drm :


    Initialised drm but nothing about radeon

    cat /var/log/Xorg.0.log | grep -i "direct rendering"


    Also:

    Then obviously you don't have recent enough radeon kernel module triple check that you installed radeon compiled from git in the proper directory you need to see the line i did give.

    Comment


    • #17
      OK, I'm using the standard versions that come with Ubuntu Hardy x86_64.
      I guess I will need to build to see if I can get DRI going.
      I found some instructions at:

      http://dri.freedesktop.org/wiki/Building

      I'll attempt and report back.
      Thanks a lot for all the help diagnosing this.

      Comment


      • #18
        So I guess X is detecting the right chip, though the text is wrong (should be R410) but the drm modules don't seem to think my card is supported.
        i think it was fixed in git yesterday.

        somebody did a typo in pciids.

        http://gitweb.freedesktop.org/?p=mes...fcc2e76db3492e

        http://gitweb.freedesktop.org/?p=xor...d3851f5fb21ca3

        Comment


        • #19
          The guide suggests that to use the latest DRM modules I should have Xserver 1.5. My Xorg log is reporting version 1.4.0.90. I was hoping I wouldn't have to touch the other parts of Xorg. It seems like a full upgrade from xorg 7.3 to xorg 7.4 will be needed.

          Comment


          • #20
            I'm pretty sure you need the new X server in order to get AIGLX, which you'll want for Compiz. I thought it was mesa not drm which had the X server dependency but not 100% sure.

            Alex (agd5f) mentioned a while back that it should be pretty easy to patch the files which were modified to support 5xx back into an earlier version of mesa which does not require the latest X server -- I'll check next week and see if this is the case. If so, will see if we can either post instructions or an actual patch.

            Comment


            • #21
              Well, I tried rebuilding the dri and drm modules only, using source from git. Everything compiled without error.
              [http://dri.freedesktop.org/wiki/Building]

              Even if the whole stack didn't work, I expected that I'd now see radeon initialised in dmesg. No such luck. I did get a couldn't find RGB visual from glxinfo but I doubt that's an improvement!

              Realistically, it's probably beyond me right now since I'm pretty new to linux (though used FreeBSD for a while). Still, I might as well try to build xorg 7.4 while I'm on a roll screwing things up!

              Comment


              • #22
                I tried the stick topic here with info on how to update using .deb packages and made some progress.

                Now I get:

                dmesg | grep drm
                [ 40.559264] [drm] Initialized drm 1.1.0 20060810
                [ 40.567352] [drm] Initialized radeon 1.29.0 20080613 on minor 0
                [ 43.070095] [drm] Setting GART location based on new memory map
                [ 43.070962] [drm] Loading R400 Microcode
                [ 43.070997] [drm] Num pipes: 2
                [ 43.071004] [drm] writeback test succeeded in 1 usecs
                [ 77.698202] [drm] Num pipes: 2
                [ 182.706096] [drm] Loading R400 Microcode
                [ 182.706123] [drm] Num pipes: 2
                [ 187.520228] [drm] Num pipes: 2
                [ 191.120150] [drm] Setting GART location based on new memory map
                [ 191.121018] [drm] Loading R400 Microcode
                [ 191.121049] [drm] Num pipes: 2
                [ 191.121054] [drm] writeback test succeeded in 1 usecs
                [ 217.301150] [drm] Num pipes: 2
                [ 501.957824] [drm] Loading R400 Microcode
                [ 501.957851] [drm] Num pipes: 2
                [ 504.207978] [drm] Num pipes: 2
                [ 507.800241] [drm] Setting GART location based on new memory map
                [ 507.801111] [drm] Loading R400 Microcode
                [ 507.801146] [drm] Num pipes: 2
                [ 507.801153] [drm] writeback test succeeded in 1 usecs
                [ 544.001440] [drm] Num pipes: 2
                [ 547.574397] [drm] Setting GART location based on new memory map
                [ 547.575280] [drm] Loading R400 Microcode
                [ 547.575315] [drm] Num pipes: 2
                [ 547.575321] [drm] writeback test succeeded in 1 usecs
                [ 556.968699] [drm] Num pipes: 2
                [ 673.965856] [drm] Setting GART location based on new memory map
                [ 673.966697] [drm] Loading R400 Microcode
                [ 673.966729] [drm] Num pipes: 2
                [ 673.966734] [drm] writeback test succeeded in 1 usecs
                [ 688.377301] [drm] Num pipes: 2
                [ 732.747416] [drm] Setting GART location based on new memory map
                [ 732.748275] [drm] Loading R400 Microcode
                [ 732.748310] [drm] Num pipes: 2
                [ 732.748317] [drm] writeback test succeeded in 1 usecs
                [ 748.031854] [drm] Num pipes: 2
                [ 751.603312] [drm] Setting GART location based on new memory map
                [ 751.604176] [drm] Loading R400 Microcode
                [ 751.604212] [drm] Num pipes: 2
                [ 751.604218] [drm] writeback test succeeded in 1 usecs
                [ 756.730460] [drm] Num pipes: 2
                [ 779.326775] [drm] Loading R400 Microcode
                [ 779.326810] [drm] Num pipes: 2
                [ 806.765247] [drm] Num pipes: 2
                [ 944.922487] [drm] Loading R400 Microcode
                [ 944.922514] [drm] Num pipes: 2
                [ 948.024324] [drm] Num pipes: 2


                However, I still think I need to upgrade other components.
                Screen is only white when I try to log in to gnome.
                I temporarily set xorg.conf to use the vesa driver while I sort it out.

                Comment


                • #23
                  Tried the xorg-edgers-live-test script in a live cd environment and DRM worked without further tweaking. This card was definitely not supported in xorg 7.3 as the documentation claimed at the time. Thanks for all the help tracking down the issue.

                  Comment

                  Working...
                  X